VirtualBox

Ticket #8268 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

VM will not boot after upgrading to 4.0

Reported by: yrro Owned by:
Priority: blocker Component: other
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

After upgrading to 4.0.2, and restoring my VM's state, it operated normally for a few seconds before freezing up (no mouse cursor, had to use the magic sysrq B key to reset it).

Now, the vm locks up during boot, after the following is logged:

ahci 0000:00:0d.0: PCI INT A -> Link[LN KA] -> GSI 5 (level, low) -> IRQ 5 ahci: SSS flag set, parallel bus scan disabled ahci 0000:00:0d.0: AHCI 0001.0100 32 slots 2 ports 3 Gbps 0x3 impl SATA mode ahci 0000:00:0d.0: flags: 64bit ncq stag only ccc scsi0 : ahci scsi1 : ahci ata1: SATA max UDMA/133 abar m8192@0xf0806000 port 0xf0806100 irq 5 ata2: SATA max UDMA/133 abar m8192@0xf0806000 port 0xf0806180 irq 5 scsi2 : ata_piix scsi3 : ata_piix ata3: PATA max UDMA/33 cmd 0x1f0 ctl 0x3f6 bmdma 0xd000 irq 14 ata4: PATA max UDMA/33 cmd 0x170 ctl 0x375 bmdma 0xd008 irq 15 ata3.00: ATAPI: VBOX CD-ROM, 1.0, max UDMA/1333 ata3.00: configured for UDMA/33 ata1: SATA link up 3.0 Gbps (SStatus 123 Scontrol 300) ata1.00: ATA-6 VBOX HARDDISK, 1.0, max UDMA/133 ata1.00: 629145600 sectors, multi 128: LBA48 NCQ (depth 31/32) ata1.00: configured for UDMA/133 scsi 0:0:0:0: Direct-Access ATA VBOX HARDDISK 1.0 PQ: 0 ANSI: 5

I now can't start my VM at all!

Host is Windows 7, guest is Linux 2.6.32. (Debian).

Attachments

2Untitled.png Download (98.3 KB) - added by yrro 3 years ago.
screenshot of kernel messages in case i typo'd them
non-no hang leela-2011-02-04-12-09-59.log Download (48.8 KB) - added by yrro 3 years ago.
virtualbox log of initial hang
boot hang leela-2011-02-04-12-14-03.log Download (50.2 KB) - added by yrro 3 years ago.
virtualbox log of hang during subsequent boot
leela-COM1 Download (13.8 KB) - added by yrro 3 years ago.
linux kernel log messages with IO APIC option disabled
leela-COM1.txt Download (18.5 KB) - added by yrro 3 years ago.
linux kernel log messages with IO APIC option enabled

Change History

Changed 3 years ago by yrro

screenshot of kernel messages in case i typo'd them

Changed 3 years ago by yrro

virtualbox log of initial hang

Changed 3 years ago by yrro

virtualbox log of hang during subsequent boot

comment:1 Changed 3 years ago by yrro

Process monitor reveals that VirtualBox is repeatedly opening, reading and then closing VBoxC.dll during the hang. Here's a stack trace.

0	fltmgr.sys	FltReleasePushLock + 0x3e7	0xfffff8800101a027	C:\Windows\system32\drivers\fltmgr.sys
1	fltmgr.sys	FltGetStreamHandleContext + 0x3da	0xfffff8800101c8ca	C:\Windows\system32\drivers\fltmgr.sys
2	fltmgr.sys	FltReadFile + 0x103d3	0xfffff8800103a2a3	C:\Windows\system32\drivers\fltmgr.sys
3	ntoskrnl.exe	SeUnlockSubjectContext + 0x647	0xfffff80002dcb807	C:\Windows\system32\ntoskrnl.exe
4	ntoskrnl.exe	SeQueryInformationToken + 0x20b4	0xfffff80002dc1e84	C:\Windows\system32\ntoskrnl.exe
5	ntoskrnl.exe	ObOpenObjectByName + 0x1cd	0xfffff80002dc6e4d	C:\Windows\system32\ntoskrnl.exe
6	ntoskrnl.exe	SeUnlockSubjectContext + 0x2757	0xfffff80002dcd917	C:\Windows\system32\ntoskrnl.exe
7	ntoskrnl.exe	NtCreateFile + 0x78	0xfffff80002dd7520	C:\Windows\system32\ntoskrnl.exe
8	ntoskrnl.exe	KeSynchronizeExecution + 0x3a43	0xfffff80002ac7993	C:\Windows\system32\ntoskrnl.exe
9	ntdll.dll	ZwCreateFile + 0xa	0x770102aa	C:\Windows\SYSTEM32\ntdll.dll
10	KERNELBASE.dll	CreateFileW + 0x2b6	0x7fefcfd4d76	C:\Windows\system32\KERNELBASE.dll
11	kernel32.dll	CreateFileW + 0x7d	0x76db2aad	C:\Windows\system32\kernel32.dll
12	OLEAUT32.dll	LoadRegTypeLib + 0x17c4	0x7fefea3c5a4	C:\Windows\system32\OLEAUT32.dll
13	OLEAUT32.dll	LoadRegTypeLib + 0x3b06	0x7fefea3e8e6	C:\Windows\system32\OLEAUT32.dll
14	OLEAUT32.dll	LoadRegTypeLib + 0x38df	0x7fefea3e6bf	C:\Windows\system32\OLEAUT32.dll
15	OLEAUT32.dll	OACreateTypeLib2 + 0x2a9b	0x7fefeabffdb	C:\Windows\system32\OLEAUT32.dll
16	OLEAUT32.dll	DllRegisterServer + 0xc7f	0x7fefeac0e3f	C:\Windows\system32\OLEAUT32.dll
17	OLEAUT32.dll	DllRegisterServer + 0xe79	0x7fefeac1039	C:\Windows\system32\OLEAUT32.dll
18	ole32.dll	ObjectStublessClient3 + 0x61e	0x7fefeb22cee	C:\Windows\system32\ole32.dll
19	ole32.dll	ObjectStublessClient3 + 0x3e7	0x7fefeb22ab7	C:\Windows\system32\ole32.dll
20	ole32.dll	ObjectStublessClient3 + 0x2d4	0x7fefeb229a4	C:\Windows\system32\ole32.dll
21	ole32.dll	CoGetMarshalSizeMax + 0x211d	0x7fefeb261bd	C:\Windows\system32\ole32.dll
22	ole32.dll	CoGetMarshalSizeMax + 0x1feb	0x7fefeb2608b	C:\Windows\system32\ole32.dll
23	ole32.dll	CoGetMarshalSizeMax + 0x1f9c	0x7fefeb2603c	C:\Windows\system32\ole32.dll
24	ole32.dll	CoUnmarshalInterface + 0xa1	0x7fefeb2395d	C:\Windows\system32\ole32.dll
25	ole32.dll	CoCreateFreeThreadedMarshaler + 0x8d6	0x7fefeb26f56	C:\Windows\system32\ole32.dll
26	RPCRT4.dll	RpcBindingSetAuthInfoW + 0x1fb	0x7fefd3d3f4b	C:\Windows\system32\RPCRT4.dll
27	RPCRT4.dll	NdrPointerUnmarshall + 0x2f	0x7fefd3e1eef	C:\Windows\system32\RPCRT4.dll
28	RPCRT4.dll	NdrSimpleStructUnmarshall + 0x1ba	0x7fefd3e268a	C:\Windows\system32\RPCRT4.dll
29	RPCRT4.dll	NdrPointerUnmarshall + 0x2f	0x7fefd3e1eef	C:\Windows\system32\RPCRT4.dll
30	RPCRT4.dll	NdrpMemoryIncrement + 0x6e4	0x7fefd3dfcb4	C:\Windows\system32\RPCRT4.dll
31	RPCRT4.dll	RpcAsyncInitializeHandle + 0xa39	0x7fefd480909	C:\Windows\system32\RPCRT4.dll
32	ole32.dll	CoGetInstanceFromFile + 0x33f0	0x7fefec7e830	C:\Windows\system32\ole32.dll
33	ole32.dll	DcomChannelSetHResult + 0x1a66	0x7fefeb218a2	C:\Windows\system32\ole32.dll
34	VirtualBox.exe	VirtualBox.exe + 0x31a795	0x14031a795	C:\Program Files\Oracle\VirtualBox\VirtualBox.exe
35	VirtualBox.exe	VirtualBox.exe + 0x228517	0x140228517	C:\Program Files\Oracle\VirtualBox\VirtualBox.exe
36	VirtualBox.exe	VirtualBox.exe + 0x3850dd	0x1403850dd	C:\Program Files\Oracle\VirtualBox\VirtualBox.exe
37	QtCoreVBox4.dll	QtCoreVBox4.dll + 0x1b4edb	0x671b4edb	C:\Program Files\Oracle\VirtualBox\QtCoreVBox4.dll
38	QtCoreVBox4.dll	QtCoreVBox4.dll + 0x1b5166	0x671b5166	C:\Program Files\Oracle\VirtualBox\QtCoreVBox4.dll
39	QtCoreVBox4.dll	QtCoreVBox4.dll + 0x1be032	0x671be032	C:\Program Files\Oracle\VirtualBox\QtCoreVBox4.dll
40	QtCoreVBox4.dll	QtCoreVBox4.dll + 0x1b18cc	0x671b18cc	C:\Program Files\Oracle\VirtualBox\QtCoreVBox4.dll
41	QtGuiVBox4.dll	QtGuiVBox4.dll + 0x21a7e	0x65021a7e	C:\Program Files\Oracle\VirtualBox\QtGuiVBox4.dll
42	QtGuiVBox4.dll	QtGuiVBox4.dll + 0x26cde	0x65026cde	C:\Program Files\Oracle\VirtualBox\QtGuiVBox4.dll
43	QtCoreVBox4.dll	QtCoreVBox4.dll + 0x195c6f	0x67195c6f	C:\Program Files\Oracle\VirtualBox\QtCoreVBox4.dll
44	QtCoreVBox4.dll	QtCoreVBox4.dll + 0x1cd71b	0x671cd71b	C:\Program Files\Oracle\VirtualBox\QtCoreVBox4.dll
45	QtCoreVBox4.dll	QtCoreVBox4.dll + 0x1ce822	0x671ce822	C:\Program Files\Oracle\VirtualBox\QtCoreVBox4.dll
46	USER32.dll	GetSystemMetrics + 0x2b1	0x76edc3c1	C:\Windows\system32\USER32.dll
47	USER32.dll	GetSystemMetrics + 0x4fa	0x76edc60a	C:\Windows\system32\USER32.dll
48	QtCoreVBox4.dll	QtCoreVBox4.dll + 0x1d229f	0x671d229f	C:\Program Files\Oracle\VirtualBox\QtCoreVBox4.dll
49	QtGuiVBox4.dll	QtGuiVBox4.dll + 0x995c5	0x650995c5	C:\Program Files\Oracle\VirtualBox\QtGuiVBox4.dll
50	QtCoreVBox4.dll	QtCoreVBox4.dll + 0x19536a	0x6719536a	C:\Program Files\Oracle\VirtualBox\QtCoreVBox4.dll
51	QtCoreVBox4.dll	QtCoreVBox4.dll + 0x19b10e	0x6719b10e	C:\Program Files\Oracle\VirtualBox\QtCoreVBox4.dll
52	VirtualBox.exe	VirtualBox.exe + 0x2afe	0x140002afe	C:\Program Files\Oracle\VirtualBox\VirtualBox.exe
53	VirtualBox.exe	VirtualBox.exe + 0x2e97	0x140002e97	C:\Program Files\Oracle\VirtualBox\VirtualBox.exe
54	VirtualBox.exe	VirtualBox.exe + 0x39326f	0x14039326f	C:\Program Files\Oracle\VirtualBox\VirtualBox.exe
55	VirtualBox.exe	VirtualBox.exe + 0x38a0cc	0x14038a0cc	C:\Program Files\Oracle\VirtualBox\VirtualBox.exe
56	kernel32.dll	BaseThreadInitThunk + 0xd	0x76dbf56d	C:\Windows\system32\kernel32.dll
57	ntdll.dll	RtlUserThreadStart + 0x21	0x76ff3021	C:\Windows\SYSTEM32\ntdll.dll

comment:2 Changed 3 years ago by frank

Sounds like a duplicate of #8033.

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

comment:4 Changed 3 years ago by yrro

  • Status changed from closed to reopened
  • Resolution duplicate deleted

I am not sure whether this is a bug of #8033, so I'll re-open it and let you decide based on the following:

  • the workaround (nohz=off kernel parameter) did not fix the problem
  • enabling the IO APIC option in the VM settings did fix the problem

Changed 3 years ago by yrro

linux kernel log messages with IO APIC option disabled

Changed 3 years ago by yrro

linux kernel log messages with IO APIC option enabled

comment:5 Changed 3 years ago by frank

That could still be the same problem. Please could you attach the VBox.log file for nohz=off?

comment:6 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate

See #8033. The hang is easy to reproduce with nohz=off nolapic. So this is indeed a duplicate and will be fixed in the next maintenance release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use