VirtualBox

Ticket #8033 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Since 4.0.0 Linux guest fails to complete booting with a PIT timer => Fixed in SVN

Reported by: rocks Owned by:
Priority: critical Component: other
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: other
Host type: other

Description

Since upgrading to VirtualBox 4.0.0, my Gentoo guest fails to complete booting with a tickless kernel. Passing nohz=off works around the problem.

Tested with 2.6.31 and 2.6.36.

Attachments

VBox.log Download (62.0 KB) - added by rocks 3 years ago.
freeze.png Download (23.1 KB) - added by rocks 3 years ago.
Screenshot showing where the freeze occurs.

Change History

Changed 3 years ago by rocks

comment:1 Changed 3 years ago by frank

Can you explain this a bit more? The guest boots fine until a certain phase and then stops booting? Does it stop always at the same location or is that different? What happens if it stops: Does the VM process consume any CPU cycles?

comment:2 Changed 3 years ago by rocks

While the boot process doesn't always freeze in the exact same position, it is always very close, and it definitely never reaches init. When it stops, VirtualBox drops from ~50% CPU to ~1%.

Changed 3 years ago by rocks

Screenshot showing where the freeze occurs.

comment:3 Changed 3 years ago by frank

Any chance to get the complete guest kernel output? You could setup a serial interface with a raw file backend and redirect the kernel console to the serial port (append console=ttyS0 to the kernel command line). The interesting question is why the kernel chose the PIT as timer and not the Local APIC.

comment:4 Changed 3 years ago by frank

  • Priority changed from major to critical

Actually reproducible if the guest kernel is booted with nolapic.

comment:5 Changed 3 years ago by frank

  • Summary changed from Since 4.0.0 Linux guest fails to complete booting with tickless kernel to Since 4.0.0 Linux guest fails to complete booting with a PIT timer => Fixed in SVN

This is not related to a tickless kernel. Booting with nolapic nohz=off shows the same problem. That problem will be fixed in the next maintenance release.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.0.4

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use