VirtualBox

Ticket #8267 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

Guest clock freezing intermittently on MacBook Pro

Reported by: mhofman Owned by:
Priority: major Component: VMM
Version: VirtualBox 4.0.2 Keywords: acpi clock macbook
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

I'm encountering issues identical to #2836 on my MacBook Pro running MacOS X 10.6. The clock of my Windows 7 guest would freeze every now and then (about 30-60 seconds) for about 10 seconds, and then resume. The guest OS would not freeze itself and stay mostly responsive but anything related to time elapsing would get stuck, like the clock gadget, resource monitors and the most annoying, any kind of animations. Any solutions posted for similar problem does not seem to do anything (or much). A consequence of the problem is that the time will appear to run slow (I originally thought this was the problem and not an effect)

One way I managed to mitigate the symptoms was to disable animations in the OS. However a lot of applications still rely on the clock time running, and will appear stuck / frozen but are in fact mostly responsive to input.

Here is my configuration:
Hardware: MacBook Pro 5,2 (Unibody 17" mid-2009) Core 2 Duo 2.8 GHz, memory 8GB
Host OS: MacOS X Snow Leopard 10.6.6 running 64 bit kernel
Guest OS: Windows 7 64 bit, ACPI, SATA controller (vm info output attached)

I've tried the following:

  • Enable or disable HPET
  • Switch between Virtualized TSC or Use Real TSC
  • Disable the ACPI battery and AC adapter in the guest Windows device manager
  • Stop Guest Addition service.

Other things I've tried:

  • Disable host caching of the SATA controller

I also attached the log file of my last try that had HPET on, using real TSC, ACPI battery device disabled, Guest Additions not running.

Attachments

vminfo.txt Download (3.4 KB) - added by mhofman 3 years ago.
VMInfo
VBox.log.1 Download (90.1 KB) - added by mhofman 3 years ago.
VBox.log

Change History

Changed 3 years ago by mhofman

VMInfo

Changed 3 years ago by mhofman

VBox.log

comment:1 Changed 3 years ago by omascia

Can you switch chipset back from ich9 to piix3, re-install the guest additions and see if this fixed it ?

comment:2 Changed 3 years ago by nike

ICH9 vs. PIIX3 chipset has nothing to do with clock. Do you connect to the VM with RDP? Can you try using QT frontend directly (your log has a lot of RDP related error messages) and see if it changes anything.

comment:3 Changed 3 years ago by mhofman

I tried both and no luck. Running in the regular interface instead of headless didn't change anything. I then changed my chipset from ich9 to piix3, reinstalled the GA and it was still the same.

Btw, I created this virtual machine with that config (ich9, acpi i/o, sata only) on virtual box 4.0.2.

comment:4 Changed 3 years ago by ni81036

Have you tried to use 1 vCPU in the VM? This could easily affect timekeeping.

comment:5 Changed 3 years ago by frank

  • Description modified (diff)

comment:6 Changed 3 years ago by mhofman

I did try a few more things:

  • Run Host in 32 bit mode
  • Switch to 1 CPU
  • Change the NIC controllers type to virtio
  • Disable the VirtualBox guest driver

After all that, I still have the same issue. I tired changing the NIC controller because it feels like the frequency of the freeze increase once I start using the network.

Since I can reproduce the problem consistently and rather quickly after boot, is there any kind of verbose / debug information I can turn on to help pin point the source of the issue?

comment:7 Changed 3 years ago by mhofman

I have an update. I uninstalled Microsoft Security Essentials 2.0 in the guest and the clock freeze dropped dramatically! I still have some freeze once in a while but the guest became a lot more usable. I think MSE is exacerbating an underlying problem with VirtualBox, since the freezes have not disappeared completely.

comment:8 Changed 3 years ago by frank

Any difference with  this test build?

comment:9 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use