VirtualBox

Ticket #8243 (closed defect: duplicate)

Opened 3 years ago

Last modified 2 years ago

Guest is in unuseable state after attempt to savestate to full harddisk

Reported by: UFO Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.2 Keywords: save savestate full harddisk
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

When attempting to save the VM state, VirtualBox discovered that the harddisk had insufficient free space. After freeing some space, the VM still appears to be in the 'Saving' state, according to VirtualBox' title bar. The Manager indicates that the VM is Paused - but there seems to be no way to unpause it. The only way out seems to kill the VM process, as it does no longer respond to the menu Close item, or closing the window.

This is the output of various VBoxManage commands:

ivo@IvoTop:~$ VBoxManage list runningvms
"IvoLap" {16570d8a-35d6-4cf5-a5a2-08f3ce5ad944}
ivo@IvoTop:~$ VBoxManage showvminfo IvoLap
...
State:           paused (since 2011-02-02T01:33:28.529000000)
...
ivo@IvoTop:~$ VBoxManage controlvm IvoLap savestate
VBoxManage: error: Already paused
VBoxManage: error: Details: code VBOX_E_INVALID_VM_STATE (0x80bb0002), component Console, interface IConsole, callee nsISupports
Context: "Pause()" at line 164 of file VBoxManageControlVM.cpp
ivo@IvoTop:~$ VBoxManage controlvm IvoLap resume
VBoxManage: error: Cannot resume the machine as it is not paused (machine state: Saving)
VBoxManage: error: Details: code VBOX_E_INVALID_VM_STATE (0x80bb0002), component Console, interface IConsole, callee nsISupports
Context: "Resume()" at line 101 of file VBoxManageControlVM.cpp
ivo@IvoTop:~$ VBoxManage controlvm IvoLap pause
VBoxManage: error: Already paused
VBoxManage: error: Details: code VBOX_E_INVALID_VM_STATE (0x80bb0002), component Console, interface IConsole, callee nsISupports
Context: "Pause()" at line 97 of file VBoxManageControlVM.cpp

Change History

comment:1 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Duplicate of #6189.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use