VirtualBox

Ticket #8059 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Guru meditation (PGM_PAGE_GET_STATE(pPage) == PGM_PAGE_STATE_ALLOCATE) trying to create snapshot

Reported by: lnoland Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: other
Host type: other

Description

In VBox 5.0 running on a 64-bit Windows 7 Professional host, I attempted to take a snapshot of my currently running machine by clicking on the snapshot icon in the GUI. The virtual machine died immediately with the error VERR_SSM_LIVE_GURU_MEDITATION (the error dialog and vbox.log file are attached). I was, subsequently, able to take a snapshot of the aborted machine. I could also restart the machine and take a snapshot at that point so I don't know what is the significant context of the original problem. After taking the second successful snapshot, I tried to delete the first but it would not allow me to saying that the "hard disk g:\ . . . has more than one child disk" -- by child disk, I presume it is referring to snapshots. Is preventing one from deleting a snapshot if there is more than one beneath it a new feature or is this a bug? I'm pretty sure one used to be able to do that.

Attachments

VBoxSnapError.jpg Download (50.7 KB) - added by lnoland 3 years ago.
Error dialog
MythBuntu-2011-01-11-07-40-04.zip Download (49.7 KB) - added by lnoland 3 years ago.
The zipped log file

Change History

Changed 3 years ago by lnoland

Error dialog

comment:1 follow-up: ↓ 2 Changed 3 years ago by lnoland

Note: I was not able to attach my log file as apparently there is a limit of 400000 bytes and mine is about 405000. Do you want me to try compressing it, or breaking it up into more than one file?

Changed 3 years ago by lnoland

The zipped log file

comment:2 in reply to: ↑ 1 Changed 3 years ago by lnoland

Replying to lnoland:

Note: I was not able to attach my log file as apparently there is a limit of 400000 bytes and mine is about 405000. Do you want me to try compressing it, or breaking it up into more than one file?

OK, that was a dumb question -- of course I should compress the log file and try again. It is now attached as a zip archive.

comment:3 Changed 3 years ago by lnoland

I believe that the above error may be related to another error I reported recently (see ticket  http://www.virtualbox.org/ticket/7972). I recently had another issue with snapshots -- I was unable to restore a snapshot, which was caused by my inability to load the extender pack. Since I had USB enabled for my virtual machine but there was no USB implementation available, it refused to allow me to restore from the snapshot. I was dead in the water until I could get the extender pack loaded. It occurred to me that the first snapshot error might have been due to this mismatch between the virtual machine's described state and the actual physical state. It's just speculation, but it seems plausible so I thought I should report it.

comment:4 Changed 3 years ago by frank

  • Summary changed from VERR_SSM_LIVE_GURU_MEDITATION error when trying to create snapshot to Guru meditation (PGM_PAGE_GET_STATE(pPage) == PGM_PAGE_STATE_ALLOCATE) trying to create snapshot

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Sounds more like a duplicate of #7910. For the other issue please create a separate ticket. Actually there is a chance that the extpack issue was fixed in 4.0.2, I'm not sure.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use