VirtualBox

Ticket #8006 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Guest Fedora 12 can not boot any more (pPage->enmKind != PGMPOOLKIND_FREE) => Fixed in SVN

Reported by: rumen Owned by:
Priority: major Component: VMM/RAW
Version: VirtualBox 4.0.0 Keywords: Fedora Boot
Cc: Guest type: Linux
Host type: Linux

Description

After an upgrade from 3.2.12 the fedora VMs stopped booting sometimes generating an error (see the attached log) but not always. I created new VM and tried to install Fedora 12 but after the installation when I try to boot the VM I get "NO BOOT DEVICE FOUND".

I have the same problem on Ubuntu 10.04 and MacOS X 10.6.5 hosts.

Attachments

F12_x-2011-01-04-17-43-51.log Download (178.0 KB) - added by rumen 3 years ago.
VBox.log Download (226.4 KB) - added by raffaellod 3 years ago.
Boot failure with Linux 2.6.36 with Gentoo patchset 5

Change History

Changed 3 years ago by rumen

comment:1 Changed 3 years ago by rumen

UPDATE: after a downgrade to 3.2.12 the all the machines started booting again. Even the one installed under 4.0.0.

comment:2 Changed 3 years ago by frank

  • Summary changed from Guest Fedora 12 can not boot any more to Guest Fedora 12 can not boot any more (pPage->enmKind != PGMPOOLKIND_FREE)

Changed 3 years ago by raffaellod

Boot failure with Linux 2.6.36 with Gentoo patchset 5

comment:3 Changed 3 years ago by raffaellod

Same issue here, with a Gentoo guest with minimal custom-configured kernel version 2.6.36 with Gentoo patchset 5, which worked perfectly until I upgraded from VirtualBox 3.2.12 to 4.0.0.

Host is Gentoo as well, with the same kernel, very up-to-date.

I have a number of other guests, and I don’t seem to have any problems with Arch Linux, Fedora 14, Ubuntu 10.10, and OpenSolaris 2009.06. I’m also investigating a lock-up crash in Windows XP SP3 that appeared with 4.0.0, but I’ll probably file a separate bug for that.

comment:4 Changed 3 years ago by raffaellod

I believe I found what, in my case at least, leads to the failure of the assertion in the subject (pPage->enmKind != PGMPOOLKIND_FREE).

I reconfigured the faulty guest kernel using the .config from another (working) guest, Ubuntu 10.10, and I started disabling/altering configuration options until the error showed up again (very lengthy process - hours of recompilations). And it did, when I disabled highmem support (CONFIG_NOHIGHMEM=y) while still enabling PAE support (CONFIG_X86_PAE=y).

I tried re-enabling highmem (CONFIG_HIGHMEM4G=y) or disabling PAE (#CONFIG_X86_PAE), and it resumed working; I then reverted them again, one by one, and I got still the same guru meditation. So, I think that the combination no-highmem + PAE is the culprit. It also makes sense that it’s a memory-related problem, since the assertion that fails is in

VBox/VMM/VMMAll/PGMAllPool.cpp(5117) PGMPOOLPAGE* pgmPoolGetPage(PGMPOOL*, RTHCPHYS)

I don’t know if this is the same problem that’s afflicting the OP, but the workaround I found (either enable highmem or disable PAE) works for me.

I hope you’ll be able to reproduce, and maybe fix, this issue.

comment:5 follow-up: ↓ 6 Changed 3 years ago by sigwx

Seems to be hardware specific for me as I use 4.0.2 on a newer system with VT-x support and it works fine. Move the VMs to a older P4 system without VT-x and I see the same issues.... or is this the same as #7938?

comment:6 in reply to: ↑ 5 Changed 3 years ago by raffaellod

Replying to sigwx:

Seems to be hardware specific for me as I use 4.0.2 on a newer system with VT-x support and it works fine. Move the VMs to a older P4 system without VT-x and I see the same issues.... or is this the same as #7938?

It can’t be the same: this bug only happens with no hwvirt, while the nested paging (related to #7938) is only available with hwvirt.

comment:7 Changed 3 years ago by frank

  • Component changed from VMM to VMM/RAW

I closed a couple of duplicates. Let's summarize the findings (raffaellod, thank you for your investigation):

  • this seems to be a VBox 4.0 regression (VBox 3.2.12 works)
  • all reports have in common that no hardware virtualization is used
  • the guest is always 32-bit and uses PAE
  • the hosts of all reporters are 32-bit but I believe the same would happen with Vt-x disabled on a 64-bit host

comment:8 Changed 3 years ago by frank

  • Summary changed from Guest Fedora 12 can not boot any more (pPage->enmKind != PGMPOOLKIND_FREE) to Guest Fedora 12 can not boot any more (pPage->enmKind != PGMPOOLKIND_FREE) => Fixed in SVN

The fix will be available with the next maintenance release.

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use