VirtualBox

Ticket #7946 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Mouse arrow stuck -> fixed as of 14 Apr 2011

Reported by: cyruspy Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

After installing Guest Additions the mouse arroy doesn't follow move movement. If you click on new location the arrow jumps there, but still doesn't move as you move the mouse.

Host: OpenSUSE 11.3 - x86_64 Guest: SLES11 SP1 - x86_64

Attachments

VBox.log Download (51.1 KB) - added by cyruspy 3 years ago.
messages Download (52.8 KB) - added by cyruspy 3 years ago.
/var/log/messages from Linux Guest
Xorg.0.log Download (15.0 KB) - added by cyruspy 3 years ago.
/var/log/Xorg.0.log from Linux guest
xorg.conf Download (4.1 KB) - added by cyruspy 3 years ago.
/etc/X11/xorg.conf from guest

Change History

Changed 3 years ago by cyruspy

comment:1 Changed 3 years ago by cyruspy

Sorry, it should state:

"the mouse arrow (in-screen pointer) doesn't follow mouse movement"

Changed 3 years ago by cyruspy

/var/log/messages from Linux Guest

Changed 3 years ago by cyruspy

/var/log/Xorg.0.log from Linux guest

comment:2 Changed 3 years ago by michael

Could you please attach all /etc/X11/xorg.* files from the guest? Thanks.

Changed 3 years ago by cyruspy

/etc/X11/xorg.conf from guest

comment:3 Changed 3 years ago by cyruspy

Still happens with SLES11-SP1+patches and VBox 4.0.4

comment:4 Changed 3 years ago by michael

Ticket #8640 is a duplicate of this one. Quote:

Host: Windows 7, x64, VBox 4.0.4 (and 4.0.0)

Guest: Linux - SLES 11 SP1 (32+64bit, both KDE and GNOME)

After installing GA on SLES 11 guest, Xorg mouse became unresponsive.

comment:5 Changed 3 years ago by Technologov

Added myself as CC.

-Technologov

comment:6 Changed 3 years ago by Technologov

Any news on this one ?

comment:7 Changed 3 years ago by michael

Just testing the distribution (and a fix) now. The problem seems to be that SLES (and probably SLED too) 11 SP 1 ship X.Org Server 1.6.5, but unlike openSUSE with the same version they still do not enable input device autodetection.

comment:8 Changed 3 years ago by michael

I hope that this Additions test build (see here) will fix this:

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r71151.iso

comment:9 Changed 3 years ago by Technologov

  1. Yes, thanks, mouse problem fixed.
  1. Detected Regression: "Guest Control Execute" now fails. Worked with 4.0.4.

VBoxManage --nologo guestcontrol execute "SLES 11 32-bit" "/bin/uname" --arguments "-a" --username root --password 123456 --wait-for stdout

  1. Found new problem: 3D Acceleration doesn't installs. (it still shows Mesa Software Rasterizer)

Should I open new bugs for 2 & 3 ?

-Technologov

comment:10 Changed 3 years ago by michael

  • Summary changed from Mouse arrow stuck to Mouse arrow stuck -> fixed as of 14 Apr 2011

Please do. Thanks for testing.

comment:11 Changed 3 years ago by frank

  1. is already known.

comment:12 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use