VirtualBox

Ticket #7947 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

4.0.0 - crash with async I/O and VMDK snapshots => fixed in svn/4.0.2

Reported by: avi_m1968 Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 4.0.0 Keywords: snapshots crash sata vmdk
Cc: Guest type: other
Host type: other

Description

Hello

i have just upgraded from virtualbox 3.2.12 to 4.0.0 and i can't start my Ubuntu 10.04 machine . it crashes with the following line " plymouth main process terminated status 2" and then VirtualBox software crashes also!

AppName: virtualbox.exe AppVer: 4.0.0.0 ModName: vboxddu.dll ModVer: 0.0.0.0 Offset: 0000374f

before the upgrade the Ubuntu 10.04 i have ran without a problem. (without 3d support)

please check this since i can't access the machine.

Avi

(i can run my Mint 10 linux)

Attachments

6d68_appcompat.txt Download (39.6 KB) - added by avi_m1968 3 years ago.
VBox.log Download (49.3 KB) - added by avi_m1968 3 years ago.
virtualbox400_crash.jpg Download (129.0 KB) - added by avi_m1968 3 years ago.
VirtualBox 4.0.0 CRASHES during ubuntu 10.04 boot !!!

Change History

Changed 3 years ago by avi_m1968

Changed 3 years ago by avi_m1968

Changed 3 years ago by avi_m1968

VirtualBox 4.0.0 CRASHES during ubuntu 10.04 boot !!!

comment:1 Changed 3 years ago by avi_m1968

Hello

Virtual Box crashes during Ubuntu 10.04 boot, when a problem with plymount error happens during the boot.

can't access my linux guest anymore!

comment:2 Changed 3 years ago by aeichner

  • Summary changed from 4.0.0 - after upg. from 3.2.12 - ubuntu 10.04 AND VMbox crashes on start - plymouth main process terminated status 2 to 4.0.0 - crash with async I/O and VMDK snapshots => fixed in svn/4.0.2

This crash will be fixed in 4.0.2. It happens if a VM uses VMDK images, has snapshosts and uses async I/O (default for the SATA controller you are using). As a workaround, enable "Use host I/O cache" in the controller settings of the VM.

comment:3 Changed 3 years ago by avi_m1968

Hello aeichner

Thank you for the workaround :-) it worked.

However two things happened which I don't know if related to the workaround or happened because of the virtual box crash.

  1. After the ubuntu started I tried to install the guest addition from the virtualbox cd. I got many errors that the system disk can't be accessed and its only in read-only mode. then the install failed. and I was only able to shutdown the ubuntu. (no other software work too)
  2. after I closed it , it started only in single mode due to disk errors.

I had to do fsck on the virtual disk and only after that I was able to start the ubuntu and install the guest addition then update the ubuntu.

Again it might be due to the virtualbox crashing many times in the middle of the Boot sequence which did something to the virtual disk.

thank yo again

Avi

comment:4 Changed 3 years ago by aeichner

This was most probably caused by the crash which can leave the image in an inconsistent state.

comment:5 Changed 3 years ago by aeichner

  • Keywords snapshots crash sata vmdk added
  • Host type changed from Windows to other
  • Component changed from other to virtual disk
  • Guest type changed from Linux to other

comment:6 Changed 3 years ago by charlierlee

So I tried with/without I/O cache, tried ext3, ext4, ntfs, same issue. I could reproduce the error by logging into the MSDN subscription website and download an ISO. After the download completed, the download tool provided by the msdn subscription site would do a crc check. Sometimes I could get one to suceed, but for the most part a crc error would get thrown. I had this problem running VirtualBox 3.2.8 OSE and 4.0.0. It didn't matter if I ran VirtualBox host as Ubuntu 10.10 or Windows 7. I can't wait to get this bug fixed.

comment:7 Changed 3 years ago by aeichner

@charlierlee: Please open a new ticket because this is a different issue and attach the VBox.log there, thanks!

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use