VirtualBox

Opened 14 years ago

Closed 13 years ago

Last modified 9 years ago

#7941 closed defect (fixed)

VM Portability/XML: Shared folder path is not absolute => Fixed in SVN

Reported by: Technologov Owned by:
Component: other Version: VirtualBox 4.0.0
Keywords: Cc:
Guest type: other Host type: other

Description

I am pushing the new v4.0 architecture to the limits.

Hosts: WinXP --> RHEL5 x64, VBox v4.0.0

VM cannot be moved from Windows to Linux host due to shared folders.

VirtualBox ERROR:

Failed to open virtual machine located in /home/alexey/Windows XP Unattended3/Windows XP Unattended3.vbox.

Shared folder path 'E:\' is not absolute.

VM cannot be imported.

Workaround: Manually Remove Shared Folders from XML.

-Technologov, 29.12.2010.

Attachments (1)

Windows XP Unattended3.vbox (30.2 KB ) - added by Technologov 14 years ago.
VBox VM XML

Download all attachments as: .zip

Change History (16)

by Technologov, 14 years ago

Attachment: Windows XP Unattended3.vbox added

VBox VM XML

comment:1 by Technologov, 14 years ago

It would be nice if VirtualBox reduces the importance of this issue from Error to Warning.

-Technologov

comment:2 by patrick.steiner, 13 years ago

I can confirm this bug on a OS X Host

comment:3 by Dan Rollo, 13 years ago

comment:4 by Frank Mehnert, 13 years ago

Summary: VM Portability/XML: Shared folder path is not absoluteVM Portability/XML: Shared folder path is not absolute => Fixed in SVN

This will be fixed in the next maintenance release.

comment:5 by Frank Mehnert, 13 years ago

Resolution: fixed
Status: newclosed

comment:6 by Technologov, 13 years ago

Resolution: fixed
Status: closedreopened

Reopened. Still broken in 4.0.6.

comment:7 by Technologov, 13 years ago

IMO, on VM import (Machine->Add) it should warn user about existing incompatible shared folders, and offer the user to delete them. (from all snapshots)

-Technologov

comment:8 by Jacky, 13 years ago

Just tried on V4.0.8, still outstanding, guess has to modify the xml manually...

comment:9 by Charles Burns, 13 years ago

I don't think this was fixed in a maintenance release. If it was, it's regressed. Still a problem in 4.1

comment:10 by MarcelS, 13 years ago

Confirmation - still a problem in 4.1.
IMHO: If detected, Import-Dialog should ask for valid path and/or deletion of shared folder.

comment:11 by Christian Pötzsch, 13 years ago

Fixed in SVN. The fix will be included in the next minor version.

comment:12 by Andrei ILIE, 13 years ago

Same problem on VirtualBox 4.1.2

I need to import a VM with shared folders already set, but because I do not have that folders (I don't have D: on linux), the import fails:

WinXP host (with shared folders) --> WinXP guest --> Linux host

possible dup: Ticket #7001

comment:13 by rivimey, 13 years ago

Just experienced this problem on 4.1.2... not easy to workaround when all you have is an .ova file.

I looked at the trunk svn for vboxmanage and could find no evidence of change there of the sort I would expect -- which is "import" commands to ignore shared folder specs (as for e.g. a floppy) and dry-run check that the shared folder is ok.

I agree that, from the GUI, it would be nice to have a prompt for the updated folders.

My variant of the problem was exporting a Debian VM from Win7 and importing on an Ubuntu machine. I'd just updated the Ubuntu vb to 4.1.2 (why is "natty" still 4.0.4). My workaround was to use "sed" on the .ova file to edit the bad path to one in /tmp that had the same number of characters.

comment:14 by Frank Mehnert, 13 years ago

Resolution: fixed
Status: reopenedclosed

VBox 4.1.4 contains the fix.

comment:15 by tturner, 9 years ago

I'm in Vbox 5.0.8 on OS X and I still see this problem. We support both Windows and OSX hosts and need to automate the removal and adding of these mounts.

SFO1212438846Q:Org-migration localuser$ vboxmanage sharedfolder add "DevBox3.3.8" -name "Public" -hostpath "C:\Users\Public" --automount shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory VBoxManage: error: Shared folder path 'C:\Users\Public' is not absolute VBoxManage: error: Details: code NS_ERROR_INVALID_ARG (0x80070057), component SharedFolderWrap, interface ISharedFolder, callee nsISupports VBoxManage: error: Context: "CreateSharedFolder(Bstr(name).raw(), Bstr(hostpath).raw(), fWritable, fAutoMount)" at line 1020 of file VBoxManageMisc.cpp

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use