VirtualBox

Ticket #7001 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Export and then Import fails to install. Error suggests that the ovf file has wrong information

Reported by: Perryg Owned by: umoeller
Priority: major Component: OVF
Version: VirtualBox 3.2.4 Keywords: Not OS specific, OVF encodes wrong
Cc: Guest type: Linux
Host type: Windows

Description

Exporting an appliance from Windows and Importing to Linux fails now. It looks like the encoding of the OVF file has static information stored in it that will not allow it to be imported. The D:\Shared folder was setup on the guest, but that should not stop the install. It should continue and dis-allow the shared folder information as it has in the past. Now that I know I guess I can always delete the share folders before exporting but that seems like a step that should not be needed plus it makes it a major problem if this were at different locations. At the very least it should be a setting that I can uncheck on the Import screen.

Attachments

Import-error.png Download (124.6 KB) - added by Perryg 4 years ago.
Windows-XPpro-Bridged.ovf Download (19.2 KB) - added by Perryg 4 years ago.
WrongPrimaryDrive.png Download (74.0 KB) - added by Perryg 4 years ago.
XPpro-Bridged.ovf Download (19.0 KB) - added by Perryg 4 years ago.
New OVF
export-error.jpg Download (54.4 KB) - added by Perryg 4 years ago.
WindowsXP-Original
ubuntuMaster.ovf Download (14.0 KB) - added by wgregori 3 years ago.

Change History

Changed 4 years ago by Perryg

Changed 4 years ago by Perryg

Changed 4 years ago by Perryg

Changed 4 years ago by Perryg

New OVF

comment:1 Changed 4 years ago by Perryg

Update:

I removed the shared folder and exported again and Import failed. Seems the SATA on the XP on Windows made Linux mad. No worries I switched it back to IDE on both drives and exported again. Import succeeded but I was presented with found no bootable media.

It seems that something in the export Import is broken. It Imported the drives backwards, Primary/Secondary were reversed, but one other thing. I looks like it exported the secondary drive and the Primary drive as one and the original (19GB) file is nowhere to be found.

Attaching the Windows screen shot and the Linux import screen shot as well as the Log file from the Linux host of the imported XP guest. Also the new OVF file

I did try to switch them around but neither will boot as I suspect the export/import has something bad wrong in it.

Changed 4 years ago by Perryg

WindowsXP-Original

comment:2 Changed 4 years ago by umoeller

  • Owner set to umoeller
  • Status changed from new to assigned

Thanks for the report. If I see this correctly, we fail because there are platform-specific settings in the OVF such as the shared folder path which doesn't exist on Linux. So the import code should probably issue a warning but not fail. We'll look into this.

comment:3 Changed 4 years ago by whiochon

I have the same problem. It occurs when there are multiple virtual disk images associated with the machine. Note in the .ovf files attached the UUID of all the images in the <StorageControllers> section at the bottom of the file is the same. They should match the UUIDs of the images listed in the <DiskSection> section at the top of the file, in the same order.

I have been able to import the ovf by editing it first to fix the error, and removing the .mf file (otherwise VirtualBox complains as it has also calculated the wrong SHA key on export)

comment:4 Changed 4 years ago by javaboyuk

I have an export import issue too:

export from a solaris host (but has a shared are "/datapool"

import onto a windows host, gives error "/datapool" not absolute

if you edit the .ovf file to add say c: to path you get a checksum eror on the file as you've edited it!

not work arround

comment:5 Changed 4 years ago by whiochon

Checksum error can be avoided by removing the checksum file (*.mf) But it sounds like the shared folder issue is another issue altogether.

comment:6 Changed 4 years ago by TheOtherPhilC

My experience is same as whiochon. I have two SATA disks attached to one controller. UUIDs are correct in the DiskSection of the .ovf, but one UUID is listed twice in the VirtualSystem/vbox:Machine/StorageControllers/StorageController/AttachedDevice sections for the relevant controller.

As with whiochon, I was able to get past it by renaming the .mf and editing the .ovf with the correct UUID.

In my case, there are no shared folders to confuse the issue. The only possible anomaly I can find other than the UUID problem is that while the original VM has one IDE (PIIX4) controller with a single port having a DVD identified as "IDE Secondary Master", the OVF PIIX4 controller has a count of two ports with the DVD attached to port 1.

Changed 3 years ago by wgregori

comment:7 follow-up: ↓ 8 Changed 3 years ago by wgregori

I'm having the same problem with a linux export of a linux machine trying to import it to the same linux box. I have the same problem with a window's box. I've attached the ovf file.

comment:8 in reply to: ↑ 7 Changed 3 years ago by wgregori

Replying to wgregori:

I'm having the same problem with a linux export of a linux machine trying to import it to the same linux box. I have the same problem with a window's box. I've attached the ovf file.

The exports were created in VB 4.0.4

comment:9 Changed 3 years ago by myersjj

I have this same problem using the latest version 4.0.6. This is quite disturbing :( I'm running Windows 7 x64 with a Linux guest.

comment:10 Changed 3 years ago by ailie

Same problem on VirtualBox 4.1.2

I need to import a VM with shared folders already set, but because I do not have that folders (I don't have D: on linux), the import fails:

WinXP host (with shared folders) --> WinXP guest --> Linux host

possible dup: Ticket #7941

comment:11 Changed 3 years ago by poetzsch

  • Status changed from assigned to closed
  • Resolution set to duplicate

Duplicate of #7941.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use