VirtualBox

Ticket #7912 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Segfault on entering settings window

Reported by: schuay Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

On VMs created with older versions of VirtualBox, VirtualBox segfaults when entering the settings window by either right clicking on the VM and selecting "Settings..." or through the Machine menu.

Clicking on the settings headers on the right side of the main Vbox window works fine.

Backtrace:

Program received signal SIGSEGV, Segmentation fault.
0x00007f95ffe4a078 in QWidgetPrivate::showChildren(bool) () from /usr/lib/libQtGui.so.4
(gdb) bt
#0  0x00007f95ffe4a078 in QWidgetPrivate::showChildren(bool) ()
   from /usr/lib/libQtGui.so.4
#1  0x00007f95ffe4a1af in QWidgetPrivate::show_helper() () from /usr/lib/libQtGui.so.4
#2  0x00007f95ffe4a5ea in QWidget::setVisible(bool) () from /usr/lib/libQtGui.so.4
#3  0x00007f95ffe4a146 in QWidgetPrivate::showChildren(bool) ()
   from /usr/lib/libQtGui.so.4
#4  0x00007f95ffe4a1af in QWidgetPrivate::show_helper() () from /usr/lib/libQtGui.so.4
#5  0x00007f95ffe4a5ea in QWidget::setVisible(bool) () from /usr/lib/libQtGui.so.4
#6  0x00007f96023df38c in ?? () from /usr/lib/virtualbox/VirtualBox.so
#7  0x00007f96023df1ac in ?? () from /usr/lib/virtualbox/VirtualBox.so
#8  0x00007f96024b8a6f in ?? () from /usr/lib/virtualbox/VirtualBox.so
#9  0x00007f960256c259 in ?? () from /usr/lib/virtualbox/VirtualBox.so
#10 0x00007f9600a3f17a in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#11 0x00007f95ffe4631d in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#12 0x00007f960020a64b in QMainWindow::event(QEvent*) () from /usr/lib/libQtGui.so.4
#13 0x00007f96024b5fbe in ?? () from /usr/lib/virtualbox/VirtualBox.so
#14 0x00007f95ffdf52b4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /usr/lib/libQtGui.so.4
#15 0x00007f95ffdf9dca in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libQtGui.so.4
#16 0x00007f9600a2ae9c in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /usr/lib/libQtCore.so.4
#17 0x00007f9600a2e6c5 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
---Type <return> to continue, or q <return> to quit---
#18 0x00007f9600a55d73 in ?? () from /usr/lib/libQtCore.so.4                                                                                                                                                                        
#19 0x00007f95fc80bbf3 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0                                                                                                                                                 
#20 0x00007f95fc80c3d0 in ?? () from /usr/lib/libglib-2.0.so.0                                                                                                                                                                      
#21 0x00007f95fc80c66d in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0                                                                                                                                                
#22 0x00007f9600a55f0f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4                                                                                                
#23 0x00007f95ffe9a1ae in ?? () from /usr/lib/libQtGui.so.4                                                                                                                                                                         
#24 0x00007f9600a2a232 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4                                                                                                          
#25 0x00007f9600a2a47c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()                                                                                                                                                
   from /usr/lib/libQtCore.so.4                                                                                                                                                                                                     
#26 0x00007f9600a2e97b in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4                                                                                                                                                  
#27 0x00007f960236136f in TrustedMain () from /usr/lib/virtualbox/VirtualBox.so                                                                                                                                                     
#28 0x00007f960472bc3d in __libc_start_main () from /lib/libc.so.6                                                                                                                                                                  
#29 0x00000000004011f9 in ?? ()                                                                                                                                                                                                     
#30 0x00007fff22a4f078 in ?? ()                                                                                                                                                                                                     
#31 0x000000000000001c in ?? ()                                                                                                                                                                                                     
#32 0x0000000000000001 in ?? ()                                                                                                                                                                                                     
#33 0x00007fff22a4f9ce in ?? ()                                                                                                                                                                                                     
#34 0x0000000000000000 in ?? ()

VM xml file is attached.

Attachments

ArchHurd.xml Download (6.2 KB) - added by schuay 3 years ago.
ArchHurd.xml-prev Download (6.1 KB) - added by schuay 3 years ago.

Change History

Changed 3 years ago by schuay

Changed 3 years ago by schuay

comment:1 Changed 3 years ago by seblu

I've same issue on newly created VM.

comment:2 Changed 3 years ago by jfraymondpa

I also am having this same problem on a newly installed Fedora 14 and a new VMs using VBox 4.0.0. The work around noted above does work.

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #7875.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use