VirtualBox

Ticket #7875 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Virtualbox 4.0 crash when clicking the "Settings" button -> Fixed in SVN

Reported by: roentgen Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Virtualbox 4.0.0-69151~Ubuntu~maverick The host is Ubuntu 10.10 x64 and the guest is Windows XP Pro SP3.

With the VM powered off when I click the Settings button the Virtualbox GUI dissapears and core is dumped.

I had installed all the four 4.0 betas and I didn't notice this problem so far. (I don't check settings that much though)

I'm attaching the log and the core.

Attachments

WinXPPro-2010-12-22-19-03-27.log.gz Download (14.3 KB) - added by roentgen 3 years ago.
VM log
dpkg.list.gz Download (9.5 KB) - added by roentgen 3 years ago.
dpkg --get-selections

Change History

Changed 3 years ago by roentgen

VM log

comment:1 Changed 3 years ago by roentgen

The core dump is too big to be attached here. You may download it from  http://www.psw.ro/tmp/vbox/core.2562.bz2

comment:2 Changed 3 years ago by dmuntean

I have this problem too, with exactly same hardware and versions of host/guest.

comment:3 in reply to: ↑ description Changed 3 years ago by botio

Same here, on a debian host, crashes on opening settings for every kind of guests.

comment:4 Changed 3 years ago by medber

Same here on Fedora 14 x64.

comment:5 in reply to: ↑ description Changed 3 years ago by gesantkunstwerk

I remember reading somewhere that its possible to change some of the settings from within the running guest (change memory allocation if i remember correctly) - does anybody know of a way to add usb or shared folders from within run running guest? I feel like it should be possible

comment:6 Changed 3 years ago by gesantkunstwerk

Maybe done through vboxmanage command?  http://www.virtualbox.org/manual/ch03.html#settings-usb ? (sorry if i shouldn't be posting a workaround here)

comment:7 Changed 3 years ago by gesantkunstwerk

 http://www.virtualbox.org/manual/ch08.html#vboxmanage-modifyvm-other

VBoxManage modifyvm --uartmode<1-N> <devicename>

I"ll stop now...

comment:8 Changed 3 years ago by stefan.becker

See more cases in this threads:

 http://forums.virtualbox.org/viewtopic.php?f=15&t=36960  http://forums.virtualbox.org/viewtopic.php?f=7&t=37378

For me its crashing on Suse 11.3 / 64 with KDE 4.5x.

Seems to be on KDE Desktop. On Gnome it works for me.

comment:9 Changed 3 years ago by yadav

i have new input on this bug

for kubuntu 10.10 x86_64

when 'details' is select (top right) on manager dialog box and then settings is clicked the app with crash each time

however if i select 'snapshots' (top right) then settings, i don't not get a crash

comment:10 follow-up: ↓ 11 Changed 3 years ago by csbac

See also #7909. Probably duplicate.

comment:11 in reply to: ↑ 10 Changed 3 years ago by gagahhag

Same problem here: kUbuntu 10.10 x64

I can open settings when clicking a title (e.g. General or Storage) on the right side of the VB Manager while VM is powered off. Setting dialog opens as usual and changes can be made.

comment:12 Changed 3 years ago by csbac

Hi, great!

At least sometimes/for some vms, it works by clicking general; for others, it works when selecting snapshots (see comment 9), then the button.

I tried some more debugging; unfortunately, it crashes deep inside the (optimised) qt libraries, in inline code, so I'm unable to examine all data ...

@Oracle: Is the cause of the problem known, or should we investigate further? Maybe we should gather the QT versions we are using, here, to find out whether it is a qt version problem ...

Are there also i386-users who have this problem?

  • System: Opensuse 11.3 x64
  • Qt: libqt4-4.6.3-8.3.x86_64 from openbuildservice, not the opensuse original one

Sebastian

comment:13 Changed 3 years ago by frank

The cause is unknown but nevertheless I hope we can fix the problem quite soon.

comment:14 Changed 3 years ago by frank

Unfortunately still unable to reproduce. roentgen, could you attach the compressed output of dpkg --get-selections? Thank you!

Changed 3 years ago by roentgen

dpkg --get-selections

comment:15 Changed 3 years ago by frank

Thanks. All: Does this crash only happen for 64-bit hosts or for 32-bit hosts as well?

comment:16 Changed 3 years ago by frank

Now we were able to reproduce it the first time. Changing the widget style from Default (Oxygen) to another style prevents the crash here.

comment:17 Changed 3 years ago by csbac

Mh. I tried various window decorations and various desktop designs ... still same results ..

Glassified+Redmond, looks awful, still crashes ...

Sorry, Sebastian

comment:18 Changed 3 years ago by frank

Widget style please, not Windows decorations.

comment:19 Changed 3 years ago by frank

We were able to reproduce the crash and hopefully fixed it properly. I've created some test builds, you can download them here (openSUSE 11.3  32 bit,  64 bit; Ubuntu 10.10  32 bit,  64 bit). Could you check if the crash is gone?

comment:20 Changed 3 years ago by csbac

Yeah, Great, Crash is Gone!

Btw, I switched "Erscheinungsbild von Anwendungen", "Stil" from Oxygen to anything else ... VBox still used Oxygen and still crashed. Strange, but doesn't matter any longer.

Thanks, Sebastian

comment:21 Changed 3 years ago by poetzsch

  • Summary changed from Virtualbox 4.0 crash when clicking the "Settings" button to Virtualbox 4.0 crash when clicking the "Settings" button -> Fixed in SVN

Thanks for the reports and the testing. Fixed in the next minor release.

comment:22 Changed 3 years ago by dflogeras

Could you tell me the rev number? I am interested in backporting this fix and I cannot seem to find it in the public SVN trunk. The last checkin there is a couple days before this bug was marked fixed.

comment:23 Changed 3 years ago by stefan.becker

Testbuild checked with Opensuse 11.3 and it works now.

comment:24 Changed 3 years ago by stefan.becker

And checked on Linux Mint (like Ubuntu 10.10). Same, working OK now.

comment:25 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for all the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use