VirtualBox

Ticket #7857 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

VM locks up under heavy disk activity

Reported by: yrro Owned by:
Priority: critical Component: other
Version: VirtualBox 3.2.12 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Since Virtualbox 3.0 I (and another user I know) have experienced semi-repeatable lockups of our Virtualbox VMs when the guest OS tries to do a lot of disk I/O.

The symptoms are that the guest display stops updating; though the mouse still moves, it does not respond to clicks (we're using the guest additions though so I guess the mouse moving does not really mean anything). The guest kernel responds to low level networking stuff, enough to return a 'connection refused' message to the host when I try to SSH in to see what's going on.

I haven't reported this until now because it is not possible to trigger this bug reliably, and the guest's log file doesn't contain anything useful; however I ran into it five times in as many days in the following circumstances:

  1. Run 'wineboot' from wine 1.3.9 (creates ~/.wine, containing a lot of small files ~/.wine)
  2. Run 'git merge' with a sufficiently complex merge
  3. Copy a lot of files to a vboxsf shared folder on the host

Over the months I have tried tweaking various guest settings, such as enabling/disabling the virtual disk controller cache, trying a PATA virtual disk controller rather than SATA, etc) but no existing open seems to make a difference.

My host is Windows 7 on amd64, and my guest is Debian GNU/Linux using 2.6.32.

Change History

comment:1 Changed 3 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #7858.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use