VirtualBox

Opened 14 years ago

Closed 7 years ago

#7858 closed defect (fixed)

VM locks up under heavy disk activity

Reported by: Sam Morris Owned by:
Component: other Version: VirtualBox 3.2.12
Keywords: Cc:
Guest type: Linux Host type: Windows

Description (last modified by Frank Mehnert)

Since Virtualbox 3.0 I (and another user I know) have experienced semi-repeatable lockups of our Virtualbox VMs when the guest OS tries to do a lot of disk I/O.

The symptoms are that the guest display stops updating; though the mouse still moves, it does not respond to clicks (we're using the guest additions though so I guess the mouse moving does not really mean anything). The guest kernel responds to low level networking stuff, enough to return a 'connection refused' message to the host when I try to SSH in to see what's going on.

I haven't reported this until now because it is not possible to trigger this bug reliably, and the guest's log file doesn't contain anything useful; however I ran into it five times in as many days in the following circumstances:

  1. Run 'wineboot' from wine 1.3.9 (creates ~/.wine, containing a lot of small files ~/.wine)
  2. Run 'git merge' with a sufficiently complex merge
  3. Copy a lot of files to a vboxsf shared folder on the host

Over the months I have tried tweaking various guest settings, such as enabling/disabling the virtual disk controller cache, trying a PATA virtual disk controller rather than SATA, etc) but no existing open seems to make a difference.

My host is Windows 7 on amd64, and my guest is Debian GNU/Linux using 2.6.32.

Attachments (6)

vbox hang leela-2010-12-15-19-10-52.log (47.9 KB ) - added by Sam Morris 14 years ago.
vbox hang leela-2010-12-15-19-10-52.log
leela.txt (3.2 KB ) - added by Sam Morris 14 years ago.
out of 'vboxmanage showvminfo --details leela'
vminfo_workstation_linux_vb3.2.12.txt (3.1 KB ) - added by Victor Benso 14 years ago.
vboxmanage showinfo's output for another virtual machine presenting the same symptoms
workstation-linux_vb3.2.12.txt (79.6 KB ) - added by Victor Benso 14 years ago.
Log of a crashed session
VBox.log (77.6 KB ) - added by Jakob Østergaard Hegelund 13 years ago.
VB 4.0.8 freeze after 22 hours of operation. No (layman) clues in log.
VBox.2.log (156.2 KB ) - added by sebacea 8 years ago.

Download all attachments as: .zip

Change History (24)

by Sam Morris, 14 years ago

vbox hang leela-2010-12-15-19-10-52.log

by Sam Morris, 14 years ago

Attachment: leela.txt added

out of 'vboxmanage showvminfo --details leela'

comment:1 by aeichner, 14 years ago

Looks like a duplicate of #7514 or #7803. Can you try if reducing the number of CPUs to 1 helps?

comment:2 by Sam Morris, 14 years ago

I often find that performing a lot of I/O does cause the guest to hang, temporarily, but always with the disk activity indicator showing that the guest is blocked while reading data from/writing it to disk. That is not this bug; the temporary hang is resolved by merely waiting patiently.

When this bug occurs, the disk activity indicator is not lit. That is, the guest is not hanging while waiting for I/O to complete; rather, a batch of I/O caused virtualbox to freeze up.

I should also note that the magic sysrq key to trigger a reboot (alt+prtsc+b) does not work; the only way to recover is to power off the VM.

comment:3 by Sam Morris, 14 years ago

I will try dropping the number of CPUs down to 1, with with and without ACPI enabled.

BTW, in case this is a hardware specific problem (my colleague and I both have the same hardware, and I don't see this bug at home with a different computer), we both have Core i5 750 CPUs.

comment:4 by Sam Morris, 14 years ago

Reducing to 1 CPU and disabling the IO/APIC does not help, sadly.

by Victor Benso, 14 years ago

vboxmanage showinfo's output for another virtual machine presenting the same symptoms

by Victor Benso, 14 years ago

Log of a crashed session

comment:5 by Victor Benso, 14 years ago

I'm having the same symptoms yrro reported. Guest stays frozen but the VM can be closed (vbox UI stays responsive). Changing to a single core seems to have delayed the crashes, but the problem is not solved. If I leave the VM open overnight it will always frozen in the morning (perhaps some disk intensive task happens overnight). My host is Win7 64-bit with ubuntu 10.10 x86_64 (kernel 2.6.35-24)

comment:6 by Sam Morris, 14 years ago

When this happens, if I reset the machine, then it hangs again during bootup when the virtualbox init script runs VBoxService.

comment:7 by Frank Mehnert, 13 years ago

Still relevant with VBox 4.0.8?

comment:8 by Sam Morris, 13 years ago

It is much less frequent with 4.0.0 through 4.0.4, but still happens occasionally.

Not seen it with 4.0.8 yet, but I only installed it today :)

comment:9 by Lucas Hokanson, 13 years ago

Hey there, I'm getting the same issue myself, I used to have my VM hosted on an XP box that I now host on an Ubuntu 11 server utilizing the latest VB(4.0.8) and I still get the lock ups.

I am however suspect of mass database activity locking the machine. I host a Medawiki website that has had issues with MYSQL connections before. My issues have been correlatable to large hits of traffic.

Would love to see a fix or workaround for this.... It's quite frustrating and hard to troubleshoot.

in reply to:  description comment:10 by Jakob Østergaard Hegelund, 13 years ago

I have this issue too.

Host: VirtualBox 4.0.8 on Solaris 10 on Intel Xeon L5520 @2.27GHz.

Only one guest shows the problem - it is a SLES11SP1 with 2 processors and 2 GB memory. It hangs sometimes during heavy disk I/O.

Absolutely nothing is printed in the VBox.log when the hang happens. I can still connect remotely to the VBoxHeadless process and get the machine console (which looks normal except it does not respond to keypresses).

The only solution is to issue a poweroff with VBoxManage.

I have absolutely nothing to go on here... Adjusting memory size and processor count does not seem to change anything. Since no errors are reported anywhere and I have 12 other VMs running under the same host without any problems what so ever, I really don't know how to proceed with this.

Is there anything I can do to help narrowing down this issue?

comment:11 by Will Bickford, 13 years ago

I've seen this issue crop up recently in VirtualBox 4.0.8 when attaching a second SATA virtual disk to an Ubuntu virtual machine. Host is Windows 7 64-bit. Happens on the guest with any number of CPUs assigned (1 to 4). Host I/O cache is disabled. Guest is not running out of RAM.

Previously the system was fine (no lockups). The strange behavior started when I added a data-only virtual disk to expand available space. Verified with both a dynamic and fixed vdi. Both the primary OS disk and the expansion disk reside on the same physical disk. Primary is 16 GiB; Expansion is 40 GiB.

The UI locks for the duration of the I/O-intensive operations and then returns once they've completed. It seems like some sort of QoS issue. I tried enabling a different I/O scheduler on the guest (CFQ => deadline), but it had no effect.

I am going to attempt a single larger install to see if the issue stems from having an expansion virtual disk or some other factor.

comment:12 by Jakob Østergaard Hegelund, 13 years ago

wbic16: your system does not lock up, it only freezes temporarily?

I am attaching a VBox.log from my system which freezes almost on a daily basis now. The attached log shows a freeze after 22 hours of operation - the log shows my only remedy, power-off, too.

by Jakob Østergaard Hegelund, 13 years ago

Attachment: VBox.log added

VB 4.0.8 freeze after 22 hours of operation. No (layman) clues in log.

in reply to:  12 ; comment:13 by Will Bickford, 13 years ago

@joe42

Scratch my problem report. The issue boiled down to runaway scheduling of threads during parallel compile. Eclipse has an automatic setting that doesn't play well with my setup (Core i7 860, Windows 7 64-bit host, Ubuntu 11.10 64-bit guest). Essentially I was getting fork-bombed.

Sorry for any confusion.

--Will

in reply to:  13 comment:14 by Will Bickford, 13 years ago

Guest should be Ubuntu 10.04 LTS, not 11.10.

comment:15 by Frank Mehnert, 11 years ago

Description: modified (diff)
Resolution: fixed
Status: newclosed

Please reopen if still relevant with VBox 4.2.6.

by sebacea, 8 years ago

Attachment: VBox.2.log added

comment:16 by sebacea, 8 years ago

Resolution: fixed
Status: closedreopened

comment:17 by Frank Mehnert, 8 years ago

sebacea, please describe what happens. The VBox.2.log file you attached shows that the VM was properly shut down.

comment:18 by Frank Mehnert, 7 years ago

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use