VirtualBox

Ticket #7766 (closed defect: fixed)

Opened 3 years ago

Last modified 6 months ago

Guru Meditation -4005 (VERR_VMX_UNABLE_TO_START_VM) with Windows 7 32bit

Reported by: deller Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Since updating some software in the Windows7 guest OS, I'm now running regularly and reproducible into a "Guru Meditation -4005" crash. Virtual machine stops working and I need to reboot the guest then. Host is a 64bit Fedora 13 Linux, guest is 32bit Windows 7.

Attachments

VBox.log Download (294.5 KB) - added by deller 3 years ago.
VBox.log
VBox.2.log Download (281.1 KB) - added by deller 3 years ago.
VBox.log with crash on VirtualBox 4.0.8

Change History

Changed 3 years ago by deller

VBox.log

comment:1 Changed 3 years ago by deller

This is maybe the important part:

07:02:05.850 VERR_VMX_UNABLE_TO_START_VM: CPU0 instruction error 0
07:02:05.850 VERR_VMX_UNABLE_TO_START_VM: CPU0 exit reason 0
07:02:05.850 VERR_VMX_UNABLE_TO_START_VM: CPU1 instruction error 7
07:02:05.850 VERR_VMX_UNABLE_TO_START_VM: CPU1 exit reason 0
07:02:05.870 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!![[BR]] 07:02:05.870 ![[BR]] 07:02:05.870 !! Guru Meditation -4005 (VERR_VMX_UNABLE_TO_START_VM)

comment:2 Changed 3 years ago by deller

I changed the setting for that Win7 VM to use one CPU only instead of two. That way I didn't had any further guru meditations any more. Nevertheless, it would be nice if it could get fixed to work with 2 CPUs as well...

comment:3 Changed 3 years ago by deller

After upgrading to Virtualbox 4.0.8 (r71778 linux.amd64) the bug still exists (original report was for Virtualbox 3.2.10)
New VBox.log attached.

Changed 3 years ago by deller

VBox.log with crash on VirtualBox 4.0.8

comment:4 Changed 3 years ago by hajma

seeing the same. Host solaris11e, guest Windows XP

comment:5 Changed 16 months ago by deller

I could reproduce this crash up until (including) Virtualbox 4.0.16. Then I switched the hardware (CPU, board) while keeping all other components (host operating system=Fedora13, same harddisk and disk layout, same virtual machines).... and suddenly the crashes are gone...

In summary I have the feeling, that this crash only happened due to the Core2Duo E7600 CPU:

vendor_id       : GenuineIntel
cpu family      : 6
model           : 23
model name      : Intel(R) Core(TM)2 Duo CPU     E7600  @ 3.06GHz
stepping        : 10
microcode       : 0xa0b
cpu MHz         : 1603.000
cache size      : 3072 KB
cpuid level     : 13
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dtherm tpr_shadow vnmi flexpriority

Maybe there is some generic problem in Virtualbox with the Core2Duo E7600? At least I don't see this crash any longer on the i7-3770K CPU (with VirtualBox 4.0.16 and 4.0.18).

comment:6 Changed 16 months ago by deller

One further note regarding my comment #2 above:
Even with only one vCPU configured for the guest, I could see the crashes with the Core2Duo CPU - but *much* less often than with more vCPUs configured.

comment:7 Changed 6 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.3.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use