VirtualBox

Ticket #7670 (closed defect: duplicate)

Opened 3 years ago

Last modified 6 months ago

Windows guest crashes when 3D accel. is enabled and Nvidia Forceware driver is used

Reported by: Tron04 Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.2.10 Keywords: nvoglnt.dll nvidia
Cc: Guest type: other
Host type: Windows

Description (last modified by misha) (diff)

After windows xp sp3 starts in the guest (guest additions have to be installed!) and the windows boot logo disappears, the guest crashes as soon as windows graphics initialize. This happens only when 3D acceleration is enabled in the guest and the new nvidia forceware drivers 260.xx are used on the host system. The problem did not occur with older forceware drivers (eg. 258.89).

VirtualBox Gui crashes in ModName: nvoglnt.dll (which is the nvidia opengl dll). See crash report. My host system specs:  http://goo.gl/bdRZ

Attachments

9e91_appcompat.txt Download (35.4 KB) - added by Tron04 3 years ago.
VBox.log Download (44.4 KB) - added by Tron04 3 years ago.
VBox.log

Change History

Changed 3 years ago by Tron04

Changed 3 years ago by Tron04

VBox.log

comment:1 Changed 3 years ago by Technologov

There is one more user on the forum complaining on VBox crashes with NVIDIA:

 http://forums.virtualbox.org/viewtopic.php?f=6&t=36143&p=162469#p162469

-Technologov

comment:2 Changed 3 years ago by Steve Richards

I've got the same issue. Happens with 3d enabled.

I have multiple entries but the are all the same.

From Windows event log.

Faulting application name: VirtualBox.exe, version: 3.2.10.0, time stamp: 0x4caf2246

Faulting module name: nvoglv64.DLL, version: 8.17.12.6099, time stamp: 0x4cb9db45

Exception code: 0xc0000005

Fault offset: 0x0000000000761b28

Faulting process id: 0x1168

Faulting application start time: 0x01cb7d048a062161

Faulting application path: C:\PROGRA~1\Oracle\VirtualBox\VirtualBox.exe

Faulting module path: C:\Windows\system32\nvoglv64.DLL

Report Id: 1986917e-e8f8-11df-a4fa-00a0c6000000

comment:3 Changed 3 years ago by MrTAToad

Yes, same thing here too with the latest nVidia drivers (260.99) - it worked perfectly before nVidia updated their drivers.

It seems to be something to do with the intelppm.sys file. In addition, it ONLY happens with a Windows XP virtual machine and not Windows 2000 or Linux

comment:4 Changed 3 years ago by Technologov

This bug looks like a duplicate of bug #7516

-Technologov

comment:5 Changed 6 months ago by misha

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Marking as a dup of #7516.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use