VirtualBox

Ticket #7516 (closed defect: obsolete)

Opened 4 years ago

Last modified 2 months ago

Nvidia Graphics Driver 260.63 Breaks 3D Acceleration

Reported by: war59312 Owned by:
Priority: minor Component: 3D support
Version: VirtualBox 3.2.8 Keywords: crash, 3d, nvidia, not responding
Cc: Guest type: Windows
Host type: Windows

Description (last modified by misha) (diff)

Hi,

So I am running  http://www.nvidia.com/object/win7-winvista-64bit-260.63-beta-driver.html on Windows 7 x64.

If I enable 3D Acceleration for a Windows Guest OS and try to boot it up I get the wonderfully famous "VirtualBox GUI has stopped working" error screen.

  Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	VirtualBox.exe
  Application Version:	3.2.8.0
  Application Timestamp:	4c5aa88b
  Fault Module Name:	nvoglv64.DLL
  Fault Module Version:	8.17.12.6063
  Fault Module Timestamp:	4c8b035f
  Exception Code:	c0000005
  Exception Offset:	00000000007612d8
  OS Version:	6.1.7600.2.0.0.256.1
  Locale ID:	1033
  Additional Information 1:	3f76
  Additional Information 2:	3f76a2f97cb0d43752984c382605bc27
  Additional Information 3:	e1ac
  Additional Information 4:	e1ac6728c9b4377ec1de68f89139c85d

See Forum Thread @  http://forums.virtualbox.org/viewtopic.php?f=6&t=34764

Take Care,

Will

Attachments

Windows XP-2010-09-23-17-15-17.log Download (50.9 KB) - added by war59312 4 years ago.

Change History

Changed 4 years ago by war59312

comment:1 Changed 4 years ago by sandervl73

  • Priority changed from major to minor
  • Status changed from new to closed
  • Resolution set to invalid

Very nice, but the crash is inside NVidia code and the driver is a beta. If it happens with the release driver, then we might want to look at it.

comment:2 Changed 4 years ago by war59312

  • Status changed from closed to reopened
  • Resolution invalid deleted

Well that would be fine but as expected it still is not fixed in a stable build. :(

Still broke with 260.89 WHQL drivers:

 http://www.nvidia.com/object/win7-winvista-64bit-260.89-whql-driver.html

I posted while in beta so that you guys could look into it. Instead you use the beta excuse to ignore it.

So now a new stable Nvidia driver is out and this was still NOT fixed in VirtualBox 3.2.10.

See that's what happens when you don't look into it just because it's a beta. The whole point of beta is to find issues before it goes to a stable release.

So now you just look lazy!!

comment:3 Changed 4 years ago by sandervl73

The whole point of a beta is to report problems to the one issuing the beta. So did you report this to NVidia? All your sarcasm isn't going to convince us to take you more seriously.

comment:4 Changed 4 years ago by sandervl73

Installed the drivers in Windows 7 x64. Can't reproduce your crash.

comment:5 Changed 4 years ago by war59312

Of course reported to Nvidia and what do they say?

You guessed it, they say it's an issue with Virtual Box not their drivers.

So you say its them and they say no its you and back and forth you go and nothing gets done.

And now you say you cant reproduce. Just great! Thankfully the workaround as posted in the thread works.

comment:6 Changed 4 years ago by CrendKing

I suffer the same problem. VirtualBox works fine with NVIDIA's v258 driver. It crashes after I install the stable 260.89 driver. Fault module is same as war59312, nvoglv64.DLL. I need to disable the 3D acceleration make VM run.

comment:7 follow-up: ↓ 8 Changed 3 years ago by zlogic

I'm also having this issue. Windows 7 64-bit host, Nvidia 260.89 drivers (performed a clean install with removing previous drivers), Windows XP 32-bit as the guest OS, Virtualbox 3.2.10.

comment:8 in reply to: ↑ 7 Changed 3 years ago by kevinkk

i have the same problem. Im using the stable nvidia driver 260.89 and my VM crashes and it doesn´t matter which version of VirtualBox i´m using so the error must be in the nvidia driver!

comment:9 Changed 3 years ago by CodeM0nkey

I can also confirm as having this issue after installing the latest WHQL NVidia drivers (260.89). There is a workaround that I found  here however that seems to address the issue for now.

Create an application profile for VirtualBox.exe in the Nvidia Control Panel, and set Threaded Optimisation to On or Off.

comment:10 Changed 3 years ago by genisis

Installed NVidia Drivers Pack 260.99, also upgrade Virtual box to latest version.

Get the following message:

Problem signature:

Problem Event Name: APPCRASH Application Name: VirtualBox.exe Application Version: 3.2.12.0 Application Timestamp: 4cf64209 Fault Module Name: nvoglv64.DLL Fault Module Version: 8.17.12.6099 Fault Module Timestamp: 4cb9db45 Exception Code: c0000005 Exception Offset: 0000000000761b28 OS Version: 6.1.7600.2.0.0.256.4 Locale ID: 2057 Additional Information 1: 3f76 Additional Information 2: 3f76a2f97cb0d43752984c382605bc27 Additional Information 3: 4d12 Additional Information 4: 4d12e41703a5369c2d401c1a91c62709

Disabled 'Enabled 3D Acceleration', then fired up VM which now worked.

Upgraded Guest Additions and also selected 3D support. Rebooted VM and then re-enabled 3D Acceleration, Error came back.

Conclusion there is a capatablitly issue between the NVidia Drivers and Virtualbox for 3D support. It should also be noted that the 3D support does work with NVidia Driver Pack v258.96.

Can this be added to the list of things to fix please?

comment:11 Changed 3 years ago by Technologov

A possible duplicate of this bug found: #7670

-Technologov

comment:12 Changed 3 years ago by Technologov

Oracle: Please up priority from "minor" to "Critical"

-Technologov

comment:13 Changed 6 months ago by misha

  • Description modified (diff)

Could you check whether the issue is fixed with VBox 4.3 and 4.3 Additions?

comment:14 Changed 2 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use