VirtualBox

Opened 14 years ago

Closed 13 years ago

#7605 closed defect (fixed)

VirtualBox causes a restart of host-system (Linux and Windows)

Reported by: Nils Owned by:
Component: other Version: VirtualBox 3.2.10
Keywords: restart of host Cc:
Guest type: Linux Host type: Linux

Description

  1. Host: Ubuntu 10.04 LTS 32bit or Windows7 64bit (same problem)

1.2 Guest: Ubuntu 10.04 LTS 32bit - minimal virtual server
2.1 Guest: try to install Ubuntu, start a ubuntu-10.10-alternate-i386.iso

Guest 1.2 running normal.
Starting of guest 2.1 via "VBoxHeadless --startvm test &".
Look on guest 2.1 "rdesktop -a 16 guest(1.2)_ip".
When I try to "install ubuntu" the Host 1. restart!

Attachments (6)

VBox.log (36.0 KB ) - added by Alex Villacís Lasso 14 years ago.
Log of session that eventually rebooted host. Kernel is 2.6.36.
config-original.config (102.1 KB ) - added by Alex Villacís Lasso 14 years ago.
Kernel configuration used to compile crashing kernel
config-nocrash.config (107.3 KB ) - added by Alex Villacís Lasso 14 years ago.
Kernel configuration used to compile non-crashing kernel
VBox.2.log (39.6 KB ) - added by aispobla 14 years ago.
Ubuntu 10.10
VBox.3.log (36.4 KB ) - added by airstep 14 years ago.
Faulted when check disk's on system Win2003 startup. Also randomly fault on system work, often when run debug mode in Visual Studio.
VBox.log.3 (300.7 KB ) - added by airstep 14 years ago.
ArchLinux. Some detailed crash log.

Download all attachments as: .zip

Change History (23)

comment:1 by Sander van Leeuwen, 14 years ago

No VBox.log -> nothing we can say or do.

comment:2 by Frank Mehnert, 14 years ago

Cc: and 3.2.8 removed

comment:3 by Alex Villacís Lasso, 14 years ago

I can provide more information on this bug, as this happens on my Fedora 12 system (but not with the default kernel). This is a regression from 3.2.8.

My affected system is a Fedora 12 x86_64 system with a CPU that has *no* support for hardware virtualization. Therefore, I run 32-bit guests only. I also run self-compiled kernels from vanilla source from kernel.org. The kernels on which I noticed the issue are 2.6.36-rc6 and 2.6.36-rc8.

After installing VirtualBox 3.2.10 on the affected host, I noticed that my Windows XP-SP2 guest caused a host reboot after a minute or so. WinXP manages to show the desktop, and I move the mouse around, and the host reboots. I thought that this might be a regression on Guest Additions, so I uninstalled them in the short time window before the host reboot, only to find that another guest, a CentOS 5.5-based distro (Elastix 1.6) also caused a host reboot. Unlike the WinXP guest, the CentOS 5.5 distro runs a 2.6.18-based kernel with no Guest Additions installed. Both of these reboots happened with the -rc kernels. When I rebooted the host with the updated stock Fedora 12 kernel (2.6.32.21-168.fc12.x86_64), the host reboot did not happen.

Ubuntu-10.10 uses the 2.6.35-22-generic kernel, so this problem is not limited to the 2.6.36-rcX kernels, since a 2.6.35 kernel is affected too.

Another data point: this issue only appears when VirtualBox is *not* using hardware virtualization on a x86_64. As I write this, my work machine (x86_64 with hardware virtualization) is running a 2.6.36-rc8 kernel on the host and Ubuntu-10.10 on a 32-bit guest, with no issues whatsoever. I also ran the Elastix (CentOS-5.5 compatible) distro, also with no issues.

Something that might be useful: when booting Elastix, you can watch the kernel booting, up until the point when the console shows the message: "Starting udev...". After a second or so, the host reboots. With the Elastix 32-bit installation, this is 100% reproducible.

I tried to examine the VirtualBox log, but there is no suspicious message there. No guru meditation or anything. Just a truncated boot process.

comment:4 by Alex Villacís Lasso, 14 years ago

I suggest changing the "Component" classification to "VMM/RAW", as this seems to be an issue with software virtualization.

comment:5 by Alex Villacís Lasso, 14 years ago

Bug #7540 might be related, but my affected computer does not display any BIOS option to enable hardware virtualization, so I cannot enable it at will.

comment:6 by Frank Mehnert, 14 years ago

Thanks for the additional information but please, could you attach a VBox.log of such a VM which rebooted the host anyway? It will show us more of the configuration of your VM. Thank you!

by Alex Villacís Lasso, 14 years ago

Attachment: VBox.log added

Log of session that eventually rebooted host. Kernel is 2.6.36.

by Alex Villacís Lasso, 14 years ago

Attachment: config-original.config added

Kernel configuration used to compile crashing kernel

by Alex Villacís Lasso, 14 years ago

Attachment: config-nocrash.config added

Kernel configuration used to compile non-crashing kernel

comment:7 by Alex Villacís Lasso, 14 years ago

I have discovered that the host reboot is sensitive to the kernel configuration. I have attached two kernel configurations. The first, "config-original.config", was the one I used for compiling the 2.6.36 vanilla kernel that reboots a while after starting VirtualBox. The second, "config-nocrash.config", is the result of running "make oldconfig" on the kernel configuration found in the Fedora 14 LiveCD for x86_64, but copied into the 2.6.36 vanilla kernel tree, and used for compilation. This one does NOT crash on running my virtual machines. Other than realizing this difference, I have not analyzed in detail the nature of the change that makes one stable and not the other.

comment:8 by Frank Mehnert, 14 years ago

This bug will be most probably fixed in the next maintenance release. You could also install a test build of the upcoming release to verify that your problem is indeed fixed.

by aispobla, 14 years ago

Attachment: VBox.2.log added

Ubuntu 10.10

comment:9 by aispobla, 14 years ago

I have the same problem, after of update kernel of 2.6.35 at 2.6.36. Use ArchLinux 64 with VirtualBox-ose, but is the same problem, when start virtualbox, the system reboot after of one minut or two. I haven't hardware virtualization.

by airstep, 14 years ago

Attachment: VBox.3.log added

Faulted when check disk's on system Win2003 startup. Also randomly fault on system work, often when run debug mode in Visual Studio.

by airstep, 14 years ago

Attachment: VBox.log.3 added

ArchLinux. Some detailed crash log.

comment:10 by airstep, 14 years ago

Downgrade to kernel26 2.6.35.8-1 helps a lot. Now virtualbox-ose 3.2.10-3 works good. So this bug depends on kernel issue.

in reply to:  10 ; comment:11 by aispobla, 14 years ago

Replying to airstep:

Downgrade to kernel26 2.6.35.8-1 helps a lot. Now virtualbox-ose 3.2.10-3 works good. So this bug depends on kernel issue.

In ArchLinux 64 also work fine in my PC with kernel 2.6.38.8-1. Nothing problem with kernel 2.6.35.8-1.

in reply to:  11 ; comment:12 by airstep, 14 years ago

Replying to aispobla:

In ArchLinux 64 also work fine in my PC with kernel 2.6.38.8-1. Nothing problem with kernel 2.6.35.8-1.

There is some mistake in your's post. Latest git kernel version in development is 2.6.37-rc4 for today...

in reply to:  12 comment:13 by aispobla, 14 years ago

Replying to airstep:

Replying to aispobla:

In ArchLinux 64 also work fine in my PC with kernel 2.6.38.8-1. Nothing problem with kernel 2.6.35.8-1.

There is some mistake in your's post. Latest git kernel version in development is 2.6.37-rc4 for today...

Yes, I'm sorry... I wanted say kernel 2.6.35.8-1! I'm sorry also by my english...

comment:14 by airstep, 13 years ago

Seems this issue was fixed with VirtualBox 3.2.12 version. Thanks.

comment:15 by Frank Mehnert, 13 years ago

The original reporter mentioned Windows 7 as well. fry@linux, still reproducible with VBox 3.2.12 on Windows 7?

comment:16 by Frank Mehnert, 13 years ago

Oh, and thanks for the feedback airstep!

comment:17 by Frank Mehnert, 13 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use