VirtualBox

Ticket #7540 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

running WinXP in VM resets the linux kernel of the host => Fixed in SVN

Reported by: norbusan Owned by:
Priority: major Component: VMM/RAW
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I am running VIrtualBox 3.2.8 on Debian/sid, kernel 2.6.36-rc6 self compiled. When I start the Windows XP virtual machine that worked until recently, then one of the following things happens (all of them happened to me several times, on several occations):

  • the Windows XP VM resets
  • linux kernel resets and reboots the laptop

Unfortunately the VirtualBox does not leave any traces in the syslog of the host, since the reset happens instantly and nothing is flushed to the disc. I attach a VBox.log from a run on the same day, where I also had several resets of the VM.

Attachments

VBox.log Download (44.7 KB) - added by norbusan 4 years ago.
log file of running vm when the kernel was reset

Change History

comment:1 Changed 4 years ago by frank

The problem might be fixed with the next maintenance release as we fixed a bug which could be related. But of course I'm not sure. You could also try to unlock VT-x in your BIOS (because it is currently not available, so most probably disabled in the BIOS).

comment:2 Changed 4 years ago by norbusan

Hi Frank! I tried it now with:

  • unlocked VT-x in BIOS
  • vbox 3.2.10

with the same result. There is never any dump or crash report of course since it is a complete hard lockup, immediate reboot of the machine.

I have no idea how to trace that further.

Thanks and all the best

Norbert

comment:3 Changed 4 years ago by frank

  • Version changed from VirtualBox 3.2.8 to VirtualBox 3.2.10

Thanks Norbert for the feedback. Does the VM create a VBox.log file before the host reboots? If so, could you attach the log file?

Changed 4 years ago by norbusan

log file of running vm when the kernel was reset

comment:4 Changed 4 years ago by norbusan

Hi Frank!

I have retried now and a log file has been created, the currently attached log file to this bug report is what I got today.

There is one point I was suprised at: I have the feeling that VirtualBox believes that I don't have VMX enabled, but the /proc/cpuinfo shows me the vmx bit is set, but in the log file it seems it is set to 0.

In case you need it, I am currently running linux-2.6 git HEAD as of yesterday.

Thanks a lot and all the best, and let me know if I can provide any other explanation.

Norbert

comment:5 Changed 3 years ago by frank

The logfile says that VT-x is locked or disabled. Please check the BIOS settings of your host, many hardware vendors disable VT-x in the BIOS for some reason. Of course, the host should not reboot without VT-x.

comment:6 Changed 3 years ago by frank

Hmm, you don't use any Linux performance counters while executing the VM, do you?

comment:7 Changed 3 years ago by norbusan

Hi Frank!

That is strange ... why does the /proc/cpuinfo say something else here? How else can I check for that bit?

Concerning performance counters: Not that I know of, what would be the kernel config option for that, or program running?

Thanks

Norbert

comment:8 Changed 3 years ago by frank

  • Component changed from other to VMM/RAW

Well, the extension is there but not usable because locked by the BIOS or by someone else.

Performance counters: That should be not the case (at least I hope so) if you don't know what I'm talking about :) See linux-2.6.35.../tools/perf.

comment:9 Changed 3 years ago by norbusan

Ok, I will check again in my bios, since it is a stupid sony with a locked down bios I have to enable some magic trick to access the full bios, and then enable the vm-x flag.

Concerning perf counters: Yes, they, or better there replacement PERF_EVENTS is compiled into the kernel, but I am not running any user space utility. Should I try to disable that one?

comment:10 Changed 3 years ago by frank

Yes, trying a kernel with PERF_EVENTS disabled would be great. So far I thought that this code is not used if no process is started which uses these perfcounters but I might be wrong. If you enabled VT-x in the meantime, make sure to disable it in the VM settings before doing the test with the recompiled Linux kernel. Thanks!

comment:11 Changed 3 years ago by tholin

I also started experiencing this problem after upgrading to 2.6.36. My system doesn't have any hardware visualization capability so I don't think it's related to that.

I'm guessing the problem is related to the new lockup detector in 2.6.36:

"lockup_detector: Combine nmi_watchdog and softlockup detector

The new nmi_watchdog (which uses the perf event subsystem) is very similar in structure to the softlockup detector. Using Ingo's suggestion, I combined the two functionalities into one file: kernel/watchdog.c.

Now both the nmi_watchdog (or hardlockup detector) and softlockup detector sit on top of the perf event subsystem, which is run every 60 seconds or so to see if there are any lockups."

I didn't have CONFIG_NMI_WATCHDOG set in my previous kernel but for some reason I had CONFIG_LOCKUP_DETECTOR set in my new kernel. I have disabled the lockup detector now but I haven't had the courage to test vbox yet. You other people can try first :)

bug #7605 is a dup of this.

norbusan: What type of magic do you use for accessing the full bios? The bios on my laptop is very minimal. It would be nice to get the full range of options.

comment:12 Changed 3 years ago by norbusan

@frank: I have now again enable the full BIOS menu and there two different options for virtualization, but still I see

00:00:00.925 VMX - Virtual Machine Technology = 0 (1)

in the log file. Anyway. at least the last time I was running VBox it succeeded to actually run for an extended period of time without crash. No idea if it is related, but I will make more tests soon.

@tholin: see  http://feature-enable.blogspot.com/2009/07/enable-vt-on-insydeh2o-based-sony-vaio.html

comment:13 Changed 3 years ago by frank

  • Summary changed from running WinXP in VM resets the linux kernel of the host to running WinXP in VM resets the linux kernel of the host => Fixed in SVN

Yes, makes sense (the host NMI setup is guilty). There will be a fix in the next maintenance release which should solve your problems. The workaround is to enable VT-x/AMD-V.

comment:14 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in VBox 3.2.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use