VirtualBox

Ticket #7560 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

GA in VirtualBox 3.2.8 for Ubuntu 10.10 are not working as it should

Reported by: abcuser Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Hi, yesterday I have installed new version of Ubuntu 10.10 as a guest of VirtualBox 3.2.8 on Windows XP SP3 host. Installation went without a problem. Then I have installed guest additions and restart guest. The following problems:

  1. Fullscreen mode does not work - it looks like Ubuntu is using new version of X.org and GA is not supporting it.
  2. Mouse integration does not work.
  3. Copy/paste between guest and host (and vice versa) does not work.

It looks like GAs is not working for Ubuntu 10.10. Regards

Attachments

VBox.log Download (88.9 KB) - added by abcuser 4 years ago.
monitor_crash.png Download (65.4 KB) - added by abcuser 4 years ago.

Change History

Changed 4 years ago by abcuser

comment:1 Changed 4 years ago by abcuser

I have tried to reinstall GA and it looks error was reported in the first place I installed GA.

Building the VirtualBox Guest Additions kernel modules
Building the main Guest Additions module ...done.
Building the shared folder support module ...done.
Building the OpenGL support module ...done.
Doing non-kernel setup of the Guest Additions ...done.
Starting the VirtualBox Guest Additions ...done.
Installing the Window System drivers
Warning: unknown version of the X Window System installed. Not installing X Window System drivers.
Installing graphics libraries and desktop services components ...done.

comment:2 Changed 4 years ago by mdaniel

This appears to be a dupe of ticket:7306

comment:3 Changed 4 years ago by abcuser

In bug 7306 is reported that x.org is not recognized. In my case two additional problems appear: mouse integration and copy/paste to/from host.

comment:4 Changed 4 years ago by mdaniel

Have you tried it with the VBoxGuestAdditions_3.2.9-66155.iso as linked in that ticket?

I have Ubuntu 10.10 amd64 in VBox 3.2.8 with those guest additions and all three items work correctly: the x.org driver, mouse integration and copy-and-paste.

comment:5 Changed 4 years ago by michael

The X.Org drivers are also in charge of mouse integration. Clipboard integration should work without them though as that is X11 "user space".

Changed 4 years ago by abcuser

comment:6 Changed 4 years ago by abcuser

@mdaniel, I have executed VBoxGuestAdditions_3.2.9-66155.iso and after some seconds monitor was filled with some strange letters, see attachment monitor_crash.png and this screen was up and no refreshing. I just waited that disk icon in VirtualBox GUI stopped displaying pulsing, so I was sure that installation was finished. I clicked on "X" to close VirtualBox and selected "Power Off". Restarted a guest and now all three problems disappeared.

Problem solved and bug report can be closed as solved. P.S. This "monitor_crash" can frighten average user to power-off guest too early. :)

comment:7 Changed 4 years ago by mdaniel

Yes, if you read the same comments on the ticket that I pointed you to, you'd be aware that the monitor corruption is expected behavior. Further, the disclaimer right below that download link says that those are pre-release ISOs and should be treated as such.

I bet a Euro that the GA of 3.2.10 (which is where they are targeting this fix, IIRC) will not have any such problems.

comment:8 Changed 4 years ago by klaus

  • Status changed from new to closed
  • Resolution set to duplicate

duplicate of #7306. 3.2.10 is released, btw.

comment:9 Changed 4 years ago by abcuser

Today I have installed VirtualBox 3.2.10 and I can confirm, that this problem is solved. Thanks a lot for help.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use