VirtualBox

Ticket #7306 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Support X.org 1.9.0 -> fixed post-3.2.8

Reported by: cartman Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Ubuntu 10.10 (pre-beta now) switched to X.org 1.9.0 RC 5, it would be nice if Virtualbox drivers are updated to support it.

Change History

comment:1 Changed 4 years ago by adept

X.org 1.9.0 is finally released. Please, update guest additions :)

comment:2 Changed 4 years ago by 3vi1

Yes please! This is basically the only issue I have with VBox at the moment.

comment:3 in reply to: ↑ description Changed 4 years ago by a99

Please! I want to test Ubuntu 10.10 alphas and betas in a virtual environment.

comment:4 Changed 4 years ago by michael

  • Summary changed from Support X.org 1.9.0 to Support X.org 1.9.0 -> fixed post-3.2.8

Done.

comment:5 Changed 4 years ago by cartman

Any chance of getting updated additions iso file?

comment:7 Changed 4 years ago by cartman

Thanks!

comment:8 Changed 4 years ago by michael

Ticket #7425 has been marked a duplicate of this one.

comment:9 Changed 4 years ago by dutchguy69

this is now working with the new version of guest additions via  http://www.virtualbox.org/download/testcase/VBoxGuestAdditions-r65553.iso

comment:10 Changed 4 years ago by a99

Thank you! It works :)

comment:11 Changed 4 years ago by frank

A more up-to-date test build of the VBox Guest Additions can be found  here.

comment:12 follow-up: ↓ 13 Changed 4 years ago by os2mac

 http://imgur.com/NNmNt.png

screen shot of Ubuntu Maverick Meerkat RC1 running in a VM on OSX after to install

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions_3.2.9-66155.iso

comment:13 in reply to: ↑ 12 Changed 4 years ago by os2mac

Replying to os2mac:

 http://imgur.com/NNmNt.png

screen shot of Ubuntu Maverick Meerkat RC1 running in a VM on OSX after to install

 http://www.virtualbox.org/download/testcase/VBoxGuestAdditions_3.2.9-66155.iso

however after a reboot of the VM it appears to be working correctly.

comment:14 Changed 4 years ago by frank

That will be fixed in the final 3.2.10 release.

comment:15 Changed 4 years ago by cakebunny

Well, I still got a few problems when using VBoxGuestAdditions_3.2.9-66155.iso in Arch Linux. The following error says failed to load kernel module "vboxvideo".

[    46.910] [drm] failed to load kernel module "vboxvideo"
[    46.910] (EE) [drm] drmOpen failed.
[    46.910] (EE) VBoxVideo(0): DRIScreenInit failed, disabling DRI.

However, in the previous output, I can see the vboxvideo module has already been loaded.

[    46.249] (II) LoadModule: "vboxvideo"
[    46.250] (II) Loading /usr/lib/xorg/modules/drivers/vboxvideo_drv.so
[    46.266] (II) Module vboxvideo: vendor="Oracle Corporation"
[    46.266] 	compiled for 1.5.99.901, module version = 1.0.1
[    46.266] 	Module class: X.Org Video Driver
[    46.266] 	ABI class: X.Org Video Driver, version 8.0
[    46.266] (**) Load address of symbol "VBOXVIDEO" is 0xb74b7060

I can still startx, but when I drag the window around, I can see the window flickering.

comment:16 follow-up: ↓ 17 Changed 4 years ago by michael

I take it from the log snippet you posted that that is a 32bit guest.

comment:17 in reply to: ↑ 16 Changed 4 years ago by cakebunny

Replying to michael:

I take it from the log snippet you posted that that is a 32bit guest.

Yes, I am using a 32bit guest,doesn't guest additions support 32 bit guest?

comment:18 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:19 Changed 4 years ago by michael

cakebunny: could you please create a new ticket for your issue? I would do it myself, but I can't automatically subscribe you.

comment:20 Changed 3 years ago by jlac10

  • Status changed from closed to reopened
  • Resolution fixed deleted

same problem here (cakebunny)v3.2.10. please help.

comment:21 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate

I assume this is a duplicate of #7572. So either install (if possible) DKMS in your guest and do /etc/init.d/vboxadd setup or change the Makefile as proposed in #7572 and do /etc/init.d/vboxadd setup.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use