VirtualBox

Ticket #7530 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

KeyCodes as seen by xev are not passed transparently to Linux guest -> duplicate of #2595

Reported by: dov.grobgeld@… Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

My actual problem is that in the latest version of VirtualBox that I am using, the Alt key is mapped to Menu key in my guest WindowsXP. But as I don't understand much of Windows key code management, I am reporting this bug, which to me seem related.

xev ( http://www.x.org/archive/X11R7.5/doc/man/man1/xev.1.html) as run natively in my Fedora linux host and as run in a Fedora Guest do not report the same keycodes for the same keys. I would expect VirtualBox to transfer keycodes transparently without any translation.

E.g. the following three keys in the lower left corner of the keyboard [Ctrl], [Win], [Alt] yield the following keycodes under the Fedora host and at the Fedora guest as reported by the keycode field of xev:

Fedora host: 37, 133, 64 Fedora guest: 64, 115, 115

Can I influence the mapping, i.e. is there a host-to-guest keycode translation table? Or is the mapping done by host keysyms to guest keycodes? Is there a configuration option for that?

Change History

comment:1 Changed 4 years ago by dov.grobgeld@…

I should perhaps add that I am using a heavily customized keyboard mapping in Linux: Dvorak layout + swapped control and Caps Lock. But again, I would expect the keycodes to be transfered transparently and that the host host keycode-to-keysym map should not influence.

comment:2 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from KeyCodes as seen by xev are not passed transparently to Linux guest to KeyCodes as seen by xev are not passed transparently to Linux guest -> duplicate of #2595

Unfortunately, we can't just do straight keycode to scan code mapping (at least not without sanity checks, which are defeated by your Dvorak layout), as this can fail in some setups. At some point I will switch to using XKB to get keyboard information which I hope will solve these issues.

Marking this a duplicate of ticket #2595.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use