VirtualBox

Ticket #7443 (reopened defect)

Opened 4 years ago

Last modified 13 days ago

Guest Addition brakes mouse: instant scrolling instead of pointer movement

Reported by: zolotov Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

Host OS: Win7HomeBasic

Guest OS: WinXP SP3

VBox version: 3.2.8

PC(Notebook): Samsung R519

After installation of the Guest Additions touchpad (and usb-mouse too) does not work properly in guest OS: any application that have scrollbars (tested on notepad, MS Office 2007, MS Paint) do constant scrolling down to the bottom of the document when touchpad is used or mouse is moved. The direction of the mouse's movement does not influence on the applications behaviour. It just scrolls down. Installation of the official touchpad drivers into guest OS does not help. The pointer does not react on any movement after the driver installation. The mouse (and touchpad) worked fine before Guest Additons installation. Uninstallation makes mouse work back as well.

Attachments

testXP-2010-09-07-19-06-48.log Download (48.7 KB) - added by zolotov 4 years ago.

Change History

Changed 4 years ago by zolotov

comment:1 Changed 4 years ago by cyrex

I can confirm this on the following settings:

Host: Ubuntu 9.04 32Bit Guest: Windows XP SP3
Host: Ubuntu 9.10 32Bit Guest: Windows XP SP3
Host: Ubuntu 10.04 32Bit Guest: Windows XP SP3
Host: Windows 7 32Bit Guest: Windows XP SP3

All for settings were Tested on 2 Intel Motherboards with Core 2 Duo and 4GB Memory, 1 AMD Gigabyte with 4GB Ram, 1 Laptop Dell, 2 Laptop HP.

In ALL!! of this cases it was the same result. After installing the Guest Addition the mouse would:

  1. Scroll any scrollable window when moving the mouse. If you moved the mouse, the scrolling bar would start scrolling downwards.
  2. When you selected several files while holding the left button, it would automatically click on all files and sometimes multiple times on each one.
  3. The click event would sometimes think it was double clicking, triple clicking and even more.
  4. When dragging any windows (If you could in very few cases) the window would start doind weird stuff like maximizing, minimizing, moving to sides, etc... Like the drag option of the mouse would have been overtaken by a digital ghost.

I DO NOT recommend to anyone running the Guest Addition until this is fixed. It worked many versions ago correctly and i mean MANY versions ago.

comment:2 Changed 4 years ago by zolotov

I've just tested VirtualBox-3.2.10 + GA. The bug is still there.

comment:3 Changed 4 years ago by cyrex

Tested 3.2.10 + GA. Same as Zolotov. This MUST be the worst problem ever. The Windows guest OS can NOT be used with this problem. It is better to not have the mouse than having it, since moving the mouse, scrolling the mouse or whatever you want to do with a scrolling windows damages everything. Do not even try to highlight several files with this, you will automatically try to execute all of them. Forget about drag/drop support. If this is not fixed by the next update am moving to any other virtualization technology available since this makes using virtualbox a pain.

comment:4 Changed 3 years ago by frank

I cannot reproduce this issue (see below). Are both of you using 3D + 2D acceleration for this VM? Any difference if 2D+3D are disabled?

zolotov, installing the touchpad drivers should not make any difference because the guest works with a virtual mouse device.

And please could you be more specific with the bug description: ... any application that have scrollbars (tested on notepad, MS Office 2007, MS Paint) do constant scrolling down to the bottom of the document when touchpad is used or mouse is moved... -- what do you mean by used? Do you just move the touchpad over the window, are you pressing the lower button of the scroll bar to start scrolling or do you use the scroll area of your touchpad? I have tried all of these and could not reproduce any unusual behavior.

comment:5 Changed 3 years ago by zolotov

Both 2D&3D were enabled. I've disabled both (3+2D) and installed GA, and got the same result - instant scrolling.

what do you mean by used?

The term "used" in my previous post mean: (1) sliding in any direction by the sensors' surface, not click or double click. (2) The sliding area of touchpad behave the same as the whole touchpad, i.e. there is no difference among touching center, sliding area o anything else. (3) I did no try to scroll. I just moved the cursor and that produced the scrolling.

comment:6 Changed 3 years ago by cyrex

Confirmed. When using either 2D, 3D or both is the same. When installing the GA the mouse goes crazy. I even manage to restart the Guest PC when dragging a windows, well "trying" to drag a window.

And for the weird question about "use" the Term is when you MOVE, CLICK, DOBLE CLICK, RIGHT CLICK, ANY CLICK, SCROLL UP, SCROLL DOWN, SCROLL SIDEWAYS, SCROLL WHATEVER, MOVE THE MOUSE WHEN NO TOP OF A WINDOW WITH A SCROLLBAR. That is the complete "use" part. And NO, it is not a programa specific, it is the complete GA specific. Windows XP, Windows Vista, Windows Whatever you like was the same problem. The problem does not appear when using another Linux OS as the Guest. So if am using Linux Host and Linux Guest no problem. But if i used the Guest as Windows it appears, no matter what the combination of Host/Guest might be. Guest can not be Windows when using the GA.

Is it more clear now?

comment:7 Changed 3 years ago by cyrex

STILL present in Virtualbox 4.0.2 AND 4.0.4

This is the worst annoying bug ever and nothing has been done for a long while.

HOST: Ubuntu 10.10 32 Bit GUEST: Windows XP 32 Bit

If you happen to move the mouse, just move it inside a window that has the scrolling option in the right side because of so many files or folders it will trigger the mouse to start scrolling downwards. If you try to drag and select something with a window that has the scrolling option because of too many items no that folder like subfolder or files it will not let you, it will start scrolling downwards. if you move the mouse up, down, left, right, whatever IT WILL SCROLL DOWNWARDS.

So if you understand this then you know that installing the Guest Addition will confuse VirtualBox into thinking that any movement from the mouse is the user scrolling downwards.

comment:8 Changed 3 years ago by HvN

Confirmed here.

HOST: Windows 7 Professional 64 Bit GUEST: Windows XP Professional SP3 32 Bit

Same error pattern as with all the other reportings.

comment:9 Changed 3 years ago by HvN

I forgot: Newest VB version, newest guest additions.

comment:10 Changed 3 years ago by HvN

POSSIBLE SOLUTION (this might only apply to german WinXP or similar, NOT THOROUGHLY TESTED):

Install Guest Additions.

Open Device Manager, choose Mouse, right click -> "update driver", choose no on windows update foobar, "install from list or specific location", "don't search, I will choose myself". Remove check on "show only compatible hardware".

Now the maybe tricky part and why I wrote "might only apply to german Win": The installed driver is called "Microsoft PS/2-Maus", I chose "Microsoft PS/2 Mouse", installed it and it worked. 2x OK confimation, restart, works. Hell knows why.

comment:11 Changed 3 years ago by elvis2

Another Solution: goto mouse > properties

Disable scrolling or set to "none".

Of course you have no scrolling but at least you can use the vm.

comment:12 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

comment:13 Changed 13 days ago by msullivan021

  • Status changed from closed to reopened
  • Resolution obsolete deleted

I just installed VirtualBox a week ago, and I am still having this problem. This issue is not obsolete, and should be reopened.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use