VirtualBox

Ticket #7029 (closed defect: fixed)

Opened 4 years ago

Last modified 19 months ago

BSOD win7 x64 everytime

Reported by: OxOOCOFFEE Owned by:
Priority: blocker Component: USB
Version: VirtualBox 3.2.4 Keywords: Clear 4C USB missing UI BSOD
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

This might be related to bug #6922 that I reported.

As reported in bug 6922 vbox fails to start when Clear 4G USB connected but virtualbox.exe is running in Task Manager. Now if I pull out the Clear 4G USB card from laptop while virtualbox.exe process is running (no ui visible) windows crashes to BSOD every time. If I first kill virtualbox.exe process first than pulling out USB is not a problem. It took me some time to notice this since my first impressions were that this was purely random and it was problem with Clear. Also there seems to be a problem with this version with USB external floppy (also reported by me) failing to mount floppy in guest (windows XP x32). Below is log of a crash from my host (Win7 x64)

Log Name: System Source: Microsoft-Windows-Kernel-PnP Date: 6/18/2010 5:34:07 PM Event ID: 219 Task Category: (212) Level: Warning Keywords: User: SYSTEM Computer: laptop Description: The driver \Driver\WUDFRd failed to load for the device USB\VID_147E&PID_1000\5&899163b&0&1. Event Xml: <Event xmlns=" http://schemas.microsoft.com/win/2004/08/events/event">

<System>

<Provider Name="Microsoft-Windows-Kernel-PnP" Guid="{9C205A39-1250-487D-ABD7-E831C6290539}" /> <EventID>219</EventID> <Version>0</Version> <Level>3</Level> <Task>212</Task> <Opcode>0</Opcode> <Keywords>0x8000000000000000</Keywords> <TimeCreated SystemTime="2010-06-18T22:34:07.578833500Z" /> <EventRecordID>27278</EventRecordID> <Correlation /> <Execution ProcessID="4" ThreadID="44" /> <Channel>System</Channel> <Computer>laptop</Computer> <Security UserID="S-1-5-18" />

</System> <EventData>

<Data Name="DriverNameLength">35</Data> <Data Name="DriverName">USB\VID_147E&amp;PID_1000\5&amp;899163b&amp;0&amp;1</Data> <Data Name="Status">3221226341</Data> <Data Name="FailureNameLength">14</Data> <Data Name="FailureName">\Driver\WUDFRd</Data> <Data Name="Version">0</Data>

</EventData>

</Event>

Attachments

061810-31215-01.dmp Download (310.3 KB) - added by OxOOCOFFEE 4 years ago.
This is a mini dump

Change History

Changed 4 years ago by OxOOCOFFEE

This is a mini dump

comment:1 Changed 4 years ago by OxOOCOFFEE

Still a problem in VirtualBox 3.2.6. Any news when this might be addressed?

comment:2 Changed 4 years ago by michaln

As far as we can tell, this problem is specific to the Clear USB device, or more likely the drivers shipped with it. The minidump unfortunately doesn't help much, it only shows that the Windows kernel code crashed. Most likely some kernel data got corrupted during a call to the Clear USB drivers.

Even if we had the device and were able to reproduce the problem, there's a chance we couldn't fix it because it's the Clear drivers doing something wrong. Basically the OS dies after calling into some driver's PnP handler, most likely Clear's (I can't tell for sure from the minidump, but it's a safe bet since other devices don't cause this).

comment:3 Changed 4 years ago by OxOOCOFFEE

I just got off live chat with Clearwire (little over 1h chat with different support levels). Well I got to L2 support level just to find out that they do not support 3rd party software. They were not even willing to look into this. How lame. So I guess for possible 4G customers. As of now (3.2.6) this card does not work and it does not look like it will work in a near future. I will update that page when something changes.

comment:4 Changed 3 years ago by Technologov

For already installed drivers, I have opened a Wish #6057

I have no good ideas, how to handle the case for not-yet-installed drivers (i.e. if incompatible driver was installed _after_ VirtualBox)

-Technologov

comment:5 Changed 19 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.1.22.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use