VirtualBox

Ticket #7030 (closed defect: invalid)

Opened 4 years ago

Last modified 8 months ago

OpenSolaris guests do not recognize back/forward buttons -> guest OS issue

Reported by: bqbauer Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.2.4 Keywords:
Cc: Guest type: Solaris
Host type: Solaris

Description (last modified by michael) (diff)

OpenSolaris 2009.06 guests (64-bit) no longer recognize the back/forward mouse buttons in the browser, but my other guests do (XP, Ubuntu). These would be mouse buttons 4 & 5, or 6 & 7--I forget which are the wheel and which are the extra buttons. I've never needed to do anything to configure these on a host or a guest. They just work for all operating systems I've tried--even Solaris 10. Center button and wheel work fine. Tested with the default FF in 2009.06 (3.1b3) and FF 3.6.3 from opensolaris.org.

Host is also OpenSolaris 2009.06, 64-bit. VB 3.2.4.

I've tested a b134 guest, and it also does NOT recognize these buttons in the browser.

For all, I also tried enabling the absolute pointing device option, but it did not help. Problem applies whether or not additions are installed.

Attachments

VBox.log Download (82.7 KB) - added by bqbauer 4 years ago.
OpenSolaris b134 64-bit guest, fresh install

Change History

Changed 4 years ago by bqbauer

OpenSolaris b134 64-bit guest, fresh install

comment:1 Changed 4 years ago by jkeil2

Yep, same here.

I have an SX:CE b129 host, running vbox 3.2.4, and an opensolaris b134 vbox guest. Guest additions are installed.

The host has a wireless Logitech desktop usb keyboard / mouse connected; the mouse has four buttons (one of them is also used as the scroll wheel). On the host os the four buttons report button 1/2/3 and button 8 events. The scroll wheel is mapped to buttons 4/5 events.

The vbox guest receives button events for buttons 1/2/3 and the scroll wheel as button 4/5 events. Button 8 events are not seen in the guest.

Using "xinput list" and "xinput test {mousedevice}" I notice that mouse motion events are received by the opensolaris guest through the /dev/vboxguest mouse device cnfigured in /etc/X11/xorg.conf; but the button and wheel events are received through the HAL auto-detected "Microsoft PS/2-style Mouse" port /dev/mouse.

AFAIR, the extended wheel-mouse protocol on PS/2 ports supports a maximum of three mouse buttons and a scroll wheel. I suspect that additional mouse buttons would be supported if they where sent to the guest os using the /dev/vboxguest mouse device and not the emulated ps/2 mouse hardware...

comment:2 Changed 4 years ago by bqbauer

Just to be clear, the problem arose after 3.1.8. This is a new issue to add to the list of problems introduced by the 3.2.x versions.

On 3.2.6 beta 1, the problem still exists with OpenSolaris guests.

comment:3 Changed 4 years ago by michael

Certain PS/2 mice, such as the MS IMEx, support five buttons and a two-way scroll wheel (see  vuidps2.c line 363 in the OpenSolaris source). We emulate this PS/2 mouse, but fixes in the emulation probably caused this regression with Solaris guests.

comment:4 Changed 4 years ago by michael

I did some tests and was unable to get a Solaris 2009.06 (32bit) guest to recognise the fourth and fifth buttons with either VirtualBox 3.1 or 3.2. Did this work on a machine with Guest Additions? (The absolute pointing device is automatically disabled when the Guest Additions are active.)

comment:5 Changed 4 years ago by michael

Also tried this with VirtualBox 3.1 booting from an OpenSolaris 2009.06 x86 live CD.

comment:6 Changed 4 years ago by bqbauer

Crud. Since I use OpenSolaris as my host OS and primary OS, I usually boot OpenSolaris as a guest only for testing. I guess I hadn't done that for a while. I just confirmed that the forward/back buttons don't work on 3.1.8 even with additions. My mistake--BUT they do work on other guests even in 3.2.4 as I mentioned, and they did work on OpenSolaris....now I just don't know where it stopped working. 3.0? 3.1?

Still a problem and annoying bug for when I do need it. I really use those buttons myself.

comment:7 Changed 4 years ago by michael

This must be some configuration issue. The OpenSolaris PS/2 mouse driver clearly contains code for five buttons and horizontal scrolling which should be compatible with VirtualBox when using either the non-absolute pointing device (PS/2 emulation) or the Guest Additions. Note that actually the horizontal wheel scrolling code will not work with VirtualBox 3.2 due to changes in our code. I have fixed that locally (but still can't get OSol to recognise it). I tried asking one of the OSol developers about this a while back, but he couldn't help me much, other than saying that there might be separate drivers for three and five button mice, with the three button driver selected by default.

So if you can find someone who knows about OSol driver configuration you might still get this working.

comment:8 Changed 4 years ago by michael

I was able to get horizontal scroll wheel events working by adding the following section to xorg.conf (and enabling it in the "ServerLayout" section):

Section "InputDevice"
        Identifier      "Mouse1"
        Driver          "mouse"
        Option          "SendCoreEvents"
        Option          "Device"                "/dev/mouse"
        Option          "Protocol"              "VUID"
        Option          "Buttons"               "9"
        Option          "ZAxisMapping"          "4 5 6 7"
EndSection

This clearly shows that at least for horizontal scroll events the problem lies between the OpenSolaris kernel driver and the X.Org input driver, and it seems to me that it is a bug in the server auto-configuration. I wonder whether similar configuration changes will also get the fourth and fifth buttons working, but so far I haven't managed to do so.

Note that this will not work with the current 3.2 series, due to the regression which I introduced. It will work with 3.1, and it works with my locally modified 3.2 build - hopefully future 3.2 releases will contain my modifications.

comment:9 Changed 4 years ago by michael

Note that the "Buttons" option line is incorrect in the last notification mail (corrected after the fact in the bugtracker entry).

comment:10 Changed 4 years ago by michael

The problem is definitely somewhere between the OpenSolaris kernel and the X server - using the dtrace script in  this bug ticket, I can see that the kernel is interpreting presses of buttons four and five correctly.

comment:11 Changed 8 months ago by michael

  • Status changed from new to closed
  • Resolution set to invalid
  • Description modified (diff)
  • Summary changed from OpenSolaris guests do not recognize back/forward buttons to OpenSolaris guests do not recognize back/forward buttons -> guest OS issue

Closing as "not our bug".

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use