VirtualBox

Ticket #6456 (reopened defect)

Opened 4 years ago

Last modified 3 years ago

Windows XP Taskbar on Autohide no longer pops up in Seamless Mode with Vb3.1.6

Reported by: FrancisT Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

With all earlier versions of VB a seamless mode Win XP VM with a windows toolbar with autohide enabled would pop up when the mouse was moved to the bottom of the screen. This no longer works now that I have upgraded to Vb 3.1.6.

If the mouse is place in the middle of the bottom of the screen then the Virtualbox bar pops up

In regular (non-seamless) mode the task bar pops up as expected

Linux OS guests work fine with a popup taskbar/panel at the bottom (or elsewhere)

I have reinstalled 3.1.6. Vritualbox Guest Additions just incase it was a problem with the old ones without any change

Attachments

VBox.log Download (41.1 KB) - added by dimitris 4 years ago.
32bit WinXP guest under 32bit Ubuntu Karmic host

Change History

comment:1 Changed 4 years ago by bqbauer

I can confirm this bug with an XP guest on my OpenSolaris host. I've now seen this on two separate hosts, each with a different XP guest.

Changed 4 years ago by dimitris

32bit WinXP guest under 32bit Ubuntu Karmic host

comment:2 Changed 4 years ago by dimitris

Confirming again: Ubuntu Karmic 32bit host, WinXP 32bit guest, fullscreen (as opposed to seamless) mode.

As a workaround, I'm maximizing the VB window, instead of full-screen I've been using up to and including 3.1.4.

comment:3 Changed 4 years ago by Panajev

Confirmed on OS X 10.6.2 running Windows Server 2003 (XP codebase). Both in windowed mode and in seamless mode.

comment:4 Changed 4 years ago by FrancisT

I confirm the same behavior under both seamless and full-screen modes.

I also have a workaround. An alternative way to bring up the taskbar is to press CTRL-ESC (or possibly the windows logo key - though not for me as I've remapped that)

comment:5 Changed 4 years ago by Panajev

Thanks for the work-around, it does indeed work :).

I have re-mapped the CTRL-key using Sharpkeys too, using OS X it is much more convenient to have the left CMD key mapped as the left CTRL key and use a different host key (right CMD works) for VirtualBox itself.

What's the point? If you have to do a lot of copy and paste between Host and Virtualized OS, using the same key to do copy and past is essential (CMD+C or CMD+V working in the same way under the host system [OS X] and in the Virtualized OS [Windows Server 2003 with left CTRL key remapped to left CMD key]).

comment:6 Changed 4 years ago by MarkCranness

I confirm this problem also: Windows 2000 auto-hide task bar will no longer unhide when mouse is moved to bottom of screen.

A program that monitors the cursor (pointer) position reports the following vertical range on the host: 0 -> 1679.

That program on a VirtualBox 3.1.2 guest reports a range of 0 -> 1678.

That program on a VirtualBox 3.1.6 guest reports a range of 0 -> 1677.

1677 is two pixels short of 1679, and not low enough to mouse-over the two pixel high (hidden) taskbar and cause it to unhide.

The same problem happens at 1680x1050 : 3.1.6 guest pointer range is 0 -> 1047 and two pixels short of the bottom of the screen (1049).

The problem happens Fullscreen and also happens non-fullscreen.

comment:7 Changed 4 years ago by jnpapado

I can confirm the same issue on Windows 7 and 2008 guests on Windows XP and Linux hosts with VB 3.1.6. An alternative workaround is to change the window border width to at least 3 pixels.

comment:8 Changed 4 years ago by MarkCranness

More info: On VirtualBox 3.1.6, full screen, the guest pointer position is consistently recorded with an offset to the host pointer position. If the host pointer is at position X,Y, then the guest thinks it is at X-2,Y-2 (but always >= 0). VirtualBox 3.1.2 has an offset of -1,-1.

When in fullscreen, there should be no offset.

The problem affects me even when NOT in fullscreen, so likely the offset is NOT linked to fullscreen only and the offset should be removed in all cases.

comment:9 follow-up: ↓ 10 Changed 4 years ago by frank

This is a 3.1.6 regression where the guest mouse cursor coordinates are off by -1,-1 and therefore the guest mouse cursor cannot be moved to the very last pixel at the bottom of the VM. As mentioned elsewhere, the bottom panels must be raised manually by pressing the Windows key or Ctrl+Esc. The fix will be available with the next maintenance release.

comment:10 in reply to: ↑ 9 Changed 4 years ago by MarkCranness

@Frank: My measurements showed that the mouse coordinates are off by -2,-2 for 3.1.6, and off by -1,-1 for 3.1.2.

comment:11 Changed 4 years ago by ghutch

What are the plans for correcting this? Is there a plan or are we awaiting "the next release?"

comment:12 Changed 4 years ago by frank

The fix will be part of the next release.

comment:13 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:14 Changed 4 years ago by MarkCranness

While this particular problem is solved, there is still an offset between the reported guest and host mouse pointer positions. The guest is still off by -1,-1 (the guest reads one lower in both x and y coordinates).

So on a 1280x1024 host display, guest full-screen, the guest mouse pointer goes from Y=0 to 1022, while the host goes from 0 to 1023. On the guest, the bottom most position of Y=1023 CANNOT be reached.

When the host reads Y=0, or Y=1, the guest reads Y=0. When the host reads X, the guest reads X-1.

If you use a paint program on the guest, you can see this difference. Pixels drawn appear one up and one left of where they are expected to appear based on the mouse pointer position, as compared to the same program running on the host.

Should I re-open this ticket or create a new one?

This program (Windows) shows mouse pointer position as the mouse is moved (I run it on host and guest):  http://www.filefront.com/17226592/PointerPositionRecorder.zip/ (I can provide source if required.)

comment:15 Changed 4 years ago by MarkCranness

Extra info: Only happens when Mouse Integration is enabled.

Host: Windows XP, VB 3.2.8r64453, Guest: Windows XP, GA 3.2.8r64453 (and earlier versions)

comment:16 Changed 3 years ago by jonnjonzzn

  • Status changed from closed to reopened
  • Resolution fixed deleted

This is still a problem in 4.0.2. In my case a seamless mode Windows 7 guest on Linux host (Fedora 14 Gnome). With a host application maximized you cannot access the hidden Windows taskbar at bottom of the screen. There are no other panels, docks from host at bottom of screen. I'm re-opening ticket because the description of the problem originally described still exists despite the resolved closure previously. The original description of problem still exists and has not been resolved.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use