VirtualBox

Ticket #6455 (closed defect: obsolete)

Opened 4 years ago

Last modified 4 months ago

WinXP BSODs at startup

Reported by: jimoe Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

VBox v3.1.6
host: opensuse v11.1 linux 2.6.27.45-0.1-default x86_64
host: opensuse v11.2 linux 2.6.31.12-0.2-desktop x86_64
guest: WinXP sp3

Windows XP crashes to a BSOD (blue screen of death) during startup as a guest OS. It happens fairly often. So much so that if I must close Windows, I select "Save Machine State" instead of a normal shutdown. The only time I choose shutdown is when there is no choice (a new program installation, windows updates, etc.).

Sometimes just attempting to start again is enough to get Windows past whatever the problem is and it starts normally. Other times I must boot to Safe Mode, login/logout of an admin account, and restart. That usually works, though not always.

Attachments

screenshot-winxp-BSOD.png Download (28.0 KB) - added by jimoe 4 years ago.
One form of Windows BSOD
screenshot-vm-winxp-BSOD2.png Download (22.2 KB) - added by jimoe 4 years ago.
Another form of Windows BSOD
VBox.log Download (54.6 KB) - added by jimoe 4 years ago.
Log file from BSOD experience

Change History

Changed 4 years ago by jimoe

One form of Windows BSOD

Changed 4 years ago by jimoe

Another form of Windows BSOD

comment:1 Changed 4 years ago by klaus

AFAICT no one got such BSODs, and they contain very little information, so without getting more information there's not much to work on. Could you e.g. provide minidumps?

comment:2 Changed 4 years ago by jimoe

Hmm. Well, we get these BSODs quite predictably. They appear to be related to how, or when, the Guest Additions are loaded. If the mouse icon becomes active, I know that Windows will continue to boot; otherwise it BSODs.

How do I create a minidump? Is the dump from VBox or Windows?

comment:3 Changed 4 years ago by jimoe

This defect persists in VirtualBox-3.2-3.2.0_61806_openSUSE111-1.x86_64.

comment:4 Changed 4 years ago by jimoe

This defect persists in VirtualBox-3.2-3.2.4_62467_openSUSE111-1.x86_64.

comment:5 Changed 4 years ago by mhanor

attach minidumps from the guest
read here  http://support.microsoft.com/kb/315263

comment:6 Changed 4 years ago by mhanor

you should also attach a VM session log when the guest encountered a BSOD

Changed 4 years ago by jimoe

Log file from BSOD experience

comment:7 Changed 4 years ago by jimoe

I followed the instructions for creating a minidump; I did this in a root account in Safe Mode. I even created the <Minidump> directory since there was none.

No dumps were ever created after a BSOD. I tried this on multiple computers.

More information:

We currently have six workstations running almost the same hardware. They all have the same motherboard (asus m3a78-em), CPU (amd athlon am2 5200), and memory (4GB). The difference in hardware is the disk drive complement. Most have some form of SATA drive running at 7200 rpm; two stations have 10K or 15K rpm SCSI drives.

I mention this because one station WILL NOT start the winXP VM for VBox version 3.2.4. (I have reverted that one to v3.1.6 which does start the VM.) It BSODs without fail. No crash dump was ever produced. That system has a 10K rpm SCSI drive. I have upgraded the other systems to v3.2.4 and get only a couple of BSODs before the VM finally starts.

comment:8 Changed 4 years ago by jimoe

It persists in v3.2.6_63112_openSUSE111-1.x86_64.

Worse, I now have TWO workstations where Windows BSODs rather than starts. The second computer does not have any SCSI drives, only SATA.

Other computers, however, start Windows after a few BSODs.

comment:9 Changed 4 years ago by sandervl73

  • Version changed from VirtualBox 3.1.6 to VirtualBox 3.2.6

You can try a few things:

  • turn off 3d & 2d acceleration in the display settings of the VM
  • check if using one CPU makes any difference

comment:10 Changed 4 years ago by jimoe

  • turn off 3d & 2d acceleration in the display settings of the VM

I had the "opportunity" to try this a couple of weeks ago. I had managed to damage the video drivers in such a way that VBox would crash it video acceleration was enabled. It made no difference to the BSOD problem. (I have subsequently fixed the video issue and now have acceleration enabled again.)

  • check if using one CPU makes any difference

Yes, it does! The computer that BSOD'd yesterday without exception at v3.2.6 now starts cleanly with only a single CPU allowed.

comment:11 Changed 4 years ago by jimoe

Do you need any further input to resolve this?

comment:12 Changed 4 years ago by jimoe

This persists in VirtualBox-3.2-3.2.8_64453_openSUSE111-1.x86_64.

comment:13 Changed 4 years ago by jimoe

This persists in VirtualBox-3.2-3.2.10_66523_openSUSE111-1.x86_64.

comment:14 Changed 4 years ago by frank

  • Version changed from VirtualBox 3.2.6 to VirtualBox 3.2.10

comment:15 Changed 4 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use