VirtualBox

Ticket #6330 (closed defect: worksforme)

Opened 4 years ago

Last modified 3 years ago

PXE boot fail with Intel E1000 => Fixed in SVN

Reported by: trevort Owned by:
Priority: major Component: network
Version: VirtualBox 3.1.4 Keywords: pxe boot
Cc: Guest type: Windows
Host type: Linux

Description

I've been working with Windows Deployment Services, and IF I set a host to use an Intel Pro adaptor it will not load the PXE boot program. It will get an IP, and start to load the file sent to it from the server, but when it tries to load it will crash. If I use the PCNet adapter, it will load, but win2k8 doesn't have a driver for that in the PXE boot environment.

Attached is a screenshot of the failed boot screen, a txt file of my guest environment, and the log file.

Attachments

pxe-boot-fail-vm-info.txt Download (1.2 KB) - added by trevort 4 years ago.
vm info
VBox.log Download (78.3 KB) - added by trevort 4 years ago.
log file
Screenshot-w2k8-ent-Montreal.png Download (28.5 KB) - added by trevort 4 years ago.
screenshot

Change History

Changed 4 years ago by trevort

vm info

Changed 4 years ago by trevort

log file

comment:1 in reply to: ↑ description Changed 4 years ago by trevort

Also, see ticket #2536, which seems related.

Changed 4 years ago by trevort

screenshot

comment:2 in reply to: ↑ description Changed 4 years ago by trevort

Just a couple more bits of info:

I'm running Ubuntu 9.1 with the latest updates (kernal 2.6.31-20), 64bit. I don't have a virtualization feature on my processor though, so that feature is 'disabled' (it's not an option). I did remove and re-add the boot image and that didn't help. When I use any of the intelpro nic adapters the VM will either freeze at 100% CPU utilization or it will error out (as shown in the screen shot). If I use the PCNet adapter I don't have any problems (but I the boot fails once windows PE loads since windows PE doesn't have a driver for it).

comment:3 Changed 4 years ago by trevort

I tested with a windows host (Vista 32bit) using the same VMs. The problem persists - windows and linux hosts both have the same problem.

Is there any additional files/logs/info I should upload / produce?

comment:4 Changed 4 years ago by frank

  • Summary changed from PXE boot fail with Intel Pro to PXE boot fail with Intel E1000

comment:5 Changed 4 years ago by runout

There is a temporary solution. Add two NIC: the first one is PCnet card, the second - Intel card. PXE will use the first;than, when WinPE boots, i will configure Intel card with DHCP-client and will use it during installation. It works form me and i suppose for you too. Good luck!

comment:6 Changed 3 years ago by aleksey

Recent versions of WDS (based on Windows Server 2008 and above) use TFTP window of eight packets to send data back to PXE client. When two data packets arrive to our e1000 UNDI driver in short time frame they are erroneously combined to form a single packet. The problem is now resolved and the fix will be available in the next maintenance release.

comment:7 Changed 3 years ago by aleksey

  • Summary changed from PXE boot fail with Intel E1000 to PXE boot fail with Intel E1000 => Fixed in SVN

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 4.0.2.

comment:9 Changed 3 years ago by jars99

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm still having this problem in Ubuntu 10.10 with VirtualBox 4.0.2 r69518. If I change the adapter to anything besides intel everything seems to work fine.

comment:10 Changed 3 years ago by aleksey

Could you enable the internal packet capture with

VBoxManage modifyvm <vm_name> --nictrace1 on --nictracefile1 <name_of_choice>

reproduce the problem and send the capture file to aleksey dot ilyushin at oracle dot com? Actually I am only interested in the part of the file where the problem manifests itself. Please attach vbox.log as well.

comment:11 Changed 3 years ago by paperdiesel

I'm also having this problem with 4.0.4 r70112. Selecting any of the 3 Intel adapter types causes "FATAL: Could not read from the boot medium! System halted." PXE boot works fine, however, when using either of the 2 PCnet adapters. I have emailed aleksey dot ilyushin at oracle dot com with the capture and VBox.log files.

comment:12 Changed 3 years ago by frank

paperdiesel, do you have the extension pack installed? This is necessary to use the Intel PXE code which supports the Intel adapters. In case you already installed the extension pack then please attach a VBox log of such a VM session where booting from PXE does not work.

comment:13 Changed 3 years ago by jars99

aleksey - I sent those files to you - did you get them? Any idea why the packet capture wasn't getting any real data?

Any other updates on this? I'm anxious to move all my systems to 4.0, but I want to wait until this is fixed.

comment:14 Changed 3 years ago by aleksey

jars99,

I got the files, thanks! Judging by the empty packet capture file (it is binary btw) and missing LanBootRom in [/Devices/pcbios/0/Config/] it is very likely that you do not have the extension pack installed. Can you check the output of the following command?

VBoxManage list extpacks

Oracle VM VirtualBox Extension Pack contains PXE ROM with E1000 support.

comment:15 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use