VirtualBox

Ticket #2536 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

PXE Boot failure -> Fixed in SVN

Reported by: j.schneider@… Owned by:
Priority: critical Component: network/hostif
Version: VirtualBox 3.2.4 Keywords: pxe amd-v
Cc: Guest type: other
Host type: Linux

Description

PXE Boot from network fails. Transmission of the kernel from tftp server interrupts after a while. This problem only appears if VT-x/AMD-V activated.

See attached screenshot and logfile.

VirtualBox 2.0.4 r38406 running on debian linux amd64

Attachments

pxe-boot-failure.log Download (39.1 KB) - added by j.schneider@… 5 years ago.
VM logfile
pxe-boot-failure.png Download (39.6 KB) - added by j.schneider@… 5 years ago.
vm screenshot
pxe-boot-failure-2.1.log Download (39.8 KB) - added by j.schneider@… 5 years ago.
VM logfile (vbox 2.1.0)
Screenshot-test Virtual Machine.png Download (28.7 KB) - added by lfarkas 4 years ago.
screenshot where it's hang
VBox.log-good Download (61.2 KB) - added by lfarkas 4 years ago.
the working log
VBox.log-bad Download (65.9 KB) - added by lfarkas 4 years ago.
the not working log
pxe_boot_failed_vbox.png Download (19.1 KB) - added by crissi 3 years ago.
sceenshot vbox pxe msg at failed boot

Change History

Changed 5 years ago by j.schneider@…

VM logfile

Changed 5 years ago by j.schneider@…

vm screenshot

comment:1 Changed 5 years ago by j.schneider@…

Networkadapter is PCnet-Fast III connected to hostinterface vbox1 (bridged)

comment:2 Changed 5 years ago by j.schneider@…

Is somebody reading this? Problem persists with VirtualBox 2.1.0 (network bridged to hostinterface eth0)

Changed 5 years ago by j.schneider@…

VM logfile (vbox 2.1.0)

comment:3 Changed 5 years ago by frank

Just to be sure: You don't experience this when AMD-V is disabled for that VM (are you 100% sure)?

comment:4 Changed 5 years ago by j.schneider@…

I have never seen that problem with deactivated AMD-V. With deactivated AMD-V PXE boot fails sometimes because there is no DHCP-response. But if TFTP tranfer is once started it completes in every case. PXE-boot also seems to be about twice as fast with AMD-V deactivated. Failure rate with AMD-V activated is about 80%. Please ask me if you need more information.

comment:5 Changed 5 years ago by j.schneider@…

Sorry, I have to correct my last posting.

AMD-V. With deactivated AMD-V PXE boot fails sometimes because there is no DHCP-response.

This only happens with Intel PRO/1000.

comment:6 Changed 5 years ago by corsac

It seems that I have the same kind of problem.

I run virtualbox-ose 2.1.0 and I can't use PXE on any VM. Wether I chose PCnet-PCI II or PCnet-FAST III, when I try to do PXE boot the screen stays black, 100% CPU on host and that's all.

But on this VM, deactivating VT-x (I'm on a Core2Duo) fixes the problem.

I can't try Intel card as I run -ose, but it seems the problem is shared anyway.

Cheers, -- Yves-Alexis

comment:7 Changed 5 years ago by corsac

Oh and BTW it seems RIS (Remote Installation Service) by MS is failing after the configuration part, on virtualbox while it works fine on vmware, for example.

comment:8 Changed 5 years ago by j.schneider@…

Problem persists with VirtualBox 2.1.2-41885

comment:9 Changed 5 years ago by cdufour

I also confirm problem persists with VirtualBox 2.1.2-41885

In order for PXE boot to work, I had to:

  1. Set host interface (eth0) to promiscuous mode (otherwise, VBox guest's PXE agent wouldn't respond to ARP request from TFTP server): ifconfig eth0 promisc
  1. Disable Intel VT extensions (CPU Intel Q9300), or TFTP download would get stuck before end of download (never at the same point, though)

Hope this helps

comment:10 Changed 5 years ago by frank

  • Component changed from network to network/hostif

comment:11 Changed 5 years ago by j.schneider@…

Problem persists with VirtualBox 2.1.4-42893

comment:12 Changed 5 years ago by sunlover

  • Keywords amd-v added
  • Version changed from VirtualBox 2.0.4 to VirtualBox 2.1.4
  • Summary changed from PXE Boot failure to PXE Boot failure -> Fixed in SVN

The fix will be included in a future VBox version.

comment:13 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:14 Changed 5 years ago by sandervl73

This is now really fixed. PXE boot performance is significantly faster now. Will be part of the upcoming 3.0 release.

comment:15 Changed 5 years ago by corsac

I've just tried with virtualbox-ose on Debian sid, and it still doesn't work. Same symptoms:

  • if VT-x is enabled, as soon as the guest gets the startom.com executable from the TFTP server and tries to run it, it goes to “Guru Meditation” error.
  • if VT-x is disabled, the startom.com / OSChooser part is run fine, but when bootstrapping to the selected installation, it only reboots without doing anything.

Maybe it's a different issue?

comment:16 Changed 4 years ago by lfarkas

  • Status changed from closed to reopened
  • Resolution fixed deleted

i've installed VirtualBox-3.2-3.2.4_62467_fedora12-1.i686 on my fedora-12 and it's still not working. ie. if i turn off VT-x/AMD-V support than it's working, but if turn it on than it's hang:-(

comment:17 Changed 4 years ago by sandervl73

Do you realize it's not really useful to reopen tickets without providing any information? VBox.log of that session is the bare minimum...

comment:18 Changed 4 years ago by lfarkas

you've got right.

  1. i attached the log when VT-x/AMD-V disabled and the pxe boot menu appeared than poweroff the guest.
  2. i attached the log when VT-x/AMD-V enabled and wait many second where it hang than poweroff the guest.
  3. i attached the screenshot of the guest where it's hang.

Changed 4 years ago by lfarkas

screenshot where it's hang

Changed 4 years ago by lfarkas

the working log

Changed 4 years ago by lfarkas

the not working log

comment:19 Changed 4 years ago by sandervl73

  • Version changed from VirtualBox 2.1.4 to VirtualBox 3.2.4

Thanks.

comment:20 Changed 4 years ago by Lelik

Unable to reproduce such problem with or w/o VT-x/AMD-V. Tried latest Debian netboot installation ( http://ftp.debian.org/debian/dists/stable/main/installer-i386/current/images/netboot/) Unpacked netboot.tar.gz to tftpboot directory and configured DHCP to offer pxelinux.0 file. Boots and installs well.

Can you upload your images/configs (if it possible and legal) somewhere please?

comment:21 Changed 4 years ago by lfarkas

fedora people suggest to update from pxeboot from 3.73 to 3.83 and it seems now both virtualbox and kvm are able to boot from net. thanks. ps. anyway it's be useful to add to the faq that older pxeboot can't work.

comment:22 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:23 Changed 3 years ago by crissi

  • Status changed from closed to reopened
  • Resolution fixed deleted

This problem is back on 4.0. Only if VT-x/AMD-V support is disabled boot works.

Changed 3 years ago by crissi

sceenshot vbox pxe msg at failed boot

comment:24 Changed 3 years ago by crissi

vbox versions: r69151 extension pack r69151 vbox

comment:25 Changed 3 years ago by aleksey

  • Status changed from reopened to closed
  • Resolution set to fixed

The problem was fixed in 4.0.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use