VirtualBox

Ticket #6329 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

VirtualBox destroys VmWare 7.0.1 Image

Reported by: Sharky444 Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 3.1.4 Keywords: vmdk
Cc: Guest type: Windows
Host type: Windows

Description

I've just tried using a vmdk image with Windows XP on it. It was created by VMWare 7.0.1, my VB version is 3.1.4 and the host is Windows 7 Ultimate x64.

Result: the vmdk got corrupted, you get a loading operating system error when Windows starts to boot. This is no blue screen, just a text message on a black screen.

What is bad about this, is that the vmdk was destroyed. You cannot use it in VMWare anymore, you get the same loading operating system error.

Luckily I had a backup of it. After restoring the backup I've tested it with VMWare. Works. Loaded again with Virtualbox. It has been destroyed again.

Since I've still the backup, I can repeat the operation if needed.

Change History

comment:1 Changed 4 years ago by Technologov

hmmm... this issue deserves higher priority.

-Technologov

comment:2 Changed 4 years ago by klaus

Do you happen to have a "flat" VMDK file (i.e. a fixed size image) where this happens? Would simplify investigation, as I suspect the text descriptor file is the source of all problems.

comment:3 follow-up: ↓ 5 Changed 4 years ago by aeichner

Couldn't reproduce here so far. Tried with a VMDK created with VMware workstation 7.1.0. The guest is Windows Vista. Boots fine with VirtualBox and no sign of corruption.

comment:4 Changed 4 years ago by chriswolf

Here are several workarounds for both VMDK type=2 (monolithicFlat) and type=0 (monolithicSparse):

 http://communities.vmware.com/message/983441#983441

comment:5 in reply to: ↑ 3 ; follow-up: ↓ 6 Changed 4 years ago by chriswolf

Replying to aeichner:

Couldn't reproduce here so far. Tried with a VMDK created with VMware workstation 7.1.0. The guest is Windows Vista. Boots fine with VirtualBox and no sign of corruption.

Right, because the issue is not booting with VirtualBox, but booting with VMware, once that VMDK is booted by VirtualBox - it gets modified by VirtualBox by adding the following Disk DescriptorFile entries:

  • ddb.uuid.modification
  • ddb.uuid.parent
  • ddb.uuid.parentmodification
  • ddb.geometry.biosCylinders
  • ddb.geometry.biosHeads
  • ddb.geometry.biosSectors

These entries cause VMware to fail to load the VMDK, so yes, it will boot fine with VirtualBox, but not VMware. To restore the VMDK file back to the way it was before VirtualBox modified it, you can try one of these procedures:

 http://communities.vmware.com/message/983441#983441

comment:6 in reply to: ↑ 5 Changed 4 years ago by chriswolf

Replying to chriswolf:

Replying to aeichner:

Couldn't reproduce here so far. Tried with a VMDK created with VMware workstation 7.1.0. The guest is Windows Vista. Boots fine with VirtualBox and no sign of corruption.

Right, because the issue is not booting with VirtualBox, but booting with VMware, once that VMDK is booted by VirtualBox - it gets modified by VirtualBox by adding the following Disk DescriptorFile entries: [...]

I tried a Windows-XP guest and the issue does NOT occur - it appears to be when the guest OS is Linux, specifically Ubuntu-9.1. At some point I may try a different flavor of Linux to see if the issue is specific to Ubuntu/Debian or generic to Linux.

comment:7 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use