VirtualBox

Ticket #6166 (reopened defect)

Opened 4 years ago

Last modified 8 months ago

Windows 7 x86 Host Crashes on installing x64 Guest System (AMD only)

Reported by: SvenBrnn Owned by:
Priority: critical Component: other
Version: VirtualBox 4.1.6 Keywords: host, crash, x64, 64bit
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

My Windows 7 x86 System Crashes if i try to Install an 64bit Vista or Windows 7 on the Guest PC. The Host PC suddenly reboots. I will attach the Log.

Attachments

Win7 X64-2010-02-04-01-26-59.log Download (35.4 KB) - added by SvenBrnn 4 years ago.
Log when trying to install x64 System
Windows Server 2008 R2-2010-03-12-12-58-48.log Download (42.1 KB) - added by pmdarrow 4 years ago.
VM log of Windows Server 2008 R2 64bit guest crashing Windows 7 32bit host
showvminfo.txt Download (2.0 KB) - added by pmdarrow 4 years ago.
Output of VBoxManage showvminfo for Windows Server 2008 R2 guest causing crash.
031210-20093-01.dmp Download (154.6 KB) - added by pmdarrow 4 years ago.
Minidump of VirtualBox 3.1.4 crash
VBox.log Download (39.4 KB) - added by nikkynews 4 years ago.
Log Crash 32bit host with 64bit guest
VBox.2.log Download (37.9 KB) - added by sevva 4 years ago.
Windows 2008 R2 as guest on Windowd XP host
Win7 X64-2010-06-14-11-41-33.log Download (37.4 KB) - added by SvenBrnn 4 years ago.
New Logfile
2008-R2-64Bit-2010-07-28-09-35-29.log Download (50.7 KB) - added by javad1980 4 years ago.
2008-R2-64Bit-2010-07-28-10-11-47.log Download (75.8 KB) - added by javad1980 4 years ago.
2008-R2-64Bit-2010-07-28-10-12-05.log Download (75.4 KB) - added by javad1980 4 years ago.
2008-R2-64Bit-2010-07-28-10-21-25.log Download (79.5 KB) - added by javad1980 4 years ago.
2008-standard-64-2010-07-16-18-00-25.log Download (74.6 KB) - added by javad1980 4 years ago.
2008-standard-64-2010-07-19-18-19-16.log Download (73.9 KB) - added by javad1980 4 years ago.
2008-standard-64-2010-07-20-09-24-54.log Download (45.9 KB) - added by javad1980 4 years ago.
2008-standard-64-2010-07-20-10-34-22.log Download (73.7 KB) - added by javad1980 4 years ago.
Windows 7 x64 test-2010-08-22-02-02-09.log Download (43.2 KB) - added by SagePtr 4 years ago.
Host: Windows 7 x86, Guest: Windows 7 x64, CPU: AMD
w7-64-2011-03-20-03-37-25.log Download (33.5 KB) - added by dlong 3 years ago.
windbg.txt Download (5.7 KB) - added by dlong 3 years ago.
VBox.3.log Download (74.5 KB) - added by osmiy 3 years ago.
Raise BSOD 0x0101 on HOST 32bit
BSD_0x00000101.TXT Download (3.3 KB) - added by osmiy 3 years ago.
HOST 32bit GUEST 64bit
VBox.log.1 Download (46.8 KB) - added by hael 3 years ago.
VBox 4.0.8 r71778.log Download (52.9 KB) - added by osmiy 3 years ago.
sporadical host reboot
VBox.log.2.1 Download (79.8 KB) - added by AgainAndAgain 19 months ago.
host suddenly reboot

Change History

Changed 4 years ago by SvenBrnn

Log when trying to install x64 System

comment:1 Changed 4 years ago by pmdarrow

I have this exact same problem, but the guest OS I'm trying to install is Windows Server 2008 R2 64bit. I've attached the VM log and the output from VBoxManage showvminfo. I have  discussed this problem at length with forum moderator Perryg and we have been unable to come up with a solution. Virtualization technology is enabled in the BIOS. Here are my specs:

CPU: Intel Core 2 Duo E6600
Motherboard: Asus P5LD2
RAM: 4GB RAM
Host OS: Windows 7 32bit
VirtualBox version: 3.1.4

Changed 4 years ago by pmdarrow

VM log of Windows Server 2008 R2 64bit guest crashing Windows 7 32bit host

Changed 4 years ago by pmdarrow

Output of VBoxManage showvminfo for Windows Server 2008 R2 guest causing crash.

Changed 4 years ago by pmdarrow

Minidump of VirtualBox 3.1.4 crash

comment:2 Changed 4 years ago by michaln

Here's the bugcheck information from the minidump:

CLOCK_WATCHDOG_TIMEOUT (101)
An expected clock interrupt was not received on a secondary processor in an
MP system within the allocated interval. This indicates that the specified
processor is hung and not processing interrupts.
Arguments:
Arg1: 00000060, Clock interrupt time out interval in nominal clock ticks.
Arg2: 00000000, 0.
Arg3: 80dc8120, The PRCB address of the hung processor.
Arg4: 00000001, 0.

The OS kernel in the minidump had been modified (almost certainly by Windows Update) and Microsoft for some reason does not have symbols for it. At any rate, the stack trace probably didn't contain anything useful, it was all inside the 'nt' module with no VirtualBox code in sight.

comment:3 Changed 4 years ago by michaln

  • Version changed from VirtualBox 3.1.2 to VirtualBox 3.1.4

Changed 4 years ago by nikkynews

Log Crash 32bit host with 64bit guest

comment:4 Changed 4 years ago by nikkynews

Installing guest Windows Server 2008 R2 crashes the host immediately after loading files. Host system is Windows 7 32-bit. See logfile VBox.log.

comment:5 Changed 4 years ago by pmdarrow

Tested with Ubuntu Desktop 9.10 64bit as a guest, Windows 7 32bit as the host; same issue. No minidump unfortunately because there is no BSOD, just a hard reboot.

comment:6 Changed 4 years ago by pmdarrow

Ruled out any hardware issues or VTx problems - VMware Workstation 7.0.1 runs 64bit guests on 32bit Windows fine.

comment:7 Changed 4 years ago by klaus

  • Priority changed from major to critical

comment:8 Changed 4 years ago by michaln

FWIW, Microsoft has updated their debug symbols, so a full stack trace can now be obtained from the minidump. But that unfortunately doesn't help, because as I said earlier, there is nothing useful in that stack trace. The minidump only contains information for the CPU which triggered the bugcheck, which in this unusual case is the CPU *not* having problems.

Changed 4 years ago by sevva

Windows 2008 R2 as guest on Windowd XP host

comment:9 Changed 4 years ago by sevva

Same problem with Windows XP as host and Windows 2008 Server R2 as guest - reboot after loading files at installation start. Another configuration (host Windows 7 on my home notebook) with this Windows 2008 Server R2 as guest works fine. I tried to copy VM with Win2008 from working installation to another, but unsuccess. Its reboot host after guest starts. Think, its hardware trouble, not Microsoft.

comment:10 Changed 4 years ago by sandervl73

No, it's a known problem with 64 bits guests on 32 bits hosts. (see manual) Pretty sure this has been reported before (which makes this a duplicate)

comment:11 Changed 4 years ago by sandervl73

#3963 marked as a duplicate of this one.

comment:12 follow-up: ↓ 13 Changed 4 years ago by sandervl73

I have fixed one possible problem with Intel CPUs. If anybody is interested in testing a new build, then please let me know.

comment:13 in reply to: ↑ 12 Changed 4 years ago by pmdarrow

Replying to sandervl73:

I have fixed one possible problem with Intel CPUs. If anybody is interested in testing a new build, then please let me know.

I'm interested in testing a new build since I'm still having this issue in 3.2.4.

comment:15 in reply to: ↑ 14 Changed 4 years ago by pmdarrow

It works! It not longer crashes after "Loading files..."; I'm installing Windows Server 2008 R2 as we speak. This is great, I can now test my software on 64bit Windows - thanks sandervl73.

comment:16 Changed 4 years ago by sandervl73

Great. Thanks for testing!

comment:17 Changed 4 years ago by sandervl73

Here's a 3.2 branch build that includes the fix:  http://www.virtualbox.org/download/testcase/VirtualBox-2010-06-10-17-08-42-win-3.2-rel-3.2.5-r62570-MultiArch.exe

The first test build is from the unstable branch.

comment:18 Changed 4 years ago by pmdarrow

Works great, thanks again.

comment:19 Changed 4 years ago by sandervl73

  • Summary changed from Windows 7 x86 Host Crashes on installing x64 Guest System to Windows 7 x86 Host Crashes on installing x64 Guest System -> fixed in SVN (test build available)

comment:20 follow-ups: ↓ 21 ↓ 23 Changed 4 years ago by Technologov

But original bug is about *AMD* processors. see vbox.log by SvenBrnn.

-Technologov

comment:21 in reply to: ↑ 20 Changed 4 years ago by SvenBrnn

Replying to Technologov:

But original bug is about *AMD* processors. see vbox.log by SvenBrnn.

-Technologov

I will Test it this Evening when i am back at home, didnt have time to test it, yet.

comment:22 Changed 4 years ago by sandervl73

Do you honestly think I don't know that? 3 out of 4 attached logs are for Intel CPUs that should no longer have this problem.

comment:23 in reply to: ↑ 20 Changed 4 years ago by SvenBrnn

Replying to Technologov:

But original bug is about *AMD* processors. see vbox.log by SvenBrnn.

-Technologov

Same Problem, the Host suddenly Crashes. Its not Fixed for AMD Processors.

Changed 4 years ago by SvenBrnn

New Logfile

comment:24 follow-up: ↓ 25 Changed 4 years ago by sandervl73

If that happens with 32-bit guests as well, then your BIOS needs to be updated.

comment:25 in reply to: ↑ 24 Changed 4 years ago by SvenBrnn

Replying to sandervl73:

If that happens with 32-bit guests as well, then your BIOS needs to be updated.

It happened if i Try to install x64 Guest Windows 7 on x84 Host Windows 7

comment:26 follow-up: ↓ 27 Changed 4 years ago by sandervl73

I asked you if 32 bit guests are stable...

comment:27 in reply to: ↑ 26 Changed 4 years ago by SvenBrnn

Replying to sandervl73:

I asked you if 32 bit guests are stable...

32 Bit Guest Works Stable

comment:28 Changed 4 years ago by frank

  • Summary changed from Windows 7 x86 Host Crashes on installing x64 Guest System -> fixed in SVN (test build available) to Windows 7 x86 Host Crashes on installing x64 Guest System (AMD only)

Do we all agree that the problem is fixed for Intel CPUs but still present for some AMD environments?

comment:29 Changed 4 years ago by javad1980

I am still facing this issue sometimes . I have already installed 2 VPCs , both of them are windows 2008 64 bit . ( One of them is standard , the other is R2 ) . My own windows is Win 7 , professional 32 bit .

Sometimes , when the VPCs are running , suddenly my PC is restarted . So please tell me where to find the log files to send to you .

My Oracle Virtual Box version is 3.2.6 r63112 My Pc Spec : Processor : Intel(R) CORE (TM ) i5 CPU 2.7GHz RAM : 4 GB

comment:30 Changed 4 years ago by frank

The log files we want to see are in the main GUI window, Machine / Show Log... Please use the attach function to add the log of such a VM session to this ticket.

Changed 4 years ago by javad1980

Changed 4 years ago by javad1980

Changed 4 years ago by javad1980

Changed 4 years ago by javad1980

Changed 4 years ago by javad1980

Changed 4 years ago by javad1980

Changed 4 years ago by javad1980

Changed 4 years ago by javad1980

comment:31 Changed 4 years ago by javad1980

I hope it is Ok I attached 8 log files to this issue . Thank you . Javad .

comment:32 Changed 4 years ago by dalobo

I can confirm that this is not fixed. I was on the same version as Frank - 3.2.6 r63112 with an I7 Quad core (860 - 2.8/ w 8M) with 4 gigs of RAM and I still get reboots. I just upgraded to 3.2.8 and it happens less often, but it still happens.

I will try to get some log files.

Changed 4 years ago by SagePtr

Host: Windows 7 x86, Guest: Windows 7 x64, CPU: AMD

comment:33 Changed 4 years ago by aunsb

I've been experiencing the same problems as others above have experienced using:

VB version: 3.2.8
System: Intel Core i7 M620 (ie mobile - 2 cores + HT) with virtualisation extensions enabled, 2.67GHz; 4GB RAM; NVidia M3100 graphics
Host: Windows 7 Professional, x86
Guest: Ubuntu 10.04 AMD64 build (with VB extensions installed)

I have recently checked the "Enable PAE/NX" option (under settings->system->processor), and I have not experienced any host system crashes since doing so (~5 days, previously my host system was crashing 2-3 times a day). By default the "Enable PAE/NX" option was disabled when I set-up the virtual machine (under 3.2.6).

I have no idea what this has actually done and if it really solves the problem, however I figure that it might make an interesting data-point.

comment:34 Changed 3 years ago by jauntys

I have recently started experiencing this problem. Previously my system worked fine. It was only when I expanded the memory in my machine from 2GB to 4GB that this issue started.

comment:35 Changed 3 years ago by frank

If your host is really 32-bit then you can't increase the guest memory to 4G with VBox 3.2.10.

comment:36 Changed 3 years ago by jauntys

No, the physical memory in the machine was increased from 2 GB to 4 GB. The guest memory is 512 MB and hasn't changed.

comment:37 Changed 3 years ago by frank

Is this problem still relevant with VBox 4.0?

comment:38 Changed 3 years ago by SvenBrnn

I will try it this Evening

comment:39 Changed 3 years ago by frank

Any news here? Can we close this ticket?

comment:40 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

I will close this defect as it seems that the problem was finally fixed.

Changed 3 years ago by dlong

comment:41 Changed 3 years ago by dlong

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have what I think is the same crash:

Host: AMD Turion(tm) 64 X2 (laptop), 2GB RAM, 32-bit Windows 7 Guest: 64-bit Windows 7 VirtualBox 4.0.4

Usually the host reboots with no warning, but sometimes I get the clock 0x101 blue screen mentioned above. The state for the hung thread is corrupt when examining the MEMORY.DMP in WinDbg, so I can't look at the stack backtrace.

The guest was installed using a different host. On my laptop, it crashes very early in the Windows boot.

Changed 3 years ago by dlong

comment:42 Changed 3 years ago by osmiy

I see the same crash on VBox 4.0.4 r70112 (log attached).

Lot of HOST reboots without BSOD, once BSOD 0x0101 (attached)

HOST: Win7 32bit (7601 SP1); CPU: Intel i5 520M @ 2.4 GHz; RAM: 4 GB

GUEST: Arch Linux 64bit; RAM: 1024 MB

Tried on the guest with/without (PAE/NX) (Nested paging) (1 or 2 CPU)

Changed 3 years ago by osmiy

Raise BSOD 0x0101 on HOST 32bit

Changed 3 years ago by osmiy

HOST 32bit GUEST 64bit

Changed 3 years ago by hael

comment:43 Changed 3 years ago by hael

I have a similar crash on 4.0.4r70112

Symptom: Win7-32bit suddenly reboots when starting/running Win2008R2-64bit Host: Windows 7 Professional 32bit, 4 GB RAM Guest: Windows Server 2008 R2 64bit, 1 GB RAM

The guest was created on Win7-32bit system with T6670 CPU, where it ran without problems for several weeks. After transferring (Export Appliance...) the appliance to a Win7-32bit machine with i5-520M CPU, VirtualBox crashed the host twice in a row, once during boot and once right after booting the guest.

After the crashes, I ran Memtest86+ v4.20 for 3 hours without errors.

I am going to attach the log file of the second crash; the log file of the first crash consists of nothing but NULs.

Changed 3 years ago by osmiy

sporadical host reboot

comment:44 Changed 3 years ago by osmiy

The same with VBox 4.0.8 r71778 See attachment!

Is that problem will be fixed? Anybody looking for that? Some estimations?

comment:45 follow-up: ↓ 47 Changed 3 years ago by frank

The real cause is still unknown. It looks like only Windows hosts are affected, and probably only 32-bit Windows hosts. What we need is more information from users experiencing these crashes. In #8202 mhanor added a comment at 2011-02-21 how to attach the driver verifier to the VBox kernel drivers. It would be definitely a hint if the driver verifier would complain about some of these drivers.

comment:46 follow-up: ↓ 51 Changed 3 years ago by michaln

We also need minidumps (if available) in addition to the log files.

And it would be good to know whether this is a problem with 64-bit guests in general or only guests with lots of RAM assigned. Based on the logs, it appears that most users here are pushing the host system rather hard, using a guest with 1GB or more RAM on a host which has 3GB or less RAM available and runs a memory hungry host OS like Windows 7.

comment:47 in reply to: ↑ 45 ; follow-up: ↓ 48 Changed 3 years ago by frank

Replying to frank:

The real cause is still unknown. It looks like only Windows hosts are affected, and probably only 32-bit Windows hosts. What we need is more information from users experiencing these crashes. In #8202 mhanor added a comment at 2011-02-21 how to attach the driver verifier to the VBox kernel drivers. It would be definitely a hint if the driver verifier would complain about some of these drivers.

Actually the driver verifier will probably complain this still does not need to be the real reason for these host reboots. A much more reliable prove is to remove the USB support from VirtualBox (uninstall + install VirtualBox without USB support). If these reboots are really gone we know for sure that the USB support is guilty.

comment:48 in reply to: ↑ 47 ; follow-up: ↓ 49 Changed 3 years ago by osmiy

Replying to frank:

Actually the driver verifier will probably complain this still does not need to be the real reason for these host reboots. A much more reliable prove is to remove the USB support from VirtualBox (uninstall + install VirtualBox without USB support). If these reboots are really gone we know for sure that the USB support is guilty.

The VirtualBox without USB support looks like promising... will try to work.

Keep in mind that reboot going without any BSOD and minidumps. Once was a mystery and I catch the BSOD (decoded version already attached).

comment:49 in reply to: ↑ 48 ; follow-up: ↓ 50 Changed 3 years ago by osmiy

Replying to osmiy:

The VirtualBox without USB support looks like promising... will try to work.

Keep in mind that reboot going without any BSOD and minidumps. Once was a mystery and I catch the BSOD (decoded version already attached).

Smooth sailing! Thank's to 'frank' for solution. No sporadic resets anymore, I can live without USB.

comment:50 in reply to: ↑ 49 Changed 3 years ago by osmiy

Replying to osmiy:

Smooth sailing! Thank's to 'frank' for solution. No sporadic resets anymore, I can live without USB.

Unfortunately I've received two resets during that time. After first one the driver verifier was configured for: vboxdrv, vboxnetadp, vboxnetfilt. But it's do not provide any information during next reset.

As result I see that without USB and with enabled verifier, the system are more stable, but still can be sporadically reseted.

comment:51 in reply to: ↑ 46 Changed 3 years ago by dlong

Replying to michaln:

We also need minidumps (if available) in addition to the log files.

And it would be good to know whether this is a problem with 64-bit guests in general or only guests with lots of RAM assigned. Based on the logs, it appears that most users here are pushing the host system rather hard, using a guest with 1GB or more RAM on a host which has 3GB or less RAM available and runs a memory hungry host OS like Windows 7.

It is not necessary to push the host system hard. My guest is configured with 128MB and it causes the host crash on the initial Windows boot screen, even before the OS is loaded. Changing the guest type to Windows 7 32-bit and turning off hardware virtualization gets rid of the crash, but of course Windows 7 64-bit in the guest won't boot.

comment:52 follow-up: ↓ 53 Changed 3 years ago by dlong

And no, Windows 7 won't boot in 128MB, but the crash happens before it gets that far.

comment:53 in reply to: ↑ 52 Changed 3 years ago by misha

Replying to dlong: To get the source of the problem, it would be very helpful if you are able to connect your failing machine to the kernel debugger. Most likely the crash that leads to the host restart would result in a break in kernel debugger, where you will be able to create a dump of a failing system state (i.e. a minidump, a kernel memory dump or a full dump).

You can get the steps on how to setup a windows kernel debugger and do a mempry dump from it  here. Let me know if you have any problem or need any help with that.

comment:54 follow-up: ↓ 55 Changed 3 years ago by dlong

misha, thanks for the link on kernel debugging. I tried it, but unfortunately don't have any new information. Apparently, the 0x101 error means that the current processor noticed that the other processor was hung. But it's not clear what the other processor was doing. There is always one suspicious thread with state "????" that WinDbg can't switch to, so I suspect some kind of memory corruption. If I don't get the 0x101 BSOD, the host just reboots, even with the kernel debugger connected. I'm guessing this is what happens when the current CPU hangs instead of the 2nd CPU. Perhaps it is some kind of watchdog reset. I'll keep poking around in WinDbg.

I also tried disabling the 2nd CPU (using advanced boot options of msconfig). This causes the reboot scenario with no 0x101 BSOD, reinforcing my suspicious that the only way to get a dump is for the current CPU to detect a hang on the other CPU.

Before trying the kernel debugger, I also tried running with driver verifications enabled, as mentioned above. It didn't detect anything.

comment:55 in reply to: ↑ 54 ; follow-up: ↓ 56 Changed 3 years ago by misha

Replying to dlong: Thanks for the investigation. If you are able to catch a 0x101 crash (BSOD) either with or w/o a WinDbg attached, it would be very useful to have a Full or Kernel memory dump for the crash to get a clue on what's going on your system.

If you catch it with WinDbg, use .dump /f path/to/the/dump/file.dmp
Alternatively you could configure your system to create a Full or Kernel Memory dump (as opposed to Minidump) when the system crash occurs. To configure your system to create a Full Memory dump go to My Computer -> Properties -> Advanced System Settings -> switch to "Advanced" tab -> press "Settings" in a "Startup and Recovery" group -> select "Complete Memory Dump" and dump file location (which is %SystemRoot%\MEMORY.DMP by default). Note that you must have enough free space on your HD for the memory dump to be written, i.e. you need extra space of size ~your RAM size.

In case you have a dump, please drop me a mail at mikhail dot sennikovsky at oracle dot com and I'll post you an FTP link, where you can upload the dump.

comment:56 in reply to: ↑ 55 Changed 3 years ago by dlong

Replying to misha:

In case you have a dump, please drop me a mail at mikhail dot sennikovsky at oracle dot com and I'll post you an FTP link, where you can upload the dump.

I do have a full dump. I sent you an email on 6/7. Let me know if you didn't get it.

comment:57 Changed 3 years ago by osmiy

VirtualBox v4.1.2-73507 still contain that problem. No any dumps generated, just CPU reset.

comment:58 Changed 3 years ago by Andre.Ziegler

I think I have the same issue:

 http://www.virtualbox.org/ticket/9458

but I get no crash. The host PC (32Bit Windows 7) simply reboots when I try to install 64Bit Windows 7.

comment:59 follow-up: ↓ 60 Changed 3 years ago by frank

Hmm, but Andre.Ziegler reports that this does only happen if he uses a PAE kernel on the host. osmiy, can you confirm that?

comment:60 in reply to: ↑ 59 ; follow-up: ↓ 63 Changed 3 years ago by osmiy

Replying to frank:

Hmm, but Andre.Ziegler reports that this does only happen if he uses a PAE kernel on the host. osmiy, can you confirm that?

I tried several boots without PAE (in force disabled on host and guest) and looks like system stable. I'll try under load with several days.

comment:61 Changed 3 years ago by vader86

I have a similar Problem: directly after running our virtual machine within VirtualBox (Version 4.0.12), my host system reboots without any message. Sometimes this happens also happens while working within the guest operation system, however, in most cases the "crash" (actually just a reboot) of the host happens instantly after running the image. This happens on several notebooks (all with the same host/guest installation, just slightly different hardware).

Host: 32bit Windows 7 Guest: 64bit Ubuntu

The extended feature "PAE/NX" under "Settings->System" is disabled.

comment:62 Changed 3 years ago by Andre.Ziegler

I tried it with and without the "PAE/NX" setting under "Settings->System". If I run the 32Bit host with full 8GB RAM support, the host reboots after "Loading files".

I'm also using an AMD. I use an AMD Phenom II X4 945 (4 Core, 3GHz).

comment:63 in reply to: ↑ 60 Changed 3 years ago by osmiy

Replying to osmiy:

I'll try under load with several days.

Unfortunately the resets still present, stable reset around 48 hours. The PAE disabled on host and guest OS.


[host] C:\Windows\system32>bcdedit /enum | findstr pae ===> pae ForceDisable


With enabled PAE resets occurred around 30 minutes. Setup the same: host - Win7 SP1 B7601 32bit, guest - ARCH Linux-2.6.39 64bit, CPU - Intel i5 520M

Note: VMware Server working fine with the same image.

comment:64 Changed 2 years ago by dlong

I also get a BSOD if I turn on VT-X/AMD-V for a 32-bit Linux guest, so it doesn't require a 64-bit guest, only AMD-V. Still seeing the problem in 4.1.6.

comment:65 Changed 2 years ago by frank

  • Version changed from VirtualBox 3.1.4 to VirtualBox 4.1.6

comment:66 Changed 2 years ago by Andre.Ziegler

any news about this or #9458?

comment:67 Changed 2 years ago by song2

I have an Intel Core I5-2520M, I an running Windows7 30bit, on it I am running virtual-box 4.1.8, on that I am running Windows server 2008.

I added a second network adapter, and very early in the boot the host died (black screen, and reboot).

Changed 19 months ago by AgainAndAgain

host suddenly reboot

comment:68 Changed 19 months ago by frank

  • Description modified (diff)

AgainAndAgain, how often does this happen? Can you trigger this host reboot?

comment:69 Changed 18 months ago by Godji

I have had this issue running a 64bit Ubuntu 12.04 guest on a Windows 7 32bit host with the VB 4.1.x series. Most of the time I would get the CLOCK_WATCHDOG_TIMEOUT, but sometimes the host will simply self-reboot. The host has 4G RAM, while the guest has 1.5G. The guest is usually running at 100% CPU usage (it has 1 CPU) and often very heavy I/O simultaneously.

I noticed that the crash happens much more often when doing I/O in the guest. Copying a large file within the guest would often crash the host within seconds (but would sometimes work for a few days with no issue). The problems seems worse with increased memory pressure on the host (e.g. running more programs alongside VB).

I think I found a workaround: disable host I/O caching for the storage controller.

With this workaround, the same setup is very stable. The host still crashes but very rarely - only twice for the two months since I changed the setting.

I hope this is useful for others too, and I hope it will point the developers to where the problem might lie.

comment:70 Changed 8 months ago by frank

Please check ticket #11979, most likely this is a duplicate.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use