VirtualBox

Ticket #9458 (closed defect: duplicate)

Opened 3 years ago

Last modified 7 months ago

Host PC (Windows 7 32Bit) reboots if you install a 64Bit Windows 7 when the host PC uses PAE

Reported by: Andre.Ziegler Owned by:
Priority: critical Component: other
Version: VirtualBox 4.1.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

If I run VB (I tried 4.0.12 and 4.1.2) on a 32Bit Windows 7 with a PAE Patched Kernel [1] to use more memory and try to install a 64Bit Windows 7 as guest, the host PC suddenly reboots after the "Loading Windows files" finished at start of the Windows 7 setup. VMWare Player has no issues to run a 64Bit guest on a 32Bit PAE enabled host.

If I run the normal kernel everything is fine.

I attach 2 logs, 1 where it works and the other where the host simply reboots.

[1]  http://www.geoffchappell.com/viewer.htm?doc=notes/windows/license/memory.htm

Attachments

VBox_working_4.1.2.log Download (77.1 KB) - added by Andre.Ziegler 3 years ago.
VBox_reboot_4.1.2.log Download (47.9 KB) - added by Andre.Ziegler 3 years ago.
VBox_4.1.4_withoutPAE_working.log Download (77.4 KB) - added by Andre.Ziegler 3 years ago.
VBox_4.1.4_withPAE_not_working.log Download (48.1 KB) - added by Andre.Ziegler 3 years ago.
VBox_4.1.6_withoutPAE_working.log Download (78.9 KB) - added by Andre.Ziegler 2 years ago.
VBox_4.1.6_withPAE_not_working.log Download (49.1 KB) - added by Andre.Ziegler 2 years ago.

Change History

Changed 3 years ago by Andre.Ziegler

Changed 3 years ago by Andre.Ziegler

comment:1 Changed 3 years ago by Andre.Ziegler

Any news? Is there a new test version available?

comment:2 Changed 3 years ago by frank

Should be finally fixed with VBox 4.1.4, please confirm.

comment:3 Changed 3 years ago by Andre.Ziegler

No, it is not fixed. I still have the issue.

Changed 3 years ago by Andre.Ziegler

Changed 3 years ago by Andre.Ziegler

comment:4 Changed 3 years ago by frank

  • Version changed from VirtualBox 4.1.2 to VirtualBox 4.1.4

Thanks for the additional information.

comment:5 Changed 2 years ago by Andre.Ziegler

Have you found a way to workaround this issue?

comment:6 Changed 2 years ago by Andre.Ziegler

I get still get the error with 4.1.6.

Changed 2 years ago by Andre.Ziegler

Changed 2 years ago by Andre.Ziegler

comment:7 Changed 2 years ago by Andre.Ziegler

Also doesn't work in 4.1.7.r75040.

Are you still interested in fixing this or not? If not, I can delete the 32Bit Windows.

comment:8 Changed 2 years ago by frank

  • Description modified (diff)

Yes, we are interested in fixing this bug but we cannot reproduce this problem, therefore not that high priority.

comment:9 Changed 2 years ago by Andre.Ziegler

ok. I'm using a AMD Phenom II X945 3GHz, maybe this helps.

comment:10 Changed 2 years ago by Sébastien Barré

Hi, I also get the problem with an Intel Core i7-2600 - 3.4GHz, 4GB RAM, no PAE. guest: windows 2008 server R2, 64bits. host: windows 7, 32 bits. Virtualbox release number: 4.1.8 r75467 I note that the more I allocate memory to the guest, the more it waits before rebooting the host. So I guess there is a problem at the limit, when the memory reaches full utilization. Unfortunately I am memory-limited and it is impossible to allocate enough memory to completely avoid reboots, as in this case virtualbox cannot lock it (since it is required by the host windows). Hope this helps, Sébastien.

comment:11 Changed 11 months ago by HTamás

The bug still happens with 4.2.12. Dell E6420, Intel CPU (i5-2520), win7 professional

comment:12 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Most likely a duplicate of #11979. I know, this ticket is older but the other ticket contains more information. And we think we finally fixed the problem, see the other ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use