VirtualBox

Ticket #6059 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Restoring Windows VM with Running Linux VM inside causes host system reset

Reported by: klichota Owned by:
Priority: critical Component: other
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

This bug is related to ticket #6058.

I am running Windows XP (SP3) virtual machine on Linux (Ubuntu 8.04-derived distro) host. Inside this VM I have installed VirtualBox 3.0.12 and created VM for Linux guest (again Ubuntu 8.04-derived distro).

I have run the guest (and it is really slow) for quite long time and saved the outer (Windows) VM state (without stopping inner VM).

When I have tried to restore Windows VM state, the host (Linux) system got hard-reset - no oops, no dump, just went directly to boot procedure (BIOS, etc.). No trace of reset in host kernel logs.

I reproduced it a few times, although sometimes it did not happen (I think the inner Linux VM must run for some time for it to happen).

My processor does not support VT-X, so hardware virtualization was not used.

The kernel on host is standard Ubuntu kernel 2.6.24-24-generic.

Attachments

VBox.log Download (45.2 KB) - added by klichota 4 years ago.
VBox log of outer VM (Windows guest on Linux guest)
Test-2010-01-22-10-02-41.log Download (32.9 KB) - added by klichota 4 years ago.
VBox log of inner VM (Linux VM running inside Windows host)

Change History

Changed 4 years ago by klichota

VBox log of outer VM (Windows guest on Linux guest)

Changed 4 years ago by klichota

VBox log of inner VM (Linux VM running inside Windows host)

comment:1 Changed 4 years ago by sandervl73

Looks like a duplicate of #3945.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if necessary (test with VBox 3.2.6 first).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use