VirtualBox

Ticket #3945 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

VirtualBox 2.2.2 reboots the host machine each second time I restore the guest => Fixed in 3.1.4

Reported by: orion Owned by:
Priority: critical Component: VMM
Version: VirtualBox 3.0.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

My host machine is an openSUSE 11.0, kernel 2.6.25.20-0.1-default (i586). I am currently using VirtualBox 2.2.0 installed using the official rpm  http://download.virtualbox.org/virtualbox/2.2.0/VirtualBox-2.2.0_45846_openSUSE110-1.i586.rpm and I have no problem to suspend and resume the guest host (Windows XP sp3 with guest addition installed in it).

If I update VirtualBox to the 2.2.2, then each time I restore the guest, my host reboots immediatly. The behavior is exactly as the one of ticket:3481: No logs are created and /var/log/messages does not contain information about the cause of the reboot.

Attachments

VBox.log Download (44.0 KB) - added by orion 5 years ago.
VBox.log generated by VBox 2.2.2, using Guest Addition 2.2.0
VirtualBox.xml Download (2.7 KB) - added by orion 5 years ago.
the corrupted xml file
VBox.log-preReboot Download (45.5 KB) - added by orion 5 years ago.
The log of the session that has induced the reboot
VBox.jpg Download (66.4 KB) - added by orion 5 years ago.
The screenshot of the error message relative to the corrupted xml file

Change History

comment:1 Changed 5 years ago by frank

  • Priority changed from major to critical

Nasty problem. So this WinXP guest was created with VirtualBox 2.2.0 or an earlier version and you upgraded to VirtualBox 2.2.2. You say that your host reboots every second time. Does restoring the guest means to restore from a snapshot or from a saved state?

comment:2 Changed 5 years ago by orion

If I remember right, I created the guest with VirtualBox 1.6.4 and then I have regularly updated VBox using only official rpms.

And the problem occurs when I restore from a saved state (Host+Q, save state of the machine). I have not tried to restore from a snapshot yet...

comment:3 Changed 5 years ago by orion

I have some news about the problem.

Probably it depends on the version of the guest addition: I have updated them to the 2.2.2 version (from the 2.2.0 one) and the guest can be restored without reboots.

comment:4 Changed 5 years ago by frank

orion, please could you attach a VBox.log file, doesn't matter if with installed 2.2.0 additions or with 2.2.2 additions. So far we were not able to reproduce this problem.

comment:5 Changed 5 years ago by orion

I am not able to reproduce the problem again. Probably some operation I performed (for example, updating the guest addition and/or VirtualBox) has removed the cause of the problem.

I think you can close this ticket since it is no more reproduceable.

comment:6 Changed 5 years ago by frank

Will close but could you attach a current VBox.log file anyway? Even with older guest additions installed, the host should not crash. I just want to have a look at your configuration. A 2.2.2 VBox.log file is fine.

Changed 5 years ago by orion

VBox.log generated by VBox 2.2.2, using Guest Addition 2.2.0

comment:7 Changed 5 years ago by orion

VirtualBox has rebooted my host another time. Moreover, it has corrupted the VirtualBox.xml configuration file (now I have restored it using a backup copy). I will attach the VBox.log of the session that has induced the reboot, the corrupted xml and a screenshot of the message.

Changed 5 years ago by orion

the corrupted xml file

Changed 5 years ago by orion

The log of the session that has induced the reboot

Changed 5 years ago by orion

The screenshot of the error message relative to the corrupted xml file

comment:8 Changed 5 years ago by frank

Hmm, perhaps something related to the openSUSE kernel configuration. I assume you are using the standard openSUSE 11.0 kernel as described above or did you change the kernel config somehow?

comment:9 Changed 5 years ago by orion

I am using the officially updated kernel.

ori@orodruin:~> rpm -qi kernel-default
Name        : kernel-default               Relocations: (not relocatable)
Version     : 2.6.25.20                         Vendor: SUSE LINUX Products GmbH, Nuernberg, Germany
Release     : 0.1                           Build Date: Wed 14 Jan 2009 04:00:29 AM CET
Install Date: Tue 20 Jan 2009 01:59:26 PM CET      Build Host: deacon.suse.de
Group       : System/Kernel                 Source RPM: kernel-default-2.6.25.20-0.1.nosrc.rpm
Size        : 77728846                         License: GPL v2 or later
Signature   : DSA/SHA1, Wed 14 Jan 2009 04:13:04 AM CET, Key ID a84edae89c800aca
Packager    : http://bugs.opensuse.org
URL         : http://www.kernel.org/
Summary     : The Standard Kernel for both Uniprocessor and Multiprocessor Systems
Description :
The standard kernel for both uniprocessor and multiprocessor systems.



Source Timestamp: 2008-12-12 20:30:38 +0100
CVS Branch: SL110_BRANCH
Distribution: openSUSE 11.0 (i586)

installed from  http://download.opensuse.org/update/11.0/

The only things that may have changed the default configuration are the VirtualBox modules and the ATI fglrx module (installed using the "official" repository  http://www2.ati.com/suse/11.0/). But I have installed the ATI module much before the first reboots (that occur only with vbox 2.2.2): from the y2logRPM file

2009-03-21 08:28:57 x11-video-fglrxG01-8.582-2.1.i586.rpm installed ok
...
2009-04-29 09:14:24 VirtualBox-2.2.2_46594_openSUSE110-1.i586.rpm installed ok

comment:10 Changed 5 years ago by orion

I have some supplementary information: the reboot occurs also with guest addition 2.2.2 installed into the guest. Moreover, the reboot occurs at the end of the restoration, when the guest display is repainted (the last reboot occurs when the guest display has been repainted for one quarter of its size).

I do not know if it can be meaningful, but I suspend the guest when it is maximized.

comment:11 Changed 5 years ago by grimmo

Hello, I'm having the same problem. Running Ubuntu 9.04 with latest kernel 2.6.28-13-generic on a Dell GX270 and Windows XP SP3 as a guest. Virtualbox package version is 2.2.4-47978_Ubuntu_intrepid.

comment:12 Changed 5 years ago by frank

  • Component changed from other to VMM

Are these reboot problems still current with VBox 3.0.6?

comment:13 Changed 5 years ago by frank

In the meantime, VBox 3.0.8 was released. Please reopen this ticket if you still see this problem.

comment:14 Changed 5 years ago by orion

The problem still occurs. The current configuration is: VBox 3.0.8, fresh guest (created under VBox 3.0.6), vbox-guest-additions 3.0.8 correctly installed and guest rebooted after the installation.

comment:15 Changed 5 years ago by frank

  • Version changed from VirtualBox 2.2.2 to VirtualBox 3.0.8

comment:16 Changed 5 years ago by frank

I've got the core dump and indeed an exception in the libasound2-plugins pulse part is hit. Most probably the connection terminated unexpectedly but the question is why.

comment:17 Changed 5 years ago by frank

I'm sorry, this was the wrong defect.

comment:18 Changed 4 years ago by frank

  • Summary changed from VirtualBox 2.2.2 reboots the host machine each second time I restore the guest to VirtualBox 2.2.2 reboots the host machine each second time I restore the guest => Fixed in 3.1.4

Should be fixed in VBox 3.1.4, the  Beta 1 contains the fix.

comment:19 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use