VirtualBox

Ticket #5955 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

VirtualBox cannot set DNS servers in nat mode

Reported by: marco.pallotta Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

With VirtualBox 3.1.0 r55467 and Ubuntu 10.04 (alpha) I have found that in nat network mode (obvoulsy with the host network connection actived) virtualbox cannot set DNS servers (I verified this with a simple cat /etc/resolv.conf and with selecting "connection information" through NetworkManager icon).

With the last stable Ubuntu release (9.10) all worked ok.

Attachments

VBox.log.gz Download (8.0 KB) - added by marco.pallotta 4 years ago.
file.pcap.gz Download (3.6 KB) - added by marco.pallotta 4 years ago.

Change History

Changed 4 years ago by marco.pallotta

comment:1 Changed 4 years ago by marco.pallotta

After some "save state" and "resume state" operations NetworkManager was able to correctly set DNS info. At this point I suspect that the problem is related to NetworkManager and not to VirtualBox (seen that with the same VirtualBox release but different guest Ubuntu version all worked ok without problems).

comment:2 Changed 4 years ago by Hachiman

Does it repeat with last update of your Lucid guest and VBox 3.1.2. If yes could you please send me (vasily _dot_ levchenko _at_ Sun _dot_ COM)  pcap file.

Changed 4 years ago by marco.pallotta

comment:3 follow-up: ↓ 4 Changed 4 years ago by marco.pallotta

The same things happened with VBox 3.1.4 and one of the last Lucid guest (maybe not proper the last guest). After some reboot the problem was resolved (when I generated the pcap file the problem disappeared so I don't know if it's useful to debug the problem)

comment:4 in reply to: ↑ 3 Changed 4 years ago by Hachiman

Replying to marco.pallotta:

The same things happened with VBox 3.1.4 and one of the last Lucid guest (maybe not proper the last guest). After some reboot the problem was resolved (when I generated the pcap file the problem disappeared so I don't know if it's useful to debug the problem)

Thanks for pcap file. I've been able reproduce the problem. Resolution for me become not restart the guest, but starting dhclient once again. Not clear why guest receive IP and other network attributes but don't like name servers at first attempt.

comment:5 Changed 4 years ago by Hachiman

Could you please check if message like

option domain-name-servers 10.0.2.3;

presented in your /var/lib/dhcp3/dhclient.eth0.leases, even if /etc/resolv.conf is empty. For clear experiment I'd recommend to clean this folder.

comment:6 Changed 4 years ago by marco.pallotta

@Hachiman, there isn't the option you sayd on my dhclient-xxxxxxx-xxxx-xxxx-xxxxxxxxxxxx-ethx.lease

comment:7 follow-up: ↓ 8 Changed 4 years ago by marco.pallotta

@Hachiman, in my situation to replicate your resolution (that is restarting dhclient). Today neither with 5 reboot my guest received correct IP

comment:8 in reply to: ↑ 7 Changed 4 years ago by Hachiman

Replying to marco.pallotta:

@Hachiman, in my situation to replicate your resolution (that is restarting dhclient). Today neither with 5 reboot my guest received correct IP

Do I understand correctly, that ifconfig for you shows values you haven't expected? Could you please paste here what is output of ifconfig for you?

comment:9 Changed 4 years ago by marco.pallotta

My ifconfig reports two interfaces: eth0 with inet addr: 10.0.2.15 lo with inet 127.0.0.1

I say again that I have no option "option domain-name-servers 10.0.2.3;" in my dhclient-xxxxxxx-xxxx-xxxx-xxxxxxxxxxxx-ethx.lease

comment:10 Changed 4 years ago by marco.pallotta

I forgot to say that the same issue is present in 10.04 beta 1

comment:11 Changed 4 years ago by marco.pallotta

I tried to manually insert the entry "option domain-name-server 10.0.2.3;" in my dhclient-xxxxxxx-xxxx-xxxx-xxxxxxxxxxxx-ethx.lease but with no success.

comment:12 Changed 4 years ago by marco.pallotta

In 10.04 beta1 I haven't yet established an Internet connection. I rebooted my system many times but no dhcp address was obtained (nor restarting network manager solved the problem)

comment:13 Changed 4 years ago by marco.pallotta

I finally succeded in obtaining a dhcp address for 10.04 beta1: powered off and the powered on the system (not restarting it as it didn't work). Obviously I will try again if this workaround is only a coincidence.

comment:14 Changed 4 years ago by marco.pallotta

It seems that just powering off and powering on the system solves the issue.

comment:15 Changed 4 years ago by Hachiman

could you please attach your /etc/resolv.conf on your host to defect or send it to me (vasily _dot_ levchenko _at_ Sun _dot_ COM)?

comment:16 follow-up: ↓ 17 Changed 4 years ago by marco.pallotta

My /etc/resolv.conf is empty when the issue happens (whereas if contains the entries nameserver 213.230.155.10 and 213.230.129.10 when if runs ok). I can confirm the also with 10.04 Beta 2 powering off and powering on the system solves the issue.

comment:17 in reply to: ↑ 16 Changed 4 years ago by Hachiman

Replying to marco.pallotta:

My /etc/resolv.conf is empty when the issue happens (whereas if contains the entries nameserver 213.230.155.10 and 213.230.129.10 when if runs ok).

Talking about /etc/resolv.conf here do you mean your host or guest resolv.conf ?

comment:18 follow-up: ↓ 19 Changed 4 years ago by marco.pallotta

I was talking about guest's /etc/resolv.conf

comment:19 in reply to: ↑ 18 Changed 4 years ago by Hachiman

Replying to marco.pallotta:

I was talking about guest's /etc/resolv.conf

Could you please past here your host /etc/resolv.conf?

comment:20 Changed 4 years ago by marco.pallotta

this is my host /etc/resolv.conf

nameserver 213.230.155.10
nameserver 213.230.129.10
### BEGIN INFO
#
# Modified_by:  NetworkManager
# Process:      /usr/bin/NetworkManager
# Process_id:   5053
#
### END INFO

comment:21 Changed 4 years ago by marco.pallotta

Since I have installed 10.04 beta2 I haven't seen this issue anymore (maybe it is only a coincidence). I will make other tests.

comment:22 Changed 4 years ago by Hachiman

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use