VirtualBox

Ticket #5954 (closed defect: fixed)

Opened 4 years ago

Last modified 2 years ago

VirtualBox 3.1.2 USB Unstable - Host System Crash (Vista x64)

Reported by: vitaliygavin Owned by:
Priority: critical Component: USB
Version: VirtualBox 3.1.2 Keywords: usb, instability, crash
Cc: Guest type: Windows
Host type: Windows

Description

VirtualBox running on Microsoft Windows Vista Home Premium x64 Edition causes USB installation to fail, capturing all USB devices on host and causing Windows to crash with a Stop error. (vbox.log not provided due to loss in the emergency recovery.)

Attachments

Mini011810-01.dmp Download (266.0 KB) - added by vitaliygavin 4 years ago.
BSOD Error 1
Mini011910-01.dmp Download (266.0 KB) - added by vitaliygavin 4 years ago.
BSOD Error 2

Change History

comment:1 Changed 4 years ago by vitaliygavin

-- Update -- VMs hang on reboot, reset required. -- Update -- Virtualbox continues to run destructively in the background even after GUI and all VMs are terminated, preventing the host OS from properly shutting down resulting in BSODs. Also does not respond to force terminate from Windows Task Manager (Process Tab)!! -- Only way to terminate is to cut power to host!! -- Update -- Windows reports that the "VirtualBox USB" driver must be reinstalled in Device Manager.


comment:2 follow-up: ↓ 3 Changed 4 years ago by frank

Is it possible that there is some older driver left from a previous installation of VirtualBox?

comment:3 in reply to: ↑ 2 Changed 4 years ago by vitaliygavin

Replying to frank:

Is it possible that there is some older driver left from a previous installation of VirtualBox?

VirtualBox is uninstalled with Add/Remove Programs when upgrading, and then this version is installed. All guest additions are upgraded, and the previous installation file deleted and replaced with the new one.

comment:4 Changed 4 years ago by vitaliygavin

UPDATE -- Network properties disabled for all nics on host when virtualbox runs. Message is "Another properties dialog is already open..." UPDATE -- MMC frequently hangs when virtualbox runs. Uninstalling VirtualBox solves all issues and improves computer performance.

comment:5 follow-up: ↓ 6 Changed 4 years ago by sandervl73

  • Priority changed from blocker to critical

Works fine here since 3.1.2.

Reinstall VirtualBox without the network components to rule out that part. In case of a BSOD it's useful to attach the minidump here. Without it we can't help you.

comment:6 in reply to: ↑ 5 Changed 4 years ago by vitaliygavin

Replying to sandervl73:

Works fine here since 3.1.2.

Reinstall VirtualBox without the network components to rule out that part. In case of a BSOD it's useful to attach the minidump here. Without it we can't help you.

Already running version 3.1.2, and networking is required. Is downgrading possible? This version really hurts server performance...

Changed 4 years ago by vitaliygavin

BSOD Error 1

Changed 4 years ago by vitaliygavin

BSOD Error 2

comment:7 Changed 4 years ago by vitaliygavin

UPDATE -- I have provided the BSOD memory dump files for this isuue. This error occurs every time I shut down the system after closing virtualbox. The system is never able to successfully shut down. I'm unable to provide the vbox.log file due to the corruption of the system. I think this issue deserves higher priority. Even after a full system recovery, on a clean install of Windows, this issue persists. 'Previous versions didn't have this issue.'

comment:8 Changed 4 years ago by sandervl73

Could be similar to #5885. You can check the test build that's posted there. Only applies if the cause is USB.

It's still useful to uninstall VirtualBox and reinstall without network to rule out that possibility. And yes, you can downgrade.

comment:9 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.1.6. The Windows USB host support was completely rewritten for VBox 4.1.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use