VirtualBox

Ticket #5936 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Swapped keys on Mac host Linux guest

Reported by: gionn Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

Macbook pro keyboard have 2 keys with keycodes swapped (49 and 94). Under native Linux, the kernel recognize the hardware and swap automatically the keys, under Virtualbox it doesn't.

As a workaround, I am using xmodmap with ~/.Xmodmap containing, it apply for the italian keyboard layout only:

keycode  49 = less greater less greater bar brokenbar
keycode  94 = backslash bar backslash bar notsign notsign

Change History

comment:1 Changed 4 years ago by gionn

Hey, so much dupes: #5278 #4006 #2996 #1494 #5185

comment:2 Changed 4 years ago by uhebeisen

same situation under Windows XP with the Swiss German keyboard selected. I've just checked the italian keyboard layout and the key position is the same. On the Swiss German keyboard the affected keys are "<" and "§" (topmost left key).

There is a keyboard layout editor from Microsoft that I will use to create a Swiss German MacBook (and MacBook Pro) keyboard. It would be possible to swap these to keys in a special configuration but I think it would be better to wait until this issue gets fixed in a next version of VB.

VB for Mac 3.1.2 MacBook pro Mac OS X 10.6.2 Guest OS: WinXP ServicePack 3

comment:3 Changed 4 years ago by gionn

Another fix is to enable the apple:badmap xkb option.

On Debian Lenny I've apt-getted console-setup and followed the wizard with default choices; modified the file /etc/default/console-setup:

XKBMODEL=""
XKBLAYOUT="it"
XKBVARIANT=""
XKBOPTIONS="lv3:ralt_switch,apple:badmap"

Can the two keycodes be swapped automatically by Guest additions when the host is MacOs?

Thanks.

comment:4 Changed 4 years ago by claudio_

I've added to  http://www.virtualbox.org/ticket/6046 (another duplicate) a program which shows that the scancode is wrong down to what the 8042 controller delivers.

comment:5 Changed 3 years ago by gionn

Any updates in 10 months for this minor bug?

comment:6 Changed 3 years ago by frank

  • Version changed from VirtualBox 3.1.2 to VirtualBox 3.2.10

Yes, there is a special handling for certain keyboards necessary. The fix is not straight-forward. You might have noted that there are more than 2600 other bug reports open?

comment:7 Changed 3 years ago by poetzsch

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #2996.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use