VirtualBox

Ticket #4006 (closed defect: duplicate)

Opened 5 years ago

Last modified 3 years ago

<> and @# keys are inverted in Ubuntu Linux

Reported by: M-Rick Owned by:
Priority: major Component: other
Version: VirtualBox 2.2.2 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

When using Ubuntu Linux with the French MacBook keyboard, keys <> and @# are inverted : <> should be between SHIFT and W, @# should be on left of &1, but I have @# between SHIFT and W, <> on left of &1. The problem will not occur neither in Parallels Desktop nor in VMware Fusion.

Change History

comment:1 in reply to: ↑ description Changed 5 years ago by ha42

See also ticket #2996. I have the same problem with a Windows XP guest on a Macbook with OS X 10.4.11. On a german keyboard the keys </>/| (to the right of the left shift key) and ^/° (left to the key 1/!, below ESC) are swapped.

The problem is not new, I had this also on earlier versions (since 1.6 I belive). Could you please fix this? It is really annoying - try to write some HTML or XML with this keys swapped!

comment:2 Changed 4 years ago by Technologov

This bug seems related to bugs #2996 #1494

-Technologov

comment:3 Changed 4 years ago by walter.recaldini

Same problem for the Italian keyboard \| and <> are swapped. The problem apply to all guest OS (at least linux and windows)

comment:4 Changed 4 years ago by pato

I've exactly the same problem with ubuntu 10.04. Please can you solve the problem, I guess it doesn't take a lot of time to solve.

comment:5 Changed 3 years ago by michaln

  • Status changed from new to closed
  • Resolution set to duplicate

This is a duplicate of #2996.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use