VirtualBox

Ticket #5849 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Snapshotting a running VM on iscsi leads to I/O error => fixed in SVN, will be fixed in 3.1.4

Reported by: bauer40 Owned by:
Priority: minor Component: virtual disk
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Linux
Host type: Solaris

Description

I am running a most current debian VM on top of VBox 3.1.2 on Solaris 10 U6u7, kernel 141415-04. This VM uses an ISCSI disk provided by the same physical host.

When trying to snapshot the running machine by selecting "Take snapshot" from the "Machine" menu and trying to take a snapshot, the progress starts, takes a few seconds and aborts again.

After that, further disk I/O requests of the guest lead to write errors.

The most recent guest additions are installed.

Set the priority to minor due to the not so frequent setup using ISCSI.

Attachments

VBox.log Download (75.0 KB) - added by bauer40 4 years ago.
VBox.log
testdebian.xml Download (4.4 KB) - added by bauer40 4 years ago.
XML configuration file of the VM

Change History

Changed 4 years ago by bauer40

VBox.log

Changed 4 years ago by bauer40

XML configuration file of the VM

comment:1 follow-up: ↓ 2 Changed 4 years ago by klaus

Confirmed. Caused by an incorrect empty string check. I didn't try it, but maybe you could work around this by explicitly specifying LUN 0. That's the immediate problem which prevents the VM from continuing.

comment:2 in reply to: ↑ 1 Changed 4 years ago by bauer40

Replying to klaus:

Confirmed. Caused by an incorrect empty string check. I didn't try it, but maybe you could work around this by explicitly specifying LUN 0. That's the immediate problem which prevents the VM from continuing.

Good to know. I suppose you mean I should temporary use the --lun option :

VBoxManage addiscsidisk --server some.host.name --target iqn.... --lun 0

Will this be fixed?

comment:3 Changed 4 years ago by klaus

Sure it will be fixed.

comment:4 Changed 4 years ago by klaus

  • Component changed from other to virtual disk
  • Summary changed from Snapshotting a running VM on iscsi leads to I/O error to Snapshotting a running VM on iscsi leads to I/O error => fixed in SVN, will be fixed in 3.1.4

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use