VirtualBox

Ticket #5815 (new defect)

Opened 4 years ago

Last modified 5 weeks ago

Clipboard sharing stops working

Reported by: sesam Owned by:
Priority: major Component: clipboard
Version: VirtualBox 3.1.2 Keywords: copy, paste, sharing, stops, working, fail
Cc: Guest type: other
Host type: Windows

Description (last modified by michael) (diff)

Clipboard sharing stops working when running VirtualBox 3.1.2r56127 for while. Rebooting the guest, or restarting vboxtray.exe solves the issue for a few minutes.

Host: Windows Vista 64bit SP2 Guest: Windows XP SP3 (clean install)

Attachments

VBox.log Download (57.2 KB) - added by sesam 4 years ago.
Log file

Change History

Changed 4 years ago by sesam

Log file

comment:1 Changed 4 years ago by sesam

Did more testing, and concluded that problem appears only occur in one direction. "copy and paste" only works once between host to guest. Same thing after I restart "vboxtray.exe", copy and paste between host to guest works once. But surprisingly "copy and paste" from guest to host continues to work.

comment:2 Changed 4 years ago by kidault

I have the same problem. Are there any solution, or what can we do to help? Host: Windows 7 Pro Guest: Windows XP Home SP3

comment:3 follow-up: ↓ 4 Changed 4 years ago by kidault

This ticket seems to be a duplicate of ticket #5266  http://www.virtualbox.org/ticket/5266

comment:4 in reply to: ↑ 3 Changed 11 months ago by xpt

Replying to kidault:

This ticket seems to be a duplicate of ticket #5266  http://www.virtualbox.org/ticket/5266

The ticket #5266 is now closed and resolution set to wontfix because it has become too long and confused. So I'm following up here.

I'm experiencing the exact same problem, detailed in here  https://forums.virtualbox.org/viewtopic.php?f=6&t=55338

To recap,

  • Host: Win 7 desktop, 12G Mem
  • Guest: Linux (Ubuntu Precise)

It works when the VM is freshly started, but it won't be long before the copy and paste capability between the host and client is gone.

When it is gone,

  • it is always that copy from Win 7 Host and paste into Linux guest that is not working. The other way around normally still works.
  • it will not work if I merely logging in and out of X on my Linux guest or even restart my Linux within VM, but I have to stop the VirtualBox entirely, and restart again.

Then it will work again.

From ticket #5266, I understand that "This is usually due to some other application misbehaving and the problem showing up in VirtualBox", and learned that in Windows guest it can be fixed by stopping and re-starting the "VBoxTray" application.

I also understand that VirtualBox uses the old, more fragile Windows XP clipboard chain functionality to listen for clipboard changes. All I'm asking for is a quick fix function like re-starting the "VBoxTray" application in Windows guest, so that I don't need to restart my Linux ever so often.

Thanks

Last edited 11 months ago by xpt (previous) (diff)

comment:5 Changed 6 weeks ago by BenArmstrong

I can confirm the existence of this bug in 4.3.8 r92456 on a Debian sid/amd64 host with a Windows XP guest, and guest additions updated to the same revision.

I have observed the same symptoms as in comment #4. Manually restarting VBoxTray does work around the issue, except after doing this my paste manager on my host is dead in the water. clipit issues a number of these errors, and clicking the clipit icon fails to bring up a menu:

Clipboard is null, recovering ...

I need to kill clipit and restart it for it to function properly again. When the problem eventually recurs, clipit stops functioning again with the same errors, and restarting VBoxTray.exe in the guest and clipit in the host resolves it again.

comment:6 Changed 6 weeks ago by BenArmstrong

I tested running without clipit or any other clipboard manager for a day. It may have delayed onset of the problem, as I had no recurrence of the bug until the following morning, and that is unusual for me to go a whole day without a single failure. However, it did not prevent the bug, as the next morning (with the VM running continuously all that time) after my first Host -> Guest paste, I was unable to do any further pastes.

Is there anything else I can do to advance a solution of this bug? This is causing a measurable trickle away of lost productivity constantly dealing with having to restart VBoxTray and my clipboard manager.

Thanks, Ben

comment:7 Changed 5 weeks ago by michael

  • Description modified (diff)

Regarding clipit, I would say that it is a bug there you need to restart it, so you should probably contact its maintainers. And the problems on the Windows XP guest side are most likely due to some other application in the guest breaking the clipboard, perhaps with a bit of experimentation you can find out what that application is. Unfortunately the Windows XP clipboard interfaces allow this to happen.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use