Ticket #5797 (closed defect: obsolete)

Opened 6 years ago

Last modified 4 months ago

Frequent network stoppages/poor performance on VBox 3.1 running pkg image-update in guest

Reported by: rlk Owned by:
Priority: major Component: network
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Solaris
Host type: Linux

Description (last modified by frank) (diff)

Running VirtualBox 3.1.0/3.1.2 on OpenSUSE 11.1 (64 bit) with OpenSolaris (b126 or b128) guest.

If I run "pkg image-update -v" in the guest to upgrade to build 129, I get frequent errors as below. I'm using NAT networking. I've tried a variety of settings in the guest (enable/disable VT-x, for example) with no change in results. I've tried both the and Sun internal repositories with the same result. What I observe is that package retrieval makes decent forward progress for a minute or so, and then hangs for quite a while with no network activity showing, then it makes more progress for a bit, and eventually the image update times out as below.

Downgrading to VirtualBox 3.0.12 fixed this. I then reinstalled 3.1.2 and it started happening again.

SUNWj6rt                               13/1692   551/59050  15.3/1200.7 

Errors were encountered while attempting to retrieve package or file data for
the requested operation.
Details follow:

1: Framework error: code: 28 reason: Operation too slow. Less than 1024 bytes/sec transfered the last 30 seconds
URL: ''. (happened 3 times)
2: Framework error: code: 18 reason: transfer closed with 12526354 bytes remaining to read
URL: ''.

Change History

comment:1 Changed 6 years ago by rlk

This is still happening with 3.1.4.

Interestingly, I find that if I run netstat -i the transfer immediately starts back up -- consistently.

comment:2 Changed 4 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use