VirtualBox

Ticket #5796 (closed defect: obsolete)

Opened 4 years ago

Last modified 3 months ago

Direct3D Fails on WinXP with Mac OS X Host (3.1.2)

Reported by: clone2727 Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.1.2 Keywords: Direct3D
Cc: Guest type: Windows
Host type: other

Description (last modified by frank) (diff)

I installed Windows XP (SP2, upgraded to SP3) in VirtualBox on my Mac OS X 10.5 (x86) MacBook Pro. I then installed the guest additions in safe mode (checking the Direct3D box) and proceeded to test Direct3D after restarting in dxdiag. The DirectX 7 3D test fails (though it's supposed to), but then the DirectX 8 and 9 3D tests fail too.

I get this in DirectX:

Direct3D 7 test results: Failure at step 40 (Creating flipping primary surface with one back buffer): HRESULT = 0x88760064 (error code)
Direct3D 8 test results: Failure at step 4 (EnumAdapterModes): HRESULT = 0x8876086c (error code)
Direct3D 9 test results: Failure at step 6 (No hardware supported display modes found): HRESULT = 0x80004005 (Generic failure)

Some others on the  forums also noted this, but I didn't see any ticket.

I've attached the vbox.log file.

Attachments

VBox.log Download (46.3 KB) - added by clone2727 4 years ago.
VirtualBox Log

Change History

Changed 4 years ago by clone2727

comment:1 Changed 4 years ago by bugstomper

I can confirm this as also happening under host Mac OS 10.6.2 (Snow Leopard) on an iMac (with Core 2 Duo) while booted into a 32-bit kernel, running a Windows XP SP3 guest, trying with both the Microsoft DirectX 9c and with wine3d installed in safe mode. I believe that it worked fine when I had VirtualBox 3.0.x.

comment:2 Changed 4 years ago by bugstomper

I was able to successfully run the dxdiag DirectX 3D teats for DirectX 8 and 9 when I installed Microsoft DirectX on a guest XP on a 32-bit first generation MacBook. But then I cloned the virtual disk and copied it to the iMac where the tests had been failing and a virtual machine using that disk runs fine.

I confirmed that all the settings of the two virtual machines on the iMac are identical, but one works and the other doesn't. I haven't figured out what is different between the two.

comment:3 Changed 4 years ago by h-lame

I can confirm that this is still happening with 3.1.4.

I'm on Mac OS X 10.5.8 on a Macbook Pro running Win XP (32-bit) SP3 guest with DirectX 9c. It was definitely all fine with VirtualBox 3.0.x.

comment:4 Changed 4 years ago by skyw4lker

Still a problem for me with 3.1.6
Host: Linux 2.6.32 (seems not only to be a OS X problem), VGA: Geforce 6600GT
Guest: Windows XP Professional(32-bit) SP3 (clean/fresh installation)

Tried with and without installing current DirectX version, installed the additions in safe mode and even tried installing the wined3d directly
Tried that with all possible combinations and orders.
The errors are always like mentioned here except that D3D8 sometimes also fails in step 6.
Most games say there is no (accelerated) video card , but OpenGL games work very fine

comment:5 Changed 3 years ago by TheLQ

This is still an issue with 4.1, Fedora 15 Linux host, Windows XP Professional guest. The first test fails, and I think its what's causing an old game to crash (Beach Head)

comment:6 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use