VirtualBox

Ticket #5755 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Solaris guest hang/crash using SMP -> retry with 3.1.4

Reported by: rasta Owned by:
Priority: major Component: guest smp
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Solaris
Host type: Windows

Description

HOST:

WinXP x64 with VT enabled (E5120 quad-core Xeon processor)

6 GB RAM

NVIDIA Quadro FX 3500 video card

VBox 3.1.0

GUEST:

Solaris 10 u8 x86 64-bit

2560 MB RAM assigned

32 MB vram assigned

PAE/VT-x/IO-APIC enabled

Solaris guest additions installed.

Guest will hang or crash to GRUB if >1 processor is assigned to guest in VM settings. During hang with 2 cpus, both cpus are pegged at 100%.

Other issues:

1) Upon guest boot, I get this error once per cpu asigned to guest:

WARNING: cpu0 failed to update microcode form version 0x0 to 0xcb.

cpu1 is referenced for second processor assigned, if any.

2) Unlike previous versions of Vbox with Solaris GA installed, the guest display will not automatically resize unless screen resolution is entered into xorg.conf.

Attachments

Solaris 10 u8-2009-12-14-14-33-17.log Download (68.2 KB) - added by rasta 4 years ago.
Log of hung Solaris guest using 2 processors after forced power-off
Solaris 10 u8-2009-12-17-11-24-22_3.1.2.log Download (67.8 KB) - added by rasta 4 years ago.
Log of hung Solaris guest using 2 processors after forced power-off - Vbox 3.1.2

Change History

Changed 4 years ago by rasta

Log of hung Solaris guest using 2 processors after forced power-off

comment:2 Changed 4 years ago by rasta

Myself and SSCBrian have noted that a guest crash (or spontaneous reboot) occurs after using Sun Update Manager when using 2 processors.

comment:3 Changed 4 years ago by rasta

After a crash/reboot encountered while running a large application, I typically get WARNINGS with "No SOF interrupts have been received, this USB EHCI host controller is unusable." The guest as a whole is unusable at this point, and the VM must be killed and restarted.

comment:4 Changed 4 years ago by rasta

Same problem with Vbox 3.1.2. With 2 processors, 3.1.2 is completely unstable. Guests will hang and/or crash every time. Will attach log.

Changed 4 years ago by rasta

Log of hung Solaris guest using 2 processors after forced power-off - Vbox 3.1.2

comment:5 Changed 4 years ago by sandervl73

1) ignore it
2) works fine here

I can't reproduce any hangs or crashes during booting. Will try the update manager.

comment:6 Changed 4 years ago by rasta

The hangs and crashes ARE NOT during booting. Booting is fine with 2 processors. They occur either during Update Manager use or during the running of a large application.

Here is a thread about the guest screen resizing problem:

 http://forums.virtualbox.org/viewtopic.php?f=20&t=25559

Even after adding my screen resolution to xorg.conf, the main Solaris login screen remains shrunken (1024x?) from my 1280x1024 screen. Others have had only intermittent problems with resizing. Do you have any ideas as to how I can diagnose/fix this? This problem only occurs on the x64 host system outlined above. This problem is minor compared to the guest hang/crash issue.

comment:7 Changed 4 years ago by sandervl73

  • Summary changed from Solaris guest hang/crash using SMP to Solaris guest hang/crash using SMP -> retry with 3.1.4

Retry with 3.1.4. That version will include an important stability fix for SMP guests.

comment:8 Changed 4 years ago by rasta

Excellent! Thank you for the update!

comment:9 Changed 4 years ago by sandervl73

  • Component changed from other to guest smp

You can try the new test build in #6070 if you like.

comment:10 Changed 4 years ago by sandervl73

Please check if 3.1.4 beta 1 solves the problem:  http://forums.virtualbox.org/viewtopic.php?f=15&t=27300

comment:11 Changed 4 years ago by rasta

Will do.

comment:12 Changed 4 years ago by rasta

So far, the 3.1.4 beta (with Solaris additions installed) has not only not crashed or hung using 2 processors, but it is blindingly fast. I have never seen my Solaris guest move so fast. It is just AWESOME. I notice that one SMP processor is assigned to each of my two (quad) cores, unlike before, where both were on one core.

I have found no problems with my huge application, Update Manager, or anything else.

Also, I mentioned above the error on booting ("WARNING: cpu0 failed to update microcode form version 0x0 to 0xcb.") I moved the VM to my main machine (XP x64, dual Xeon E5345 processors, 6GB RAM) and that error is gone, whether I use one or more processors.

Also, with the 3.1.4 beta Solaris GA, so far I have NOT seen the screen resizing issue also mentioned above.

So far, it appears you guys (and gals?) have hit the ball out of the park on this one. Way out. Great job! I'll report back if I find any problems.

By the way, is Nested Paging supported on my processors?

comment:13 Changed 4 years ago by klaus

Nested paging support on Intel processor started with the Nehalem architecture, i.e. Xeon 55xx and Core i7. Some of the "stripped down" versions don't have nested paging.

So no luck.

comment:14 Changed 4 years ago by rasta

That's what I thought. My guest is now so fast it doesn't matter anyway. Maybe Nested Paging should be disabled in the VM GUI for processors that don't support it?

comment:15 Changed 4 years ago by sandervl73

You can ignore the microcode warning. We do not emulate this mechanism, which results in some confusion in the Solaris AMD microcode update code. It's completely harmless.

Great to hear things have improved so much for you. Unfortunately you can only check for nested paging support with supervisor code. We'll fix that in a future release.

comment:16 Changed 4 years ago by rasta

Yes, you already said I can ignore the warning, but the warning does not occur on my main system, only the older system with an E5120 processor.

comment:17 Changed 4 years ago by rasta

The guest screen resize issue mentioned above appears to be exactly the same as that reported in bug #5372, fixed in 3.1.4 beta 2.

comment:18 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use