VirtualBox

Ticket #5756 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

VirtualBox guest freezes while starting at 0% if serial ports are enabled => Fixed in SVN

Reported by: KingRadical Owned by:
Priority: major Component: uart
Version: VirtualBox 3.1.0 Keywords: serial freeze startup
Cc: Guest type: other
Host type: Linux

Description

Running VirtualBox 3.1.0 r55467 on Ubuntu 9.10 (non-OSE) installed via apt from the virtualbox.org apt repository.

VM guest OS is Windows XP.

I was running the OSE in the Ubuntu repositories before, but found I would require USB support since virtualbox only supports 2 serial ports at a time.

Now, when starting my VM, if BOTH serial ports are enabled, the VM freezes at 0% while "Starting virtual machine..."

My serial settings are: Port 1 Enabled COM1 Host Device /dev/ttyS0

Port 2 Enabled COM2 Host Device /dev/ttyS1

It freezes up with any settings for the second serial device. I have verified that nothing is using the serial ports, and that they function from the host machine.

Attachments

WinXP-2009-12-14-15-17-14.log Download (33.2 KB) - added by KingRadical 4 years ago.
VBox.log
Hugo-2010-05-11-22-13-04.log Download (31.4 KB) - added by tompano 4 years ago.

Change History

Changed 4 years ago by KingRadical

VBox.log

comment:1 Changed 4 years ago by frank

Cannot reproduce this problem here. You could forcly create a  core dump and contact me via private E-mail at frank _dot_ mehnert _at_ sun _dot_ com (I can tell you an FTP server for uploading the file).

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing. Feel free to still send me the requested core dump.

Changed 4 years ago by tompano

comment:3 Changed 4 years ago by tompano

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Hello,

I have the same problem as KingRadical with 3.1.8; has there been any solution to that. I need my serial port to access a chip card reader. See the attached log file Hugo*.

Regards

Thomas

comment:4 Changed 4 years ago by pva

I have same problem with 3.2.8 here. I'm using pcmcia to com port card and as soon as I map guest COM port on /dev/ttyS2 (or ttyS1) virtual box fails to start (just hangs). Without mapping it works. In VBox.log last line is

00:00:00.656 Serial#0: emulating 16550A
[...here hangs...]

As soon as I detach pcmcia adapter virtualbox exposes and error:

Не удалось открыть сессию для виртуальной машины WindowsXP.
Failed to open host device '/dev/ttyS2' (VERR_TRY_AGAIN).
Unknown error creating VM (VERR_TRY_AGAIN).

Код ошибки: NS_ERROR_FAILURE (0x80004005)
Компонент: Console
Интерфейс: IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

and VBox.log contains:

00:09:30.480 VMSetError: /home/vbox/tinderbox/3.2-lnx64-rel/src/VBox/Devices/Serial/DrvHostSerial.cpp(1385) int drvHostSerialConstruct(PDMDRVINS*, CFGMNODE*, uint32_t); rc=VERR_TRY_AGAIN
00:09:30.480 VMSetError: Failed to open host device '/dev/ttyS2'
00:09:30.480 AssertLogRel /home/vbox/tinderbox/3.2-lnx64-rel/src/VBox/Devices/Serial/DevSerial.cpp(1326) int serialConstruct(PDMDEVINS*, int, CFGMNODE*): <NULL>
00:09:30.480 Serial0: Failed to attach to char driver. rc=VERR_TRY_AGAIN
00:09:30.480 PDM: Failed to construct 'serial'/0! VERR_TRY_AGAIN (-52) - Retry the operation.
00:09:30.493 VMSetError: /home/vbox/tinderbox/3.2-lnx64-rel/src/VBox/VMM/VM.cpp(316) int VMR3Create(uint32_t, void (*)(VM*, void*, int, const char*, unsigned int, const char*, const char*, __va_list_tag*), void*, int (*)(VM*, void*), void*, VM**); rc=VERR_TRY_AGAIN
00:09:30.493 VMSetError: Unknown error creating VM
00:09:30.493 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={6375231a-c17c-464b-92cb-ae9e128d71c3} aComponent={Console} aText={Failed to open host device '/dev/ttyS2' (VERR_TRY_AGAIN).
00:09:30.493 Unknown error creating VM (VERR_TRY_AGAIN)} aWarning=false, preserve=false
00:09:30.509 Power up failed (vrc=VERR_TRY_AGAIN, rc=NS_ERROR_FAILURE (0X80004005))

Now I'll try to get coredump... BTW is it possible to subscribe to this bug report? Please, add me to CC or I'll be unable to follow progress.

comment:5 Changed 4 years ago by pva

Frank, core dump for VirtualBox 3.2.8r64453 is here:  http://dev.gentoo.org/~pva/virtualbox-core.6718.xz

It is xz compressed (decompressor could be found at:  http://tukaani.org/xz/

And sorry for pasting logs here. I thought 5 lines does no harm, but now I see the problem (too narrow monitor ;) ) and I'm unable to edit my post... :(

comment:6 Changed 4 years ago by frank

pva, thanks for the core dump. Which is the Linux distribution you took the core dump on?

comment:7 Changed 4 years ago by pva

That's Gentoo Linux. The following link was used to download package:

 http://download.virtualbox.org/virtualbox/3.2.8/VirtualBox-3.2.8-64453-Linux_amd64.run

comment:8 Changed 4 years ago by Gallandro

Is there any progress on this bug?

I have almost the same problem (or so it appears).

I.e. I have a Windows XP guest running on a Fedora 13 x86 (32-bit) host machine.

I have a 4-port serial PCMCIA card installed.

Whenever I try to enable either or both of the Virtualbox serial ports and map them to any of the O/S serial ports that are attached to the PCMCIA card, then the virtual machine just freezes at startup (0%) saying "Starting virtual machine".

Attaching to the laptop's native serial port does not do this, i.e. it does boot when attached to native serial port.

My log shows the same as pva on the freezes: 00:00:01.508: Serial#0: emulating 16550A

I note that pva was also using a PCMCIA serial port.

comment:9 Changed 4 years ago by Gallandro

Sorry, I should have mentioned, that I am running Version 3.2.8 r64453

comment:10 Changed 4 years ago by Gallandro

I have a follow-up.

If I run Putty on each of the O/S serial ports on the Host O/S before I start the virtual machine, then the virtual machine will start successfully.

So perhaps Virtualbox is not initializing the serial ports but Putty does....?

comment:11 Changed 4 years ago by frank

  • Component changed from other to uart

comment:12 Changed 4 years ago by zerobase

I am experiencing the same behaviour here as Gallandro.

Host: Ubuntu Maverick x64, running a VM that needs two serial ports. Run a ckermit session on the serial port and the VM boots up ok.

comment:13 Changed 4 years ago by jcrc

Running VirtualBox 3.2.10 r66523 on Ubuntu 10.10 (non-OSE) installed via apt from the virtualbox.org apt repository.

VM guest OS is Windows XP.

When starting my VM, if a serial port is enabled, the VM freezes at 0% while "Starting virtual machine..." If no serial port enabled, it starts ok.

My serial settings are: Port 1 Enabled COM1 Host Device /dev/ttyUSB0 (a usb-serial adapter)

comment:14 Changed 3 years ago by skotti

One more of the useful "same here" postings. Ubuntu 10.10 with VBox 3.2.8 and 3.2.10 using a USB-Serial adapter (Prolific PL2303).

comment:15 Changed 3 years ago by areversat

Same here : Ubuntu 10.10, virtualbox 3.2.8_OSE r64453, PL2303. The interesting thing is as mentioned before if you initialize the serial port using something else (in my case minicom) the VM does boot but I haven't been able to use the serial port.

comment:16 Changed 3 years ago by areversat

Actually it does work once it's been initialized with minicom.

comment:17 Changed 3 years ago by frank

Unfortunately I still cannot reproduce the problem although I cannot test a PCMCIA adapter here. I tested a normal "bare metal" serial interface as well as a USB-to-serial converter. I never saw the VM hang during startup.

And the core dump of pva was unfortunately not that helpful because getting the correct backtrace on a Gentoo host is not that easy. So if someone on a Linux host (Ubuntu, Debian, Fedora, openSUSE) can still reproduce this problem with VBox 3.2.10 please create a  core dump of the hanging VM process and make it available to me (frank _dot_ mehnert _at_ oracle _dot_ com). I can even tell you an FTP server where you can upload the core dump.

comment:18 Changed 3 years ago by pva

frank, I never had any problems to get correct backtrace on Gentoo and having symbols for all packages at hand I'm not sure why it's bad. Could you explain what's broken so I could try to fix it on my end?

comment:19 Changed 3 years ago by jcrc

Frank, I sent you a core dump (Ubuntu 10.10 64 , VirtualBox 3.2.10 , USB adapter) by e-mail

comment:20 Changed 3 years ago by frank

pva, what I intended to say is that I cannot easily recreate your Gentoo environment here. But I need the complete environment including the debug symbols for the involved Linux packages (I have the symbols for the VBox packages of course).

comment:21 Changed 3 years ago by frank

Thanks José Carlos and Antoine for the core dumps, these are more useful for me.

comment:22 Changed 3 years ago by frank

Hmm, the backtraces clearly show that the VM process is currently trying to open /dev/ttyUSB0. Will investigate if we can circumvent blocking here.

comment:23 Changed 3 years ago by frank

  • Summary changed from VirtualBox guest freezes while starting at 0% if serial ports are enabled to VirtualBox guest freezes while starting at 0% if serial ports are enabled => Fixed in SVN

Finally I was able to reproduce this issue with such an USB-to-serial adapter on Ubuntu. The same adapter works without any issue on a Debian system on the same hardware. I think I've fixed the issue, the fix will be available with the next maintenance release.

comment:24 Changed 3 years ago by Emerson Prado

Frank, I have the same issue with a PCI-to-serial adapter (NetMos 9835), in a Linux Mint Debian Edition host. Is there any information I could send that would matter? For the record: My VM sometimes work if I never enable USB in the VM settings. A workaround that works sometimes: delete the VM (backup first!), keeping the virtual disk, create a new VM using that virtual disk and change settings as needed before installing the guest OS. My guest OS is Windows 2000 SP4. Best regards

("NetMos" became a hyperlink for reasons beyond my understanding. It points to nothing.)

comment:25 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use