VirtualBox

Ticket #5372 (reopened defect)

Opened 4 years ago

Last modified 4 years ago

Maximize causes incorrect guest resolution at startup

Reported by: whoisrich Owned by:
Priority: major Component: GUI
Version: VirtualBox 3.1.4 Keywords: resolution startup maximize xp ubuntu
Cc: Guest type: other
Host type: Windows

Description

Problem:

When the guest window is maximized, at next reboot, the window is maximized but the guest O/S within is not, leaving a large border around the guest O/S.

You then have to restore ( un-maximize ) the window, and maximize again to get the guest O/S to set itself to the correct resolution.

When you have a normal ( un-maximized ) window set roughly the same size, the problem does not occur, the guest O/S resolution is restored at next reboot.

How to re-create:

  • Maximize guest O/S window
  • Shutdown guest O/S
  • Startup guest O/S

Additional:

Host maximized resolution is 1650x1050 Host is Windows XP but may also affect other host O/S. Guest O/S are Windows XP and Ubuntu, probably affects other guest O/S.

Screenshots of the problem are attached.

Attachments

startup_resolution_windows_xp.png Download (25.1 KB) - added by whoisrich 4 years ago.
startup_resolution_ubuntu.png Download (191.7 KB) - added by whoisrich 4 years ago.
VBox Boot - Remaximize - Reboot.log Download (42.4 KB) - added by whoisrich 4 years ago.
VBox 3.1.4 March 2010.log Download (60.8 KB) - added by whoisrich 4 years ago.
VM log on a fresh install of 3.1.4

Change History

Changed 4 years ago by whoisrich

Changed 4 years ago by whoisrich

comment:1 Changed 4 years ago by whoisrich

This is still an issue in 3.0.12

Some further information:

Once both the window and the guest O/S is maximized, if you reboot the guest O/S it will have the correct resolution on the next start-up.

This makes it unlikely to be a Guest Additions problem, and more likely that the parent window gets it's own size wrong when first starting maximized.

Changed 4 years ago by whoisrich

comment:2 Changed 4 years ago by whoisrich

Added a fresh log, started with window maximized, re-maximized, then rebooted.

Screen is 1650x1050, on start up it says:

handleDisplayResize(): uScreenId = 0, pvVRAM=05e00000 w=1152 h=864

After the restore and re-maximize it says:

handleDisplayResize(): uScreenId = 0, pvVRAM=05e00000 w=1680 h=941

comment:3 Changed 4 years ago by finex

I confirm this bug.

It is reproducible with Linux as host. For example Linux host and WinXP guest.

comment:4 Changed 4 years ago by finex

This but looks be a duplicate of  http://www.virtualbox.org/ticket/3004 Anyway I suggest to mark  http://www.virtualbox.org/ticket/3004 as a duplicate of this bug because this one describes better the bug.

comment:5 Changed 4 years ago by finex

comment:6 Changed 4 years ago by finex

Other to old bugs similar (or probably exactly this) are:

 http://www.virtualbox.org/ticket/1584

and

 http://www.virtualbox.org/ticket/1779

comment:7 Changed 4 years ago by michael

I marked

#2039

and

#3004

as duplicates. I don't think that the other two were.

comment:8 Changed 4 years ago by michael

finex: you might want to test this with 3.1 beta 2 and the Guest Additions there. It at least seems to work here with the current revision of VBox.

comment:9 Changed 4 years ago by whoisrich

I just tried 'VirtualBox-3.1.0_BETA2-55019-Win.exe' from the forum, with the included 'Guest Additions 3.1.0r55019' and the problem still remains for me.

comment:10 Changed 4 years ago by eFloh

The current version 3.1 (stable) still has this effect. Additionally, the auto size feature does not work when switching to full screen mode. The virtual resolutions stays the same, I get black bars at the top and bottom of the (fullscreen) virtual machine.

comment:11 Changed 4 years ago by whoisrich

Also confirm that it's still an issue with 3.1.0 Final, using XP and Windows 7 as host.

comment:12 Changed 4 years ago by HipHoppity

Whoisrich,

I ran into this very problem with VirtualBox 3.1.2 on my Mac OSX Host with WinXP Guest. While looking for solutions, I came across your Bug Tracker ticket. You've done a nice job describing the problem.

I posted the issue recently to the Mac OSX Host forum and looks like we have found a couple of ways of resolving this problem.

Check out the thread here =>  http://forums.virtualbox.org/viewtopic.php?f=8&t=26050

I realize you're on a Windows Host and the fix might have slightly different steps. Let me know if this works for you!

Best Wishes,

Hip Hoppity

comment:13 Changed 4 years ago by whoisrich

I did not have an entry for "GUI/MaxGuestResolution" so added it, and tried:

<ExtraDataItem name="GUI/MaxGuestResolution" value="auto"/> <ExtraDataItem name="GUI/MaxGuestResolution" value="any"/> <ExtraDataItem name="GUI/MaxGuestResolution" value="1920,1080"/>

But sadly none of them affected the guest resolution.

comment:14 Changed 4 years ago by HipHoppity

Whoisrich,

Sorry to hear editing your VirtualBox.xml file didn't fix the fullscreen resolution problem for your case.

Some of the Mac OSX users have had luck sending the commands from the command line (using the Terminal utility). Perhaps sending the command:

VBoxManage setextradata global GUI/MaxGuestResolution any

from the command line on your Host machine will give you back your fullscreen resolution of your Guests after restart?

Good luck with your continued efforts on this bug.

comment:15 Changed 4 years ago by whoisrich

Yes that worked ! :D

Also now realise that I did the manual editing wrong, I mis-understood virtualbox.xml to be the virtual machine XML, when infact it meant:

c:\users\USERNAME\.virtualbox\virtualbox.xml c:\documents and settings\USERNAME\.virtualbox\virtualbox.xml

So thank you HipHoppity.

comment:16 Changed 4 years ago by HipHoppity

Whoisrich,

Excellent -- glad that worked for you!

Hopefully this info will help the developers locate the source of this bug . . .

comment:17 Changed 4 years ago by frank

  • Component changed from other to GUI
  • Summary changed from Maximize causes incorrect guest resolution at startup to Maximize causes incorrect guest resolution at startup (GUI/MaxGuestResolution)

comment:18 Changed 4 years ago by frank

  • Summary changed from Maximize causes incorrect guest resolution at startup (GUI/MaxGuestResolution) to Maximize causes incorrect guest resolution at startup => Fixed in 3.1.4

VBox 3.1.4 Beta 2 will contain a better fix.

comment:19 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:20 Changed 4 years ago by whoisrich

  • Status changed from closed to reopened
  • Resolution fixed deleted

I am re-opening as this has not been fixed, and borders now re-appear when you reboot a correctly maximized guest.

  • Fresh install of Windows 7 64 Bit
  • Virtualbox 3.1.4 with fresh machine config.
  • 1920x1080 Host Resolution.

Attaching the VM log where it is started, window restored, window maximized, rebooted, window restored, window maximized, shutdown.

My C:\Users\Logon\.VirtualBox\VirtualBox.xml had no 'MaxGuestResolution' entry. Manually adding the entry with a value of 'any' once again fixed the problem.

Changed 4 years ago by whoisrich

VM log on a fresh install of 3.1.4

comment:21 Changed 4 years ago by frank

  • Version changed from VirtualBox 3.0.10 to VirtualBox 3.1.4
  • Summary changed from Maximize causes incorrect guest resolution at startup => Fixed in 3.1.4 to Maximize causes incorrect guest resolution at startup

comment:22 Changed 4 years ago by seenjhon

Thanks for sharing...

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use