VirtualBox

Ticket #5730 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

VBox GUI Crash on Copy Paste

Reported by: Technologov Owned by:
Priority: critical Component: GUI
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: other
Host type: Windows

Description

This is about VBox Qt4 GUI, and it happens even when no VMs are running.

Forum topic:  http://forums.virtualbox.org/viewtopic.php?f=15&t=24733

Crash happens on Windows 7/x64 host with VBox 3.1.0. This ugly bug (Qt?) results in crash of VBox GUI and corrupts clipboard in Windows host.

Steps to reproduce: (sometimes reproducible)

  1. Create a new VM named "Fedora07 32-bit SMP" (type from keyboard; something long with spaces)
  1. Copy it (VM settings->General->Name field->select->ctrl+C)
  1. Create a new VM named "Fedora07 32-bit SMP" (paste it, Ctrl+V)

VBox GUI will freeze, when trying to press "X", it will Crash.

NOTE: The problem begins with Copy --- if you paste it to Windows Notepad (after step 2), nothing will be pasted. Basically it zeroes Windows Host Clipboard. But if the source is text copied from Windows Notepad, then step 3 will succeed. It seems that Qt crashes when zero-size clipboard string is pasted into it.

This is basically 2 bugs:

  1. Copy results in zero-size clipboard string
  2. Paste of zero-size clipboard string results in VBox GUI crash.

Bug 1 was not reproducible on RHEL 5/x64 and Windows XP hosts. So I can't test Bug 2.

Is there a way to artificially create zero-size clipboard strings on other host platforms?

-Technologov, 11.12.2009.

Change History

comment:1 Changed 4 years ago by Technologov

This also happens with Vista 32-bit host.

comment:2 Changed 4 years ago by Technologov

This bug is duplicate of bug #4491

-Technologov

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use