VirtualBox

Ticket #5731 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Guest additions don't work for fedora 12 kernel 2.6.31.6-162.fc12-x86-64 -> fixed after 3.1.2

Reported by: tcharl Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Hi, I'm having an issue when installing VBoxLinuxAddition-amd64. Black screen appears with a lightning underscore (but when I press ctrl-alt-f2 I can access the console). startx command tells me that VBox1 is available but no modes is set. I removed guestadditions so I can't reproduce the problem and post the Xorg.0.log.

Attachments

Xorg.0.log.txt Download (10.3 KB) - added by tcharl 4 years ago.

Change History

comment:1 Changed 4 years ago by tcharl

If you insists, I can do it for sure ;)

comment:2 Changed 4 years ago by tcharl

It neither work with 2.6.31.6-166-fc12.x86_64

The error when I type startx: (EE) open /dev/fb0: no such file or directory (EE) VBoxVideo(0): output VBOX1 enabled but has no modes (EE) VBoxVideo(0): Initial CRTC configuration failed (EE) Screens found, but none have usable configuration.

Fatal server error: no screens found

comment:3 Changed 4 years ago by michael

It would indeed be helpful if you could attach (not copy and paste :) ) Xorg.0.log and xorg.conf from the guest to this ticket.

comment:4 Changed 4 years ago by Technologov

Guest Additions for standard kernel Fedora 12 (both i686 and x64) work perfectly.

See:  http://forums.virtualbox.org/viewtopic.php?f=1&t=25735

-Technologov

comment:5 Changed 4 years ago by tcharl

Find attached my Xorg.0.log, what do you think about this?

Changed 4 years ago by tcharl

comment:6 Changed 4 years ago by michael

tcharl: how much video RAM did you allocate to the guest? If it is less than 12MB, could you try increasing it?

comment:7 Changed 4 years ago by tcharl

128MB

comment:8 Changed 4 years ago by tcharl

Général Nom:

Serveur de collaboration Système:

Fedora (64 bit) Système Mémoire de base:

2000 Mo Processeur(s):

2 Ordre d'amorçage:

Disque dur, Disque optique, Réseau VT-x/AMD-V:

Activée Pagination enchevêtrée:

Désactivée Affichage Mémoire vive vidéo:

128 Mo Accélération 3D:

Désactivée Accélération graphique 2D:

Désactivée Serveur d'affichage distant (RDP):

Désactivé Stockage IDE Controller

IDE primaire maître:

Serveur de collaboration.vdi (Normal, 52,44 GB)

IDE secondaire maître:

VBoxGuestAdditions.iso (32,21 MB) Floppy Controller

Périphérique disquette 0:

Vide Son Pilote hôte:

Windows DirectSound Contrôleur:

ICH AC97 Réseau Carte 1:

PCnet-PCI II (Pont avec l'interface MAC Bridge Miniport)

comment:9 Changed 4 years ago by tcharl

Hi,

I solved my issue,

  • Installing system-config-display
    yum install system-config-display }}}
     * running the command
    {{{
    system-config-display }}}
     * Choosing custom display settings and configuring video card driver with the vendor one.
    
    Cheers, 
    }}}
    

comment:10 Changed 4 years ago by michael

Ticket #5842 has been marked a duplicate of this one.

comment:11 Changed 4 years ago by michael

I have reproduced this and fixed it locally. It is a result of the guest screen size sanity check not quite working as it should and rejecting the saved screen size from the last session.

comment:12 Changed 4 years ago by michael

  • Summary changed from Guest additions don't work for fedora 12 kernel 2.6.31.6-162.fc12-x86-64 to Guest additions don't work for fedora 12 kernel 2.6.31.6-162.fc12-x86-64 -> fixed after 3.1.2

Committed the fix for this.

comment:13 Changed 4 years ago by michael

Ticket #6071 has been marked a duplicate of this one.

comment:14 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use