VirtualBox

Ticket #5584 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

VBoxSharedClipboardClass hang - no guest paste, VBoxSVC - excessive CPU -> Additions installation problem

Reported by: sbenotreally Owned by:
Priority: major Component: clipboard
Version: VirtualBox 3.0.12 Keywords: VBoxSharedClipboardClass VBoxSVC cpu supdrvIOCtlFast VBoxDrvLinuxIOCtl
Cc: Guest type: Windows
Host type: Linux

Description

VBoxSharedClipboardClass hang - no guest paste, VBoxSVC - excessive CPU

possible related:
http://www.virtualbox.org/ticket/503  : Clipboard / VBoxSharedClipboardClass blocks -> fixed in SVN/1.5.2
http://www.virtualbox.org/ticket/3755 : shared clipboard is not working in VB 2.2.0
http://www.virtualbox.org/ticket/5266 : Shared Clipboard stops working

Did this ever work?
Yes, virtualbox 3.0.8
Fails after upgrade to 3.0.12
never tried 3.0.10

Were there other system changes that might have had an effect on this issue?
Yes.
apt-get update
during the upgrade to 3.0.12
many packages were updated.

Is this reproducable?
Yes, can reproduce at will.

Reproduction and sequence:
1. boot linux host
2. boot vm: windows xp sp3 guest
3. host: copy some text
4. guest: paste the text

expected:  text is pasted
actual:    
a. no text is pasted
b. excessive CPU usage
c. excessive system temperature


5. shutdown guest usinng start / ....
6. guest shut down hangs with message box ( screenshot: clipboard.shutdown.screenshot.png )
   end program - VBoxSharedClipboardClass
   this program is not responding
   end now / cancel
7. end now
8. guest shutdown again, which seems successful in the VirtualBox GUI
9. host still excessive CPU usage, excessive CPU temperature:
top - 08:32:56 up 6 days, 10:44,  1 user,  load average: 1.01, 1.06, 1.21
Tasks: 1066 total,   1 running, 1065 sleeping,   0 stopped,   0 zombie
Cpu(s):  2.0%us,  1.0%sy, 97.1%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   2065556k total,   916588k used,  1148968k free,    10416k buffers
Swap:  4192880k total,  1271528k used,  2921352k free,   154000k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
31307 root      20   0 21916 3884 2636 S 96.0  0.2 929:18.35 VBoxSVC
25186 root      20   0  2904 1736  880 R  1.3  0.1   0:15.82 top
 1901 root      20   0  782m  92m  14m S  0.7  4.6 114:13.42 firefox-bin

Linux sys1 2.6.27-1-mepis-smp #1 SMP PREEMPT Sat Mar 28 21:24:54 EDT 2009 i686 GNU/Linux

10. find pids of virtualbox proccesses
:~# pidof VirtualBox
31277
:~# pidof VBoxSVC
31307

11. attempt to get dump
kill -4 31277

12. can't find dump anywhere

13. /var/log/messages has this 1 time per second since Step 4 (paste):

messages:Nov 27 13:33:42 sys1 kernel: [<f924e752>] supdrvIOCtlFast+0x41/0x53 [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e11f>] VBoxDrvLinuxIOCtl+0x31/0x16b [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e0ee>] VBoxDrvLinuxIOCtl+0x0/0x16b [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e752>] supdrvIOCtlFast+0x41/0x53 [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e11f>] VBoxDrvLinuxIOCtl+0x31/0x16b [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e0ee>] VBoxDrvLinuxIOCtl+0x0/0x16b [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e752>] supdrvIOCtlFast+0x41/0x53 [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e11f>] VBoxDrvLinuxIOCtl+0x31/0x16b [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e0ee>] VBoxDrvLinuxIOCtl+0x0/0x16b [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e752>] supdrvIOCtlFast+0x41/0x53 [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e11f>] VBoxDrvLinuxIOCtl+0x31/0x16b [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e0ee>] VBoxDrvLinuxIOCtl+0x0/0x16b [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e752>] supdrvIOCtlFast+0x41/0x53 [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e11f>] VBoxDrvLinuxIOCtl+0x31/0x16b [vboxdrv]
messages:Nov 27 13:33:42 sys1 kernel: [<f924e0ee>] VBoxDrvLinuxIOCtl+0x0/0x16b [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e752>] supdrvIOCtlFast+0x41/0x53 [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e11f>] VBoxDrvLinuxIOCtl+0x31/0x16b [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e0ee>] VBoxDrvLinuxIOCtl+0x0/0x16b [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e752>] supdrvIOCtlFast+0x41/0x53 [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e11f>] VBoxDrvLinuxIOCtl+0x31/0x16b [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e0ee>] VBoxDrvLinuxIOCtl+0x0/0x16b [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e752>] supdrvIOCtlFast+0x41/0x53 [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e11f>] VBoxDrvLinuxIOCtl+0x31/0x16b [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e0ee>] VBoxDrvLinuxIOCtl+0x0/0x16b [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e752>] supdrvIOCtlFast+0x41/0x53 [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e11f>] VBoxDrvLinuxIOCtl+0x31/0x16b [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e0ee>] VBoxDrvLinuxIOCtl+0x0/0x16b [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e752>] supdrvIOCtlFast+0x41/0x53 [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e11f>] VBoxDrvLinuxIOCtl+0x31/0x16b [vboxdrv]
messages:Nov 27 13:33:43 sys1 kernel: [<f924e0ee>] VBoxDrvLinuxIOCtl+0x0/0x16b [vboxdrv]

Attachments

VBox.log Download (66.5 KB) - added by sbenotreally 4 years ago.
VBox.log
VBox.2.log Download (53.1 KB) - added by sbenotreally 4 years ago.
VBox.log after VBOX_RELEASE_LOG=shared_clipboard.e.l.l2.l3.f

Change History

Changed 4 years ago by sbenotreally

VBox.log

comment:1 follow-up: ↓ 2 Changed 4 years ago by michael

If you run VirtualBox with the following environment variable set, you will get a lot more logging about what the shared clipboard is doing:

VBOX_RELEASE_LOG=shared_clipboard.e.l.l2.l3.f

I wonder though whether the clipboard problem is a symptom of something else, as VBoxSVC shouldn't have anything to do with the shared clipboard.

comment:2 in reply to: ↑ 1 Changed 4 years ago by sbenotreally

OK. Here is the log. I ran these commands to get it:

VBOX_RELEASE_LOG=shared_clipboard.e.l.l2.l3.f VirtualBox

Changed 4 years ago by sbenotreally

VBox.log after VBOX_RELEASE_LOG=shared_clipboard.e.l.l2.l3.f

comment:3 Changed 4 years ago by michael

Either the additional logging didn't work for some reason or there is no shared clipboard activity whatsoever in the guest. Could you try re-installing the Guest Additions?

comment:4 Changed 4 years ago by sbenotreally

Re-installed Guest Additions as follows:
1. remove Guest Additions 3.0.12
2. reboot guest
3. install Guest Additions 3.0.12
4. reboot guest

Symptoms no longer reproducible.
This problem seems fixed, unless you want to refer it to another queue for treatment as a problem during upgrade.

Thank you!

comment:5 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid
  • Summary changed from VBoxSharedClipboardClass hang - no guest paste, VBoxSVC - excessive CPU to VBoxSharedClipboardClass hang - no guest paste, VBoxSVC - excessive CPU -> Additions installation problem

Thanks for the feedback. I will close this then. Please re-open if it reoccurs.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use