VirtualBox

Ticket #5549 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

clipboard not working -> middle-button-copy not supported by design

Reported by: omergrigg Owned by:
Priority: major Component: clipboard
Version: VirtualBox 3.0.12 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Hello, I have the newest virtualbox version installed on a 64-bit Win7 pro machine. I have a VectorLinux 6.0 Lite VDI as a guest (I downloaded it from virtualboximages).

Copy/Paste doesn't work, never has. bidirectional clipboard is enabled. Any help?

Thanks

Attachments

clipboard log Download (63.4 KB) - added by michael 4 years ago.
Log previously pasted by omergrigg

Change History

comment:1 Changed 4 years ago by michael

Could you please attach a log file from a run of the VM? And did you install the Guest Additions?

comment:2 Changed 4 years ago by omergrigg

I'd gladly do it, if you could tell me how to create a log file...

comment:3 Changed 4 years ago by frank

omergrigg, I've deleted your pasted log file as it was completely unreadable. Please use the ATTACH button to attach the file, do never copy'n'paste log files.

comment:4 Changed 4 years ago by michael

I copied and pasted the log file into a text file and attached it. I had to run it through an html stripper, so it may not be perfect, but it is an improvement.

Changed 4 years ago by michael

Log previously pasted by omergrigg

comment:5 follow-up: ↓ 6 Changed 4 years ago by michael

omergrigg: please make sure that you are doing Ctrl-C, Ctrl-V copy and paste in the guest, and not the middle-mouse-button sort.

Could you try the following in the guest: kill the "VBoxClient --clipboard" daemon and restart it (as user, not root) by typing the following into a console window:

$ VBOX_RELEASE_LOG_DEST=file=clipboard.log VBOX_RELEASE_LOG=+shared_clipboard.e.l.l2.l3.f VBoxClient --clipboard -d

and then trying some copying and pasting? That should create a log file in the guest called "clipboard.log", which you can attach to this defect.

comment:6 in reply to: ↑ 5 Changed 4 years ago by omergrigg

Replying to michael: How do I kill the ""VBoxClient --clipboard" daemon" ?

omergrigg: please make sure that you are doing Ctrl-C, Ctrl-V copy and paste in the guest, and not the middle-mouse-button sort.

Could you try the following in the guest: kill the "VBoxClient --clipboard" daemon and restart it (as user, not root) by typing the following into a console window:

$ VBOX_RELEASE_LOG_DEST=file=clipboard.log VBOX_RELEASE_LOG=+shared_clipboard.e.l.l2.l3.f VBoxClient --clipboard -d

and then trying some copying and pasting? That should create a log file in the guest called "clipboard.log", which you can attach to this defect.

comment:7 Changed 4 years ago by michael

You can use the command

$ ps ax | grep VBoxClient

to find the right process ID for it, and then use the "kill" command with that process ID.

comment:8 Changed 4 years ago by omergrigg

I ran the ps command - there was no process called "VBoxClient" "3412 pts/0 S+ 0:00 grep VBoxClient". (What's the specific syntax for the kill command?) I ran the command "VBOX_RELEASE...." that you wrote and something started happening (the command prompt disappeared but never came back). After a while I just ctrl+c it. I don't know where clipboard.log should be located.

comment:9 Changed 4 years ago by michael

OK, try running just

$ VBoxClient --clipboard

and see if things work after that. Probably your Linux guest doesn't support the normal methods of starting service applications for X window.

comment:10 Changed 4 years ago by omergrigg

OK! So I ran the command you said "VBoxClient --clipboard" - and now I can copy/paste from my host (win7) to the guest (vectorlinux lite) but not the other way... at least we're getting somewhere. My virtualbox clipboard is set to "bidirectional", BTW. I really need it to work both ways, though...

comment:11 Changed 4 years ago by michael

You *did* read what I wrote about Ctrl-C, Ctrl-V versus middle-button copy and paste, didn't you?

comment:12 Changed 4 years ago by omergrigg

Ctrl-C / Ctrl-V doesn't work at all inside the guest, just middle-button. There's no menu in the terminal as well.

comment:13 Changed 4 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

I will have to close this as "invalid", I'm afraid. A couple of words of explanation below though.

Most modern X11 applications support Ctrl-C + Ctrl-V copy and paste. (In official X11 terminology, this is the "clipboard", and the middle-button thing is the "primary selection"). Sharing the primary selection with a Windows host would be rather problematic, as Windows doesn't have the same concept (and people would get very annoyed if their Windows clipboard got lost every time they selected something in X11), so we only share the clipboard. For convenience we do cheat a bit and set the primary selection if something is copied at the other end. This is close to what would happen in X11, as normally when you copy something into the clipboard you have to select if first anyway.

And it seems that your Linux distribution does not automatically start the shared clipboard guest service. To work around this, you could add the line "/usr/bin/VBoxClient-all" to the file .xinitrc in your home directory on the guest.

comment:14 Changed 4 years ago by michael

  • Summary changed from clipboard not working to clipboard not working -> middle-button-copy not supported by design
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use