VirtualBox

Ticket #5550 (closed defect: wontfix)

Opened 4 years ago

Last modified 4 years ago

On OSX CMD-R is mapped to restarting the virtual machine

Reported by: bcardarella Owned by:
Priority: trivial Component: other
Version: VirtualBox 3.0.12 Keywords: restart refresh
Cc: Guest type: other
Host type: other

Description

This is more of an annoyance than a bug.

On OSX CMD-R is commonly used to refresh the state of an app. For example, in Safari and Firefox, refreshing the page. As a web developer hitting CMD-R is more muscle memory for me more so than probably any other command combination. So when I use VirtualBox with Windows and IE I something hit CMD-R by habit to refresh the browser. And this restarts the virtual machine.

IMO mapping CMD-R to restart the virtual machine was a poor choice.

Change History

comment:1 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to wontfix

Sorry, but I don't see what the problem is. Just change the host key if you don't like this combination. On top of that reboot asks for a confirmation (unless you chose to turn that off before).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use